summaryrefslogtreecommitdiff
path: root/app-accessibility/epos/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-accessibility/epos/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-accessibility/epos/files')
-rw-r--r--app-accessibility/epos/files/README.gentoo2
-rw-r--r--app-accessibility/epos/files/epos-2.5.37-disable-tests.patch16
-rw-r--r--app-accessibility/epos/files/epos-2.5.37-gcc43.patch23
-rw-r--r--app-accessibility/epos/files/epos-2.5.37-gcc45.patch15
-rw-r--r--app-accessibility/epos/files/epos-2.5.37-gcc47.patch16
-rw-r--r--app-accessibility/epos/files/eposd20
6 files changed, 92 insertions, 0 deletions
diff --git a/app-accessibility/epos/files/README.gentoo b/app-accessibility/epos/files/README.gentoo
new file mode 100644
index 000000000000..a058564ea278
--- /dev/null
+++ b/app-accessibility/epos/files/README.gentoo
@@ -0,0 +1,2 @@
+Due to /usr/bin/say conflicting with the speech-dispatcher ebuild, it has
+beenn moved to /usr/bin/epos_say.
diff --git a/app-accessibility/epos/files/epos-2.5.37-disable-tests.patch b/app-accessibility/epos/files/epos-2.5.37-disable-tests.patch
new file mode 100644
index 000000000000..a877ca68486b
--- /dev/null
+++ b/app-accessibility/epos/files/epos-2.5.37-disable-tests.patch
@@ -0,0 +1,16 @@
+diff -uNr epos-2.5.37.org/src/tests/Makefile.am epos-2.5.37/src/tests/Makefile.am
+--- epos-2.5.37.org/src/tests/Makefile.am 2012-04-14 00:38:56.000000000 -0400
++++ epos-2.5.37/src/tests/Makefile.am 2012-04-14 00:39:10.000000000 -0400
+@@ -1,11 +1,9 @@
+ ## Process this file with automake run in the top directory to yield Makefile.in
+
+ TESTS=hard_zero_data_test \
+- intr_test \
+- legal_data_test long_data_test long_strm_test \
++ legal_data_test long_data_test \
+ random_data_test \
+ soft_zero_data_test \
+- syn2_test \
+ vogon_test \
+ shutdown_test
+
diff --git a/app-accessibility/epos/files/epos-2.5.37-gcc43.patch b/app-accessibility/epos/files/epos-2.5.37-gcc43.patch
new file mode 100644
index 000000000000..4a61b5ffd04b
--- /dev/null
+++ b/app-accessibility/epos/files/epos-2.5.37-gcc43.patch
@@ -0,0 +1,23 @@
+--- epos-2.5.37.orig/src/nnet/neural.cc
++++ epos-2.5.37/src/nnet/neural.cc
+@@ -38,7 +38,7 @@
+ #include <string.h>
+ #include <ctype.h>
+ #include <stdlib.h>
+-#include <iostream.h>
++#include <iostream>
+ #include <time.h>
+
+ /*
+--- epos-2.5.37.orig/arch/win/service/install.cpp
++++ epos-2.5.37/arch/win/service/install.cpp
+@@ -23,7 +23,7 @@
+ #include <winsvc.h>
+ #include "service.h"
+ #include <stdio.h> //sprintf & fopen
+-#include <iostream.h>
++#include <iostream>
+ #include "Shlwapi.h"
+
+ SC_HANDLE scm;
+
diff --git a/app-accessibility/epos/files/epos-2.5.37-gcc45.patch b/app-accessibility/epos/files/epos-2.5.37-gcc45.patch
new file mode 100644
index 000000000000..70af1db94407
--- /dev/null
+++ b/app-accessibility/epos/files/epos-2.5.37-gcc45.patch
@@ -0,0 +1,15 @@
+Fixing build with gcc 4.5
+
+http://bugs.gentoo.org/show_bug.cgi?id=318585
+
+--- src/nnet/neural_parse.yy
++++ src/nnet/neural_parse.yy
+@@ -255,7 +255,7 @@
+
+ int yyerror (char *s)
+ {
+- shriek (812, fmt ("BISON:yyerror:bison_nnet parser: bison_row %i (not counting empty rows) '%s' is erroneous. %s\n", row_num, bison_row_buf, s));
++ shriek (812, fmt ("BISON:yyerror:bison_nnet parser: bison_row %i (not counting empty rows) '%s' is erroneous. %s\n", row_num, bison_row_buf.c_str(), s));
+ return -1;
+ }
+
diff --git a/app-accessibility/epos/files/epos-2.5.37-gcc47.patch b/app-accessibility/epos/files/epos-2.5.37-gcc47.patch
new file mode 100644
index 000000000000..6e795e3548a9
--- /dev/null
+++ b/app-accessibility/epos/files/epos-2.5.37-gcc47.patch
@@ -0,0 +1,16 @@
+ https://bugs.gentoo.org/440354
+
+ src/nnet/map.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/src/nnet/map.h
++++ b/src/nnet/map.h
+@@ -25,7 +25,7 @@ T2 & TMap<T1,T2>::operator [] (const T1 &key) {
+ else {
+ TData x;
+ x.first() = key;
+- return insert (x)->second();
++ return this->insert (x)->second();
+ }
+ }
+
diff --git a/app-accessibility/epos/files/eposd b/app-accessibility/epos/files/eposd
new file mode 100644
index 000000000000..75aca32ca8ba
--- /dev/null
+++ b/app-accessibility/epos/files/eposd
@@ -0,0 +1,20 @@
+#!/sbin/openrc-run
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ use alsasound esound
+}
+
+start() {
+ ebegin "Starting eposd"
+ start-stop-daemon --start --quiet --background --make-pidfile --pidfile /var/run/eposd.pid \
+ --exec /usr/bin/eposd -- -f
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping eposd"
+ start-stop-daemon --stop --quiet --pidfile /var/run/eposd.pid
+ eend $?
+}