summaryrefslogtreecommitdiff
path: root/app-accessibility/epos/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-accessibility/epos/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-accessibility/epos/files')
-rw-r--r--app-accessibility/epos/files/README.gentoo2
-rw-r--r--app-accessibility/epos/files/epos-2.5.37-disable-tests.patch15
-rw-r--r--app-accessibility/epos/files/epos-2.5.37-gcc43.patch23
-rw-r--r--app-accessibility/epos/files/epos-2.5.37-gcc45.patch15
-rw-r--r--app-accessibility/epos/files/epos-2.5.37-gcc47.patch16
-rw-r--r--app-accessibility/epos/files/epos-2.5.37-gcc7.patch22
-rw-r--r--app-accessibility/epos/files/eposd20
7 files changed, 113 insertions, 0 deletions
diff --git a/app-accessibility/epos/files/README.gentoo b/app-accessibility/epos/files/README.gentoo
new file mode 100644
index 000000000000..a058564ea278
--- /dev/null
+++ b/app-accessibility/epos/files/README.gentoo
@@ -0,0 +1,2 @@
+Due to /usr/bin/say conflicting with the speech-dispatcher ebuild, it has
+beenn moved to /usr/bin/epos_say.
diff --git a/app-accessibility/epos/files/epos-2.5.37-disable-tests.patch b/app-accessibility/epos/files/epos-2.5.37-disable-tests.patch
new file mode 100644
index 000000000000..7556e7995a15
--- /dev/null
+++ b/app-accessibility/epos/files/epos-2.5.37-disable-tests.patch
@@ -0,0 +1,15 @@
+--- a/src/tests/Makefile.am
++++ b/src/tests/Makefile.am
+@@ -1,11 +1,9 @@
+ ## Process this file with automake run in the top directory to yield Makefile.in
+
+ TESTS=hard_zero_data_test \
+- intr_test \
+- legal_data_test long_data_test long_strm_test \
++ legal_data_test long_data_test \
+ random_data_test \
+ soft_zero_data_test \
+- syn2_test \
+ vogon_test \
+ shutdown_test
+
diff --git a/app-accessibility/epos/files/epos-2.5.37-gcc43.patch b/app-accessibility/epos/files/epos-2.5.37-gcc43.patch
new file mode 100644
index 000000000000..c8b1dee857ad
--- /dev/null
+++ b/app-accessibility/epos/files/epos-2.5.37-gcc43.patch
@@ -0,0 +1,23 @@
+--- a/src/nnet/neural.cc
++++ b/src/nnet/neural.cc
+@@ -38,7 +38,7 @@
+ #include <string.h>
+ #include <ctype.h>
+ #include <stdlib.h>
+-#include <iostream.h>
++#include <iostream>
+ #include <time.h>
+
+ /*
+--- a/arch/win/service/install.cpp
++++ b/arch/win/service/install.cpp
+@@ -23,7 +23,7 @@
+ #include <winsvc.h>
+ #include "service.h"
+ #include <stdio.h> //sprintf & fopen
+-#include <iostream.h>
++#include <iostream>
+ #include "Shlwapi.h"
+
+ SC_HANDLE scm;
+
diff --git a/app-accessibility/epos/files/epos-2.5.37-gcc45.patch b/app-accessibility/epos/files/epos-2.5.37-gcc45.patch
new file mode 100644
index 000000000000..cbc056dded9f
--- /dev/null
+++ b/app-accessibility/epos/files/epos-2.5.37-gcc45.patch
@@ -0,0 +1,15 @@
+Fixing build with gcc 4.5
+
+http://bugs.gentoo.org/show_bug.cgi?id=318585
+
+--- a/src/nnet/neural_parse.yy
++++ b/src/nnet/neural_parse.yy
+@@ -255,7 +255,7 @@
+
+ int yyerror (char *s)
+ {
+- shriek (812, fmt ("BISON:yyerror:bison_nnet parser: bison_row %i (not counting empty rows) '%s' is erroneous. %s\n", row_num, bison_row_buf, s));
++ shriek (812, fmt ("BISON:yyerror:bison_nnet parser: bison_row %i (not counting empty rows) '%s' is erroneous. %s\n", row_num, bison_row_buf.c_str(), s));
+ return -1;
+ }
+
diff --git a/app-accessibility/epos/files/epos-2.5.37-gcc47.patch b/app-accessibility/epos/files/epos-2.5.37-gcc47.patch
new file mode 100644
index 000000000000..6e795e3548a9
--- /dev/null
+++ b/app-accessibility/epos/files/epos-2.5.37-gcc47.patch
@@ -0,0 +1,16 @@
+ https://bugs.gentoo.org/440354
+
+ src/nnet/map.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/src/nnet/map.h
++++ b/src/nnet/map.h
+@@ -25,7 +25,7 @@ T2 & TMap<T1,T2>::operator [] (const T1 &key) {
+ else {
+ TData x;
+ x.first() = key;
+- return insert (x)->second();
++ return this->insert (x)->second();
+ }
+ }
+
diff --git a/app-accessibility/epos/files/epos-2.5.37-gcc7.patch b/app-accessibility/epos/files/epos-2.5.37-gcc7.patch
new file mode 100644
index 000000000000..6c889a662c2a
--- /dev/null
+++ b/app-accessibility/epos/files/epos-2.5.37-gcc7.patch
@@ -0,0 +1,22 @@
+Bug: https://bugs.gentoo.org/638596
+
+--- a/src/nnet/matrix.cc
++++ b/src/nnet/matrix.cc
+@@ -63,7 +63,7 @@
+ template<class T> void CMatrix<T>::multiplyByTransponed (const CMatrix &y, CMatrix &retval)
+ {
+ int i,j,k;
+- assert (cols == y.cols);
++ this->assert (cols == y.cols);
+ if (cols != y.cols) { retval.Realloc (0,0); return; }
+
+ T sum;
+@@ -80,7 +80,7 @@
+ template<class T> void CMatrix<T>::transponedMultiply (const CMatrix &y, CMatrix &retval)
+ {
+ int i,j,k;
+- assert (rows == y.rows);
++ this->assert (rows == y.rows);
+ if (rows != y.rows) { retval.Realloc (0,0); return; }
+
+ T sum;
diff --git a/app-accessibility/epos/files/eposd b/app-accessibility/epos/files/eposd
new file mode 100644
index 000000000000..75aca32ca8ba
--- /dev/null
+++ b/app-accessibility/epos/files/eposd
@@ -0,0 +1,20 @@
+#!/sbin/openrc-run
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ use alsasound esound
+}
+
+start() {
+ ebegin "Starting eposd"
+ start-stop-daemon --start --quiet --background --make-pidfile --pidfile /var/run/eposd.pid \
+ --exec /usr/bin/eposd -- -f
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping eposd"
+ start-stop-daemon --stop --quiet --pidfile /var/run/eposd.pid
+ eend $?
+}