summaryrefslogtreecommitdiff
path: root/app-accessibility/espeak-ng
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /app-accessibility/espeak-ng
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'app-accessibility/espeak-ng')
-rw-r--r--app-accessibility/espeak-ng/Manifest1
-rw-r--r--app-accessibility/espeak-ng/espeak-ng-9999.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/app-accessibility/espeak-ng/Manifest b/app-accessibility/espeak-ng/Manifest
index 611a1fe24713..46ef11b3e15c 100644
--- a/app-accessibility/espeak-ng/Manifest
+++ b/app-accessibility/espeak-ng/Manifest
@@ -1,3 +1,4 @@
DIST espeak-ng-1.50.tar.gz 13665536 BLAKE2B c64c2a474374d4b6fe13bf3a99f5dfb661923c13ebd6c0bc323e7f26d9d90945c7075cc5c8f4b51e5db3303632c8c9daca7a65a1883e09d7c3faf63dd725ea3f SHA512 297dd80a6cdae3e2b8acf6823475220ce89d6a5fb68ea303156ad52cb3e7388049b6921759d4ed4e3d2e2ebd19bf931259e454f74a2ac0b7ecf4ce56c1d60c0c
EBUILD espeak-ng-1.50.ebuild 1677 BLAKE2B 715736244fe38b41dcc89bc43c324fdc2298648c8e7e862f738b2a380786520862d28906cf38f53af38ad2066879527fb3386b7f373d09bd07a0c8e9a88cf009 SHA512 88c03f6c0e98e2c9fe5bccc99f2f8da2d7923b6ecc88147651180af58e58a53dfe42ecab14afc06b042fe62d1149cc4a30d452e340882b8bdb02a74156111e98
+EBUILD espeak-ng-9999.ebuild 1643 BLAKE2B c37bf379661ac3fdaf2bc6078868de82d57620dcbb0ce101065f28e275c985dbf034481bb7544dbf6858e1bd283f077f4f6eac01a2dc97b3333a2ea78e315c21 SHA512 1dc4ec1cfb1b317cfe645ba7f30a09689d00bad68f367d74e4564626535f564493f890cf26efc1738b8df084fc68b94a3a31407ff3eade05c1f189fc836105c4
MISC metadata.xml 958 BLAKE2B 53575e74a7bee6def4121686f918e22d1143be5004b75426ec24be70209b6521b39a64200210f002e6936845bd461d13cf4dac70b99998d1e7fb299ae30ec923 SHA512 189ad2db25f9cc75948c11d13fe7271eaf5e386253a72c8d831ee9b5a9fa277723828e07ccc95e0be432ad3544ed45030596ea5ec74eb4436d012c13a636eeff
diff --git a/app-accessibility/espeak-ng/espeak-ng-9999.ebuild b/app-accessibility/espeak-ng/espeak-ng-9999.ebuild
new file mode 100644
index 000000000000..941edd1d327b
--- /dev/null
+++ b/app-accessibility/espeak-ng/espeak-ng-9999.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Software speech synthesizer for English, and some other languages"
+HOMEPAGE="https://github.com/espeak-ng/espeak-ng"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/espeak-ng/espeak-ng.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/espeak-ng/espeak-ng/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+ Turkowski unicode"
+SLOT="0"
+IUSE="+async +klatt l10n_ru l10n_zh man mbrola +sound"
+
+COMMON_DEPEND="
+ !app-accessibility/espeak
+ mbrola? ( app-accessibility/mbrola )
+ sound? ( media-libs/pcaudiolib )
+"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}
+ sound? ( media-sound/sox )
+"
+BDEPEND="
+ virtual/pkgconfig
+ man? ( app-text/ronn )
+"
+
+DOCS=( CHANGELOG.md README.md docs )
+
+src_prepare() {
+ default
+
+ # disable failing tests
+ rm tests/{language-pronunciation,translate}.test || die
+ sed -i \
+ -e "/language-pronunciation.check/d" \
+ -e "/translate.check/d" \
+ Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local econf_args
+ econf_args=(
+ $(use_with async)
+ $(use_with klatt)
+ $(use_with l10n_ru extdict-ru)
+ $(use_with l10n_zh extdict-cmn)
+ $(use_with l10n_zh extdict-yue)
+ $(use_with mbrola)
+ $(use_with sound pcaudiolib)
+ --without-libfuzzer
+ --without-sonic
+ --disable-rpath
+ --disable-static
+ )
+ econf "${econf_args[@]}"
+}
+
+src_compile() {
+ # see docs/building.md
+ emake -j1
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ emake DESTDIR="${D}" VIMDIR=/usr/share/vimfiles install
+ rm "${ED}"/usr/lib*/*.la || die
+}