summaryrefslogtreecommitdiff
path: root/app-accessibility/orca
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-accessibility/orca
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-accessibility/orca')
-rw-r--r--app-accessibility/orca/Manifest3
-rw-r--r--app-accessibility/orca/metadata.xml18
-rw-r--r--app-accessibility/orca/orca-3.24.0.ebuild72
3 files changed, 93 insertions, 0 deletions
diff --git a/app-accessibility/orca/Manifest b/app-accessibility/orca/Manifest
new file mode 100644
index 000000000000..5353f3f146a9
--- /dev/null
+++ b/app-accessibility/orca/Manifest
@@ -0,0 +1,3 @@
+DIST orca-3.24.0.tar.xz 2391740 BLAKE2B 1f294bc8e1c593690c511f0d7d660230c420b33de59c8b1e78ee8d7b16f973b9fff9ce4d656de7202ffd5789ae3604d030c442e8c35eecfd5c5dca058031e996 SHA512 9aa65b534f69bb4a1b800e715776416843ac3756ec1267feca3c66476e34e54f6744f70c0f8ac8868a009d38b6cc165267268491a9ad29ebbd3601dba09d424c
+EBUILD orca-3.24.0.ebuild 1878 BLAKE2B f3831feb7b8d95a3c4291b0a97048f58baea95ffb94793de3c25b8ff5ae4944c5a42297efb3b6802cda6e8ccdd29f15855a8520b8b3a847cf95f34d835a9470c SHA512 6437a256bf980f50cc766029959400c829b6a48f8c10b89a377b42e98cac3cade2022d7dba836512dc7af00a702d0b69b92eae21adbec53a03c05f0744adb01f
+MISC metadata.xml 640 BLAKE2B 490290dba5378d6599afa55e56780f99333b32ce71d0ca17f241c9e87c9d7ae19f3e0656c059bb841dd707df66b330da7ff860f3c0b1eb221de552227ba4ca06 SHA512 6fd5af9a57c21a72a37740f458947dce9a54e378ce5b602c9443d954ed536792cfa74299a69d02a2b0d81905a892d5b2d43f93678367ce7e039aa350c882cbb8
diff --git a/app-accessibility/orca/metadata.xml b/app-accessibility/orca/metadata.xml
new file mode 100644
index 000000000000..81828abc6360
--- /dev/null
+++ b/app-accessibility/orca/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+<use>
+ <flag name="braille">Enable braille support</flag>
+</use>
+<longdescription>
+ Orca is a flexible, extensible, and powerful assistive technology
+ for people with visual impairments. Using various combinations of
+ speech synthesis, braille, and magnification, Orca helps provide
+ access to applications and toolkits that support the AT-SPI (e.g.,
+ the GNOME desktop).
+</longdescription>
+</pkgmetadata>
diff --git a/app-accessibility/orca/orca-3.24.0.ebuild b/app-accessibility/orca/orca-3.24.0.ebuild
new file mode 100644
index 000000000000..216575e26152
--- /dev/null
+++ b/app-accessibility/orca/orca-3.24.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_REQ_USE="threads"
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-atk-2.12:2
+ >=app-accessibility/at-spi2-core-2.12:2[introspection]
+ >=dev-libs/atk-2.10
+ >=dev-libs/glib-2.28:2
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.10:3[${PYTHON_USEDEP}]
+ media-libs/gstreamer:1.0[introspection]
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ braille? (
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+ dev-libs/liblouis[python,${PYTHON_USEDEP}] )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+ dev-libs/atk[introspection]
+ dev-python/pyatspi[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.50
+ dev-util/itstool
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_prepare() {
+ gnome2_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure \
+ $(use_with braille liblouis)
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_install() {
+ installing() {
+ gnome2_src_install
+ # Massage shebang to make python_doscript happy
+ sed -e 's:#!'"${PYTHON}:#!/usr/bin/python:" \
+ -i src/orca/orca || die
+ python_doscript src/orca/orca
+ }
+ python_foreach_impl run_in_build_dir installing
+}