summaryrefslogtreecommitdiff
path: root/app-accessibility/orca
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /app-accessibility/orca
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'app-accessibility/orca')
-rw-r--r--app-accessibility/orca/Manifest2
-rw-r--r--app-accessibility/orca/orca-3.32.0.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/app-accessibility/orca/Manifest b/app-accessibility/orca/Manifest
index 7b7086fcb102..df3b6a0dfc66 100644
--- a/app-accessibility/orca/Manifest
+++ b/app-accessibility/orca/Manifest
@@ -1,3 +1,5 @@
DIST orca-3.30.2.tar.xz 2493112 BLAKE2B 06ac902f67c66d5098be1829aa7cb7a160663a3a713d407a5245a95215c309f3b374937e4b70acbf9750f6e0e270ed8ab5516ca3cb6b0a19f347ee72a01a325b SHA512 146a132ce06f7f36d6d9397c507ea767be5df6c47a5c7485c35c325868ebc0b3ff7b3653572be82f6d5ed937033cd6d68a08700056a63e5691aed4c9171b3485
+DIST orca-3.32.0.tar.xz 2512032 BLAKE2B eae6c726e5e7361b7d60f0907f8c62c476895d681cf424940586e6308bcde147094a9557243aae6ecffef142bd556cb3cb30839955403e0958f123672400bf0a SHA512 015aa26ddaffa53d646e5d708ffed9e771beebbe925c27b963cbd3c3a2b36f730c0668cac6b89a371cd81cf8a570eb591711ba923fa4d013e00e31667749cf20
EBUILD orca-3.30.2.ebuild 1446 BLAKE2B 3010b048faeac7f3c2bdfa672e5ac90eb53580e01a1edd67e041516f7e2dc504ca1c09d129ac5e83f325e9826f972255bf93e1c2794add44c2eef7d21ef7b2a0 SHA512 92d2e15ea35f9df2a5c8d63ea28da129b615a6984235085fa24c34c6d0545c50e05730ecda152223b15b2a00355daa50fd733d1c91e736f66f36163ddbe68e15
+EBUILD orca-3.32.0.ebuild 1448 BLAKE2B 8d37f2bbf2923dea97f40cf12a34789287509139bc2b33ecdbd82b8cd7610e52b0b5b86233ebefcb4b4216c97456e04d2043209a5b1f93337c7b65b06848cf62 SHA512 9469ed65cfb18f3f43bef2cfa1e9113fa9d9484c5a72e0ecd9e5fcbe29feb216857a01bde1aab8cd35135c19c704a66a8bb3e9cef537a4f40729606c61a73144
MISC metadata.xml 640 BLAKE2B 490290dba5378d6599afa55e56780f99333b32ce71d0ca17f241c9e87c9d7ae19f3e0656c059bb841dd707df66b330da7ff860f3c0b1eb221de552227ba4ca06 SHA512 6fd5af9a57c21a72a37740f458947dce9a54e378ce5b602c9443d954ed536792cfa74299a69d02a2b0d81905a892d5b2d43f93678367ce7e039aa350c882cbb8
diff --git a/app-accessibility/orca/orca-3.32.0.ebuild b/app-accessibility/orca/orca-3.32.0.ebuild
new file mode 100644
index 000000000000..62a38fbeb256
--- /dev/null
+++ b/app-accessibility/orca/orca-3.32.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_REQ_USE="threads"
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-atk-2.32:2
+ >=app-accessibility/at-spi2-core-2.32:2[introspection]
+ >=dev-libs/atk-2.32
+ >=dev-libs/glib-2.28:2
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.18:3[${PYTHON_USEDEP}]
+ media-libs/gstreamer:1.0[introspection]
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ braille? (
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+ dev-libs/liblouis[python,${PYTHON_USEDEP}] )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+ dev-libs/atk[introspection]
+ >=dev-python/pyatspi-2.32[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.50
+ dev-util/itstool
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_with braille liblouis)
+}