summaryrefslogtreecommitdiff
path: root/app-accessibility/speech-dispatcher
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-11 01:49:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-11 01:49:36 +0000
commitcf7807d7aea23a99a144afceaba961cfed652b5f (patch)
treeffd2c781c27e0b7e72152a685a04938a2b7966f0 /app-accessibility/speech-dispatcher
parent7c5ebaf83da4c538dd11b56fdd5dfdf39dcbc096 (diff)
gentoo auto-resync : 11:03:2025 - 01:49:36
Diffstat (limited to 'app-accessibility/speech-dispatcher')
-rw-r--r--app-accessibility/speech-dispatcher/Manifest4
-rw-r--r--app-accessibility/speech-dispatcher/metadata.xml3
-rw-r--r--app-accessibility/speech-dispatcher/speech-dispatcher-0.12.0.ebuild123
3 files changed, 129 insertions, 1 deletions
diff --git a/app-accessibility/speech-dispatcher/Manifest b/app-accessibility/speech-dispatcher/Manifest
index 2f5d5c271aa3..a8cba75788bf 100644
--- a/app-accessibility/speech-dispatcher/Manifest
+++ b/app-accessibility/speech-dispatcher/Manifest
@@ -1,3 +1,5 @@
DIST speech-dispatcher-0.11.5.tar.gz 7230756 BLAKE2B cacc0030489c17dcab4648c55e5b203f40d7a473be9a1ec0402e39fc8f853d30596caff4204052782ca562cc318363aa52118e6d375b5e9bf505ef7159129544 SHA512 d6d880bce0ae5bc2a5d519ef7740c689ae8b4b0bb658379762810e4beae3e465a429fbe19f7c490e89db0ea6a36aedd4b2287ac9251b90059b5c2cb3c0dd8a28
+DIST speech-dispatcher-0.12.0.tar.gz 7481967 BLAKE2B 091a4fcf3a5b1bd7af256cf311b702ea6d3dcf18900f24f04c7edd66d26eb535b442e16112c1eed2fc0867d88cb56b898c381989a0dccbf22816fe8242930d9f SHA512 684472c9410ca42f28873054613934ad93525aa5526b788dc4c2bba861aa6cb675826b9fc5083e013d25e0f23fe113691e11aa7aa9b1cebdca72abfa6119940c
EBUILD speech-dispatcher-0.11.5.ebuild 2802 BLAKE2B 3eca7c5e3b5641665271b3fd185902349ae6b6665747b8117bdd8700f4b382ca3f65dfd345f782e898e62be55b18ef13ec31e473c8def9bba8f8b89cc659aa83 SHA512 42931995d4fc27bb87138488057104a879d4503558d1ade38de34e2398c0f1b9a82e10c4bb678f946c4abd20c5ed924dd5c9cf0de46549597e6bc36df590371d
-MISC metadata.xml 721 BLAKE2B 926d97f613858988bb43ba292b45699cd0d2df876d05db38767296d1408d6f60580f32a019cd1541a517ad27606185d046838637ee4c4c27c6c70ced30d0d492 SHA512 22eeafb4e7bad9bdd96f5b950a5bbdd5259734b589bfb34876fe758a0779a5dda532b0bd696acf9da5ff124bb78e3b58d6787bd8bdc698879e34e6c8ed5bcd45
+EBUILD speech-dispatcher-0.12.0.ebuild 2934 BLAKE2B d86bf8fc68281b6c67538761529ed379d5dcd8bb1cadf54b3738cb2d6df57eaddb8e140471abffcc73faebe598693e52d39cdc8607988cbd73c911b048d7dd9b SHA512 a84dec4537cb49b5c3c95779b17ece10abb097eb861f9a6cc4cbc3cb2b130df4c3243b7145c80780728e2bd1bc482c0fe34ee6dbcd14fe6834637e5f22e6e24d
+MISC metadata.xml 866 BLAKE2B 8e27560bd30917223938589a7948fcd6e9d751bcbefd78ed909209a20c9434af0f6c229770521e1b396fabb5da2795490cca4c6bf4479448600bc7a49223f40a SHA512 42bda0bc725e75ab626e9888b25a30544f982dea11b33f0b629f19784270c62064582ab3044c1bc2013589936b4b90da43bd3d25c979c0f9ecdc938c41fa3f53
diff --git a/app-accessibility/speech-dispatcher/metadata.xml b/app-accessibility/speech-dispatcher/metadata.xml
index 506de2e0ba7d..a8f2cd1ec378 100644
--- a/app-accessibility/speech-dispatcher/metadata.xml
+++ b/app-accessibility/speech-dispatcher/metadata.xml
@@ -15,6 +15,9 @@
<use>
<flag name="espeak">Adds support for espeak-ng speech engine</flag>
<flag name="flite">Adds support for flite speech engine</flag>
+ <flag name="pipewire">
+ Enables support for PipeWire. Recommended for latency related advantages if it works in your setup.
+ </flag>
</use>
<upstream>
<remote-id type="github">brailcom/speechd</remote-id>
diff --git a/app-accessibility/speech-dispatcher/speech-dispatcher-0.12.0.ebuild b/app-accessibility/speech-dispatcher/speech-dispatcher-0.12.0.ebuild
new file mode 100644
index 000000000000..d7074e704c5a
--- /dev/null
+++ b/app-accessibility/speech-dispatcher/speech-dispatcher-0.12.0.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit flag-o-matic python-r1 systemd
+
+DESCRIPTION="Speech synthesis interface"
+HOMEPAGE="https://freebsoft.org/speechd"
+SRC_URI="https://github.com/brailcom/speechd/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="alsa ao +espeak flite nas pulseaudio pipewire +python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="python? ( ${PYTHON_DEPS} )
+ >=dev-libs/dotconf-1.3
+ >=dev-libs/glib-2.36:2
+ >=media-libs/libsndfile-1.0.2
+ alsa? ( media-libs/alsa-lib )
+ ao? ( media-libs/libao )
+ espeak? ( app-accessibility/espeak-ng )
+ flite? ( app-accessibility/flite )
+ nas? ( media-libs/nas )
+ pulseaudio? ( media-libs/libpulse )
+ pipewire? ( media-video/pipewire )"
+RDEPEND="${DEPEND}
+ python? ( dev-python/pyxdg[${PYTHON_USEDEP}] )"
+BDEPEND="
+ sys-apps/help2man
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig"
+
+src_configure() {
+ # bug #944193
+ append-cflags -std=gnu17
+
+ # bug 573732
+ export GIT_CEILING_DIRECTORIES="${WORKDIR}"
+
+ local myeconfargs=(
+ --disable-ltdl
+ --disable-python
+ --disable-static
+ --with-baratinoo=no
+ --with-ibmtts=no
+ --with-kali=no
+ --with-pico=no
+ --with-voxin=no
+ --with-espeak=no
+ $(use_with alsa)
+ $(use_with ao libao)
+ $(use_with espeak espeak-ng)
+ $(use_with flite)
+ $(use_with nas)
+ $(use_with pulseaudio pulse)
+ $(use_with pipewire)
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ use python && python_copy_sources
+
+ emake
+
+ if use python; then
+ building() {
+ cd src/api/python || die
+ emake \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)"
+ }
+ python_foreach_impl run_in_build_dir building
+ fi
+}
+
+src_install() {
+ default
+
+ if use python; then
+ installation() {
+ cd src/api/python || die
+ emake \
+ DESTDIR="${D}" \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)" \
+ install
+ }
+ python_foreach_impl run_in_build_dir installation
+ python_replicate_script "${ED}"/usr/bin/spd-conf
+ python_foreach_impl python_optimize
+ fi
+
+ find "${D}" -name '*.la' -type f -delete || die
+}
+
+pkg_postinst() {
+ local editconfig="n"
+ if ! use espeak; then
+ ewarn "You have disabled espeak-ng, which is speech-dispatcher's"
+ ewarn "default speech synthesizer."
+ ewarn
+ editconfig="y"
+ fi
+ if ! use pulseaudio; then
+ ewarn "You have disabled pulseaudio support."
+ ewarn "pulseaudio is speech-dispatcher's default audio subsystem."
+ ewarn
+ editconfig="y"
+ fi
+ if [[ "${editconfig}" == "y" ]]; then
+ ewarn "You must edit ${EROOT}/etc/speech-dispatcher/speechd.conf"
+ ewarn "and make sure the settings there match your system."
+ ewarn
+ fi
+}