summaryrefslogtreecommitdiff
path: root/app-accessibility/speech-dispatcher
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /app-accessibility/speech-dispatcher
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'app-accessibility/speech-dispatcher')
-rw-r--r--app-accessibility/speech-dispatcher/Manifest2
-rw-r--r--app-accessibility/speech-dispatcher/speech-dispatcher-0.8.1.ebuild109
2 files changed, 0 insertions, 111 deletions
diff --git a/app-accessibility/speech-dispatcher/Manifest b/app-accessibility/speech-dispatcher/Manifest
index d830c0a77aae..5721b1931c18 100644
--- a/app-accessibility/speech-dispatcher/Manifest
+++ b/app-accessibility/speech-dispatcher/Manifest
@@ -1,5 +1,3 @@
-DIST speech-dispatcher-0.8.1.tar.gz 1309969 BLAKE2B 225a7b6a134cf0c82b1e08f961bad87a509ae7b4a9948c1e548c84a325b86b70ee66cd52dabd560f6640682385ea826fa4e67ec762a3da223a14303ddfdae5c2 SHA512 35f1ae547001a45d7945406ae5672829ff9ab6ac3f0cccb9eb3670dd92888a63c7cc4270ee90b5a166e6788afe3b117b5c3ef62c41a9df9f9af94dc4e0948fe8
DIST speech-dispatcher-0.8.7.tar.gz 1333677 BLAKE2B 0b08f1a1228fe1240e14b3d52913f8fa64a1f2ee9b563294b49ea8d3e5cfd3041aa5572ec72354b360dabd2d263deb79e418b95b6174a5b89ee541e9fd23c7e2 SHA512 0e7af02e8521aa8d397ea4d0329f9a8d56970beed645456dfedc738ececd2ccd8ecfdf66e92ae852878a473ba991175e1d4dc2b8b0148c958163682b49678375
-EBUILD speech-dispatcher-0.8.1.ebuild 2672 BLAKE2B e4b66d157f2c8ffb0aec8d659281a357a75a7ffc25bb1ef3be81280e6f828e1bd649b048f5f45f4dbe732ed4a8e58b64fe0e172f5aa5849e02a5e7a35adbaf3e SHA512 877cd71ee96f436b45e19616209282db5ccd333ad6a00bda1dd214228e2235428d95c81d895f5afe43ff9ce97b024ce3d1628af2e228df4c41982e2eb71e2755
EBUILD speech-dispatcher-0.8.7.ebuild 2710 BLAKE2B ce416d9fcc75efe2c65d643720eff1d1dbb1382bab51019d204c023cada29beb467648715ef765ab7c0e4fdc62dcd2336c01a0786f26719a0149e6ffb635bf3e SHA512 33234a6574a0c7eba6846d5af3313848bea4fa33b8ed7dbcb412e4441a79b91b17bbbcc30756d149069563129ec3bbc56900cd4aa0d2f775033f63522b466567
MISC metadata.xml 632 BLAKE2B 2a60d2e822db36bf3f0547d97ccaad05d6bcce11afa71534b108358f1d71f857f200907f01c31c3083a5196e43eb681c06e2991a086c91731daced3f56282c2d SHA512 db94cba99bd2c9bbfe98b1647ac53a3861cbd697df791bea025e2a713a5991ca6929f2bc82a985ba38eef4a2571515d96aac6558fe143b68e24713490c12dd0a
diff --git a/app-accessibility/speech-dispatcher/speech-dispatcher-0.8.1.ebuild b/app-accessibility/speech-dispatcher/speech-dispatcher-0.8.1.ebuild
deleted file mode 100644
index 120aa60f8b4b..000000000000
--- a/app-accessibility/speech-dispatcher/speech-dispatcher-0.8.1.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_4 python3_5 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit eutils python-r1
-
-DESCRIPTION="Speech synthesis interface"
-HOMEPAGE="http://www.freebsoft.org/speechd"
-SRC_URI="http://www.freebsoft.org/pub/projects/speechd/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="alsa ao +espeak flite nas pulseaudio python static-libs"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-COMMON_DEPEND="python? ( ${PYTHON_DEPS} )
- >=dev-libs/dotconf-1.3
- >=dev-libs/glib-2.28:2
- >=media-libs/libsndfile-1.0.2
- alsa? ( media-libs/alsa-lib )
- ao? ( media-libs/libao )
- espeak? ( app-accessibility/espeak )
- flite? ( app-accessibility/flite )
- nas? ( media-libs/nas )
- pulseaudio? ( media-sound/pulseaudio )"
-DEPEND="${COMMON_DEPEND}
- >=dev-util/intltool-0.40.0
- virtual/pkgconfig"
-RDEPEND="${COMMON_DEPEND}
- python? ( dev-python/pyxdg[${PYTHON_USEDEP}] )"
-
-src_configure() {
- local myeconfargs=(
- --disable-python
- $(use_enable static-libs static)
- $(use_with alsa)
- $(use_with ao libao)
- $(use_with espeak)
- $(use_with flite)
- $(use_with pulseaudio pulse)
- $(use_with nas)
- )
- econf ${myeconfargs[@]}
-}
-
-src_compile() {
- use python && python_copy_sources
-
- emake
-
- if use python; then
- building() {
- cd src/api/python || die
- emake \
- pyexecdir="$(python_get_sitedir)" \
- pythondir="$(python_get_sitedir)"
- }
- python_foreach_impl run_in_build_dir building
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc ANNOUNCE AUTHORS BUGS ChangeLog FAQ NEWS README*
-
- prune_libtool_files --all
-
- if use python; then
- installation() {
- cd src/api/python || die
- emake \
- DESTDIR="${D}" \
- pyexecdir="$(python_get_sitedir)" \
- pythondir="$(python_get_sitedir)" \
- install
- }
- python_foreach_impl run_in_build_dir installation
- python_replicate_script "${ED}"/usr/bin/spd-conf
- fi
-}
-
-pkg_postinst() {
- local editconfig="n"
- if ! use espeak; then
- ewarn "You have disabled espeak, which is speech-dispatcher's"
- ewarn "default speech synthesizer."
- ewarn
- editconfig="y"
- fi
- if ! use pulseaudio; then
- ewarn "You have disabled pulseaudio support."
- ewarn "pulseaudio is speech-dispatcher's default audio subsystem."
- ewarn
- editconfig="y"
- fi
- if [[ "${editconfig}" == "y" ]]; then
- ewarn "You must edit ${EROOT}etc/speech-dispatcher/speechd.conf"
- ewarn "and make sure the settings there match your system."
- ewarn
- fi
- elog "For festival support, you need to"
- elog "install app-accessibility/festival-freebsoft-utils."
-}