summaryrefslogtreecommitdiff
path: root/app-accessibility/speech-dispatcher
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /app-accessibility/speech-dispatcher
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'app-accessibility/speech-dispatcher')
-rw-r--r--app-accessibility/speech-dispatcher/Manifest4
-rw-r--r--app-accessibility/speech-dispatcher/metadata.xml1
-rw-r--r--app-accessibility/speech-dispatcher/speech-dispatcher-0.11.1.ebuild117
3 files changed, 121 insertions, 1 deletions
diff --git a/app-accessibility/speech-dispatcher/Manifest b/app-accessibility/speech-dispatcher/Manifest
index 42993c5937ab..2e3867b7d1b1 100644
--- a/app-accessibility/speech-dispatcher/Manifest
+++ b/app-accessibility/speech-dispatcher/Manifest
@@ -1,4 +1,6 @@
AUX speech-dispatcher-0.9.1-fno-common.patch 13112 BLAKE2B 6a4125117852cfe250bed1a9936af67a2a83303ecced615febd89b9b14918dda94a78862cdcceb95fcea3ea7ed30a12d799afbc21264ff386c94f9f867eb8136 SHA512 b957ebbfd8a6a9cfe2b85cba85b77dc813e76212721d63d42b3881ed17993d7b4a8c720d4c431c8e2eb3ea60996e411402732c735948f37fa84a9fdcfa2683fc
+DIST speech-dispatcher-0.11.1.tar.gz 6548489 BLAKE2B fd4e05c51b80991bdd5d27ecf967946cfde98f978462e909f193c14eab51f3cae047d281c3e2896b3ddeeb4e045ceb72f51e5dbfaf3f9ea8a818f8146cb5e625 SHA512 859911d7db5660423bc7911eacbe8e7a9c3104df97478cbbca48ca5fd6ec018113172d49bc66781680433c77b4d2af43578c9b0f11409e2ba7ac618deb31d7cf
DIST speech-dispatcher-0.9.1.tar.gz 1662222 BLAKE2B 03c3d79a9cbbe7e549f638992fb276ab2270a45a057708721666257699479b3feb81daddf26d8032ba3f7b9ab6b836c7f582ee22a532ff018c99820af3864d87 SHA512 35adb353d22b8dff8884cb20f3836f96f4f74b272bbd442d522a10a3d3b91a0da6705e6c216764f295208b5446c2077da620de2a81cafe5a0c4dd826e33753c2
+EBUILD speech-dispatcher-0.11.1.ebuild 2780 BLAKE2B bd5a50f275810b40ab5dbe8cdafc4f02a9f9f75e3e54ce34c467a0b01cc7da55c1ac5b39f1106acaddb2371bb42b46008caea1a92d8f909e50347ceaa40b7ce9 SHA512 abf31bba90e083069c9a0382b6397553d492e4510dea624d02019346c95565910c0cb0149882ae4d3ee6eabb8bec51a8a356c306ad3037ba0a8eb160ab55eb50
EBUILD speech-dispatcher-0.9.1.ebuild 2835 BLAKE2B f840d158b1303532c3fd0f41f9e40bac941d06071a125bcbef0341e75cc0197fe29a47d495b8248bc714cf2f8da3981660b95aa91d8b178fb72a7c4a23303b51 SHA512 2e0e8b16492ee0922199389e05e7d24103d4090b218378ce3f50111705084515c112d9e363f6dabc6d10dee75e4bdbb5f7c794f4b7b6562baa11798f3dff0dc9
-MISC metadata.xml 633 BLAKE2B 02656914f79915c95b816db32c5196d5018a80967c1b21de3bac872528829975699a4a33c9dd5098db62b5ad7a3f23ddb12a9ad3317b70038428e027301eb8d4 SHA512 085016246af6554aa71ac1be359a3d9efef5610598edfbba986d3b8527ef5fc5fa0533552c58f3a103dda4d79d5cc6fe4d5697b22d46ae410a42ec2e87ec1b08
+MISC metadata.xml 708 BLAKE2B fdccc4d8de7f22eb64469021786480527bd87f3718dd5746426874266b8a46dcb6cc2b7bb25a4561a523362b919e0ed77e3f829f3fe269d90060d17a69f1b2ed SHA512 770e54e5ddeacc46165b90d41dd3ea0d1060adfdfb95055a9dab778f757189b892250e66b515773ce7b4d8b1bbdd692386b4d8cb49d670af7af8dadfed5c8788
diff --git a/app-accessibility/speech-dispatcher/metadata.xml b/app-accessibility/speech-dispatcher/metadata.xml
index 01aeb7337732..0f3199f11253 100644
--- a/app-accessibility/speech-dispatcher/metadata.xml
+++ b/app-accessibility/speech-dispatcher/metadata.xml
@@ -14,6 +14,7 @@
</maintainer>
<use>
<flag name="espeak">Adds support for espeak speech engine</flag>
+ <flag name="espeak-ng">Adds support for espeak-ng speech engine</flag>
<flag name="flite">Adds support for flite speech engine</flag>
</use>
</pkgmetadata>
diff --git a/app-accessibility/speech-dispatcher/speech-dispatcher-0.11.1.ebuild b/app-accessibility/speech-dispatcher/speech-dispatcher-0.11.1.ebuild
new file mode 100644
index 000000000000..ec934b5203c4
--- /dev/null
+++ b/app-accessibility/speech-dispatcher/speech-dispatcher-0.11.1.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit python-r1 systemd
+
+DESCRIPTION="Speech synthesis interface"
+HOMEPAGE="https://freebsoft.org/speechd"
+SRC_URI="https://github.com/brailcom/speechd/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="alsa ao espeak +espeak-ng flite nas pulseaudio python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="python? ( ${PYTHON_DEPS} )
+ >=dev-libs/dotconf-1.3
+ >=dev-libs/glib-2.36:2
+ dev-libs/libltdl:0
+ >=media-libs/libsndfile-1.0.2
+ alsa? ( media-libs/alsa-lib )
+ ao? ( media-libs/libao )
+ espeak? ( app-accessibility/espeak )
+ espeak-ng? ( app-accessibility/espeak-ng )
+ flite? ( app-accessibility/flite )
+ nas? ( media-libs/nas )
+ pulseaudio? ( media-sound/pulseaudio )"
+RDEPEND="${DEPEND}
+ python? ( dev-python/pyxdg[${PYTHON_USEDEP}] )"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig"
+
+src_configure() {
+ # bug 573732
+ export GIT_CEILING_DIRECTORIES="${WORKDIR}"
+
+ local myeconfargs=(
+ --disable-python
+ --disable-static
+ --with-baratinoo=no
+ --with-ibmtts=no
+ --with-kali=no
+ --with-pico=no
+ --with-voxin=no
+ $(use_with alsa)
+ $(use_with ao libao)
+ $(use_with espeak)
+ $(use_with espeak-ng)
+ $(use_with flite)
+ $(use_with nas)
+ $(use_with pulseaudio pulse)
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ use python && python_copy_sources
+
+ emake
+
+ if use python; then
+ building() {
+ cd src/api/python || die
+ emake \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)"
+ }
+ python_foreach_impl run_in_build_dir building
+ fi
+}
+
+src_install() {
+ default
+
+ if use python; then
+ installation() {
+ cd src/api/python || die
+ emake \
+ DESTDIR="${D}" \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)" \
+ install
+ }
+ python_foreach_impl run_in_build_dir installation
+ python_replicate_script "${ED}"/usr/bin/spd-conf
+ python_foreach_impl python_optimize
+ fi
+
+ find "${D}" -name '*.la' -type f -delete || die
+}
+
+pkg_postinst() {
+ local editconfig="n"
+ if ! use espeak-ng; then
+ ewarn "You have disabled espeak-ng, which is speech-dispatcher's"
+ ewarn "default speech synthesizer."
+ ewarn
+ editconfig="y"
+ fi
+ if ! use pulseaudio; then
+ ewarn "You have disabled pulseaudio support."
+ ewarn "pulseaudio is speech-dispatcher's default audio subsystem."
+ ewarn
+ editconfig="y"
+ fi
+ if [[ "${editconfig}" == "y" ]]; then
+ ewarn "You must edit ${EROOT}/etc/speech-dispatcher/speechd.conf"
+ ewarn "and make sure the settings there match your system."
+ ewarn
+ fi
+}