summaryrefslogtreecommitdiff
path: root/app-accessibility
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-10 11:05:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-10 11:05:14 +0100
commitfbbf0ee3d56a6fd27adf182c6907dc745623aeaa (patch)
tree2c2869a78e5e3b6af9391df951ca217cced4608d /app-accessibility
parent43297a4ed0a3760bbdd0b8c286b779f174ca5368 (diff)
gentoo auto-resync : 10:08:2024 - 11:05:14
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/Manifest.gzbin4563 -> 4557 bytes
-rw-r--r--app-accessibility/brltty/Manifest1
-rw-r--r--app-accessibility/brltty/brltty-6.6-r2.ebuild221
-rw-r--r--app-accessibility/orca/Manifest2
-rw-r--r--app-accessibility/orca/orca-46.2.ebuild61
-rw-r--r--app-accessibility/speech-dispatcher/Manifest2
-rw-r--r--app-accessibility/speech-dispatcher/speech-dispatcher-0.11.5.ebuild117
7 files changed, 404 insertions, 0 deletions
diff --git a/app-accessibility/Manifest.gz b/app-accessibility/Manifest.gz
index d867607c8a76..a2c9c9ec9737 100644
--- a/app-accessibility/Manifest.gz
+++ b/app-accessibility/Manifest.gz
Binary files differ
diff --git a/app-accessibility/brltty/Manifest b/app-accessibility/brltty/Manifest
index dea643bad055..29aee9336a2c 100644
--- a/app-accessibility/brltty/Manifest
+++ b/app-accessibility/brltty/Manifest
@@ -3,4 +3,5 @@ AUX brltty-6.6-cython3.patch 1594 BLAKE2B d18b09f888e688efb8a33c0de6cbde25956d10
AUX brltty.initd 241 BLAKE2B 80969e4840d2d38af6bc310ecf18e0253ef01667517135bc5a2f92e50882c2b72e8a4763b215c62ccbfd8d2250067b44ce9a4cb5d318dd6eb48b298826d8d5de SHA512 55ea97a546a2335ee1148396df71363442b66ed4526f8adb93e88c2cf489f10a21b5361658f590b3f64eec24844235491b15349bd0e1c4533fef7b1390fc3a6e
DIST brltty-6.6.tar.xz 3684592 BLAKE2B c1ae05b925384f3869d3c90ccc06197da2a592691830504ff01a530da87319d463e25cd7b387805c199562be815ca4e79f3679f592f3a1107025e3aba17ec159 SHA512 852bfd9179570be7b0da8b1279f84bdfedc14a319988d9c2eac5a20a9ce8977f31fdee167e8e96bb411184a1d72f4cdc633944c7b3f55bddae411fc71a9e6898
EBUILD brltty-6.6-r1.ebuild 5799 BLAKE2B 507821f81a50f205536ccaead2b4e23007ad2536a339b4e044bf2b3761bbfb78b4160758fda0c5142a818d61091c77ce6a62a515be445052fb2a1e35101b19b8 SHA512 ee88cf88581dd6ef95abdc4aee00d1b3c4a1760152d15a0c148a30511fb2cc5b56ee7661f7c5f4d7d53031b135d9c2ee3716f5b00e4bbf5d74cfe0d5eb2e9a52
+EBUILD brltty-6.6-r2.ebuild 5772 BLAKE2B 74e2bc6f01e6a96380a25f7489dc050cafb0edad9b2db22c9fa8cd6788e9894c40272b3e0ca2f60ab9b9dfc35e38e1e51bb1c0f86149a9b686057fe5a7286c07 SHA512 0188d51b003ba3c31af02e0334a7c9122a2a79bbe62ba3e81d50c5fa2e6a7573819aa4623879bf6d93f8fa9030f3535084ebcd1dd0ba37b08db1c4c78cd609d6
MISC metadata.xml 1596 BLAKE2B a0eb74542a3ad8ea8d36e269d9c0c9266b1dda440ff9c5a02b53f60c9b406e30c55d7ef58a2c49d02348b410515fb2b4ca5d36e152f006b9bab7445577441a6e SHA512 369c801ef0a8be96d66c2c163fa6000fcf35b49fd83a5521d93a6a2bac5da1f540c2fa977198fc651451959f804a9e3b3630ca8a0470231892861ed1d5cc5b6f
diff --git a/app-accessibility/brltty/brltty-6.6-r2.ebuild b/app-accessibility/brltty/brltty-6.6-r2.ebuild
new file mode 100644
index 000000000000..064030d6037b
--- /dev/null
+++ b/app-accessibility/brltty/brltty-6.6-r2.ebuild
@@ -0,0 +1,221 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+FINDLIB_USE="ocaml"
+JAVA_PKG_WANT_SOURCE="1.8"
+JAVA_PKG_WANT_TARGET="1.8"
+
+inherit findlib toolchain-funcs java-pkg-opt-2 autotools python-r1 tmpfiles
+
+DESCRIPTION="Daemon that provides access to the Linux/Unix console for a blind person"
+HOMEPAGE="https://brltty.app/"
+SRC_URI="https://brltty.app/archive/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+api +beeper bluetooth doc +fm gpm iconv icu
+ java louis +midi ncurses nls ocaml +pcm policykit python
+ usb systemd +speech tcl xml X"
+REQUIRED_USE="doc? ( api )
+ java? ( api )
+ ocaml? ( api )
+ python? ( api ${PYTHON_REQUIRED_USE} )
+ tcl? ( api )"
+
+DEPEND="
+ acct-group/brltty
+ acct-user/brltty
+ dev-libs/libpcre2[pcre32]
+ bluetooth? (
+ sys-apps/dbus
+ net-wireless/bluez
+ )
+ gpm? ( >=sys-libs/gpm-1.20 )
+ iconv? ( virtual/libiconv )
+ icu? ( dev-libs/icu:= )
+ java? ( >=virtual/jdk-1.8:* )
+ louis? ( dev-libs/liblouis:= )
+ midi? ( media-libs/alsa-lib )
+ ncurses? ( sys-libs/ncurses:0= )
+ pcm? ( media-libs/alsa-lib )
+ policykit? ( sys-auth/polkit )
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ )
+ speech? (
+ app-accessibility/espeak-ng
+ app-accessibility/flite
+ app-accessibility/speech-dispatcher
+ )
+ systemd? ( sys-apps/systemd )
+ tcl? ( >=dev-lang/tcl-8.6.13-r1:= )
+ usb? ( virtual/libusb:1 )
+ xml? ( dev-libs/expat )
+ X? (
+ app-accessibility/at-spi2-core:2
+ sys-apps/dbus
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXfixes
+ x11-libs/libXt
+ x11-libs/libXtst
+ )"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=dev-lang/tcl-8.6.13-r1
+ virtual/pkgconfig
+ nls? ( virtual/libintl )
+ python? ( dev-python/cython[${PYTHON_USEDEP}] )
+"
+
+HTML_DOCS=( "${S}"/Documents/Manual-BrlAPI/. )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.4-respect-AR.patch
+ "${FILESDIR}"/${P}-cython3.patch
+)
+
+src_prepare() {
+ default
+
+ java-pkg-opt-2_src_prepare
+
+ # We run eautoconf instead of using eautoreconf because brltty uses
+ # a custom build system that uses autoconf without the rest of the
+ # autotools.
+ eautoconf
+ use python && python_copy_sources
+}
+
+src_configure() {
+ tc-export AR LD PKG_CONFIG
+
+ export JAVAC=""
+ export JAVA_JNI_FLAGS=""
+ if use java; then
+ export JAVA_HOME="$(java-config -g JAVA_HOME)"
+ export JAVAC_HOME="${JAVA_HOME}/bin"
+ export JAVA_JNI_FLAGS="$(java-pkg_get-jni-cflags)"
+ export JAVAC="$(java-pkg_get-javac) -encoding UTF-8 $(java-pkg_javac-args)"
+ fi
+
+ # Override bindir for backward compatibility.
+ # Also override localstatedir so that the lib/brltty directory is installed
+ # correctly.
+ # Disable stripping since we do that ourselves.
+ local myconf=(
+ --bindir="${EPREFIX}"/bin
+ --htmldir="${EPREFIX}"/usr/share/doc/"${P}"/html
+ --localstatedir="${EPREFIX}"/var
+ --runstatedir="${EPREFIX}"/run
+ # the next two lines should be removed once support is added.
+ --disable-emacs-bindings
+ --disable-lua-bindings
+ # Python bindings are built separately per-impl
+ --disable-python-bindings
+ --disable-stripping
+ --with-updatable-directory="${EPREFIX}"/var/lib/brltty
+ --with-writable-directory="${EPREFIX}"/run/brltty
+ --with-privilege-parameters=lx:user=brltty
+ $(use_enable api)
+ $(use_with beeper beep-package)
+# $(use_enable emacs emacs-bindings)
+ $(use_with fm fm-package)
+ $(use_enable gpm)
+ $(use_enable iconv)
+ $(use_enable icu)
+ $(use_enable java java-bindings)
+ $(use_enable louis liblouis)
+# $(use_enable lua lua-bindings)
+ $(use_with midi midi-package)
+ $(use_enable nls i18n)
+ $(use_enable ocaml ocaml-bindings)
+ $(use_with pcm pcm-package)
+ $(use_enable policykit polkit)
+ $(use_enable speech speech-support)
+ $(use_with systemd service-package)
+ $(use_enable tcl tcl-bindings)
+ $(use_enable xml expat)
+ $(use_enable X x)
+ $(use_with bluetooth bluetooth-package)
+ $(use_with ncurses curses)
+ $(use_with usb usb-package)
+ )
+ # disable espeak since we use espeak-ng
+ use speech && myconf+=( --with-speech-driver=-es )
+
+ econf "${myconf[@]}"
+
+ if use python; then
+ python_configure() {
+ econf "${myconf[@]}" --enable-python-bindings PYTHON="${PYTHON}"
+ }
+ python_foreach_impl run_in_build_dir python_configure
+ fi
+}
+
+src_compile() {
+ emake -j1 JAVA_JNI_FLAGS="${JAVA_JNI_FLAGS}" JAVAC="${JAVAC}"
+
+ if use python; then
+ python_build() {
+ emake -C "${BUILD_DIR}"/Bindings/Python -j1
+ }
+ python_foreach_impl run_in_build_dir python_build
+ fi
+}
+
+src_install() {
+ if use ocaml; then
+ findlib_src_preinst
+ fi
+
+ emake -j1 INSTALL_ROOT="${D}" OCAML_LDCONF= install
+
+ if use python; then
+ python_install() {
+ emake -C "${BUILD_DIR}"/Bindings/Python -j1 INSTALL_ROOT="${D}" install
+ }
+ python_foreach_impl run_in_build_dir python_install
+ fi
+
+ if use java; then
+ java-pkg_doso Bindings/Java/libbrlapi_java.so
+ java-pkg_dojar Bindings/Java/brlapi.jar
+ fi
+
+ insinto /etc
+ doins Documents/brltty.conf
+ newinitd "${FILESDIR}"/brltty.initd brltty
+ emake -C Autostart/Systemd -j1 INSTALL_ROOT="${ED}" install
+ emake -C Autostart/Udev -j1 INSTALL_ROOT="${ED}" install
+
+ dodoc Documents/{CONTRIBUTORS,ChangeLog,HISTORY,README*,TODO}
+ if use doc; then
+ HTML_DOCS="doc/Manual-BRLTTY" einstalldocs
+ fi
+
+ keepdir /var/lib/BrlAPI
+ rm -fr "${ED}/run" || die
+ find "${ED}" -name '*.a' -delete || die
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+
+ elog "please be sure ${EROOT}/etc/brltty.conf is correct for your system."
+ elog
+ elog "To make brltty start on boot on an OpenRC system, type this command:"
+ elog "# rc-update add brltty boot"
+ elog
+ elog "If you are using systemd, type this command:"
+ elog "# systemctl daemon-reload"
+ elog
+ elog "Please reload udev by typing:"
+ elog "# udevadm control --reload"
+}
diff --git a/app-accessibility/orca/Manifest b/app-accessibility/orca/Manifest
index 050c975fe62b..5f51c08d147a 100644
--- a/app-accessibility/orca/Manifest
+++ b/app-accessibility/orca/Manifest
@@ -1,3 +1,5 @@
DIST orca-45.2.tar.xz 3997024 BLAKE2B dfdf113694127323a92450b04b20fcc5655be0236c0173167d5d15478703b676c3fd8c1de0e75783875c5d2d40541c764fb002314d66c7570475cd63f6bfa473 SHA512 57eee451cf0da52e1297beae6c6d527886721b23c3415a5e046f3431876fdf1603dbd81ca763ed614ace68e7db96d90b413c663f113d0033ec1f2797df7bf589
+DIST orca-46.2.tar.xz 3431952 BLAKE2B 56b8c31318ecfaf6acda365192e0dd70feb835e449ebe1e0c0292a2230c44659ddc4e9cf1fa87aba1694e3ba2c8c695754901c4a797720979af3a8143f0b0b00 SHA512 e55d5dba18b70ac2b70809f9e0af82e1fad8c72d9f3a7e03c6e4c1da29e133f80b3dabf9ad007873587b4b01a4ff36947e4ea38d7afd60748f8f98219a6a24e0
EBUILD orca-45.2-r1.ebuild 1560 BLAKE2B 13ac4e66c0ec8ed347d58136395b80950bb9d6998c0df013bcd5a826d7787b8d7bc6bc1da3a63f58f4148d26b9c9e6fa76efd5c3a0c2420d4d87f6049a388394 SHA512 382464711e1a2d921c9de5e2c410e02a322abcd22181bd82693e75960b957302fc101950e8ef70a29fafd1cb54bbd7fbf31d33f06b349e04c715a92a5649e338
+EBUILD orca-46.2.ebuild 1491 BLAKE2B 301563b199654581c5b89a2a2588e7178effc3db46fe6f1b5c5e98bb804b7c2af808f1ab6b534b88c0aa08055ba77afd0a02b933d604a577855556bfb2648dcf SHA512 ff35f88952c3e88e7e32887400ce5edd7b8c79d41cc9d8dfc92f816f891647e04ea64c031682069ccdfa0c61e9dacb21c813bcdea79d238405af3620463347f9
MISC metadata.xml 762 BLAKE2B fca9ee6ac93d2e860f6791af78380e9d8d29ac10b254299946911a29b5893028e561a18320bc026dd7e9421f3c572e1c3ac63264276a1b292996db93e1cba4a3 SHA512 6bbe0cff5af52cb48adccbb61620fd75a0811cad313867b63cb09b5a7c259230019a54ad607ee46c986188ff11ac2f6878ef20381ef34965dfe918c88ec945d0
diff --git a/app-accessibility/orca/orca-46.2.ebuild b/app-accessibility/orca/orca-46.2.ebuild
new file mode 100644
index 000000000000..5add1ce30b95
--- /dev/null
+++ b/app-accessibility/orca/orca-46.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit gnome2 meson python-single-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-core-2.50:2[introspection]
+ >=dev-libs/glib-2.28:2
+ media-libs/gstreamer:1.0[introspection]
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ $(python_gen_cond_dep '
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.18:3[${PYTHON_USEDEP}]
+ ')
+ braille? (
+ $(python_gen_cond_dep '
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+ dev-libs/liblouis[${PYTHON_SINGLE_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.46[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ ')
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_configure() {
+ local emesonargs=(
+ -Dspiel=false # spiel not yet in gentoo
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ python_optimize
+}
diff --git a/app-accessibility/speech-dispatcher/Manifest b/app-accessibility/speech-dispatcher/Manifest
index 8a181674e4df..4b6092d9f7e5 100644
--- a/app-accessibility/speech-dispatcher/Manifest
+++ b/app-accessibility/speech-dispatcher/Manifest
@@ -1,4 +1,6 @@
AUX speech-dispatcher-0.11.4-GNU_SOURCE.patch 3680 BLAKE2B 671b55d0418b92d299427fd2d457e3279f1ae9d97548dd1ff89b52a2487cd700c134e7bb042ae6b621883933d1b3c96765f6fc2ed040c0de4c7d97f017ad965f SHA512 d07edc73370fdb8d9c71f8cc9c9db15da8fe3b7d83ca42bd05a09fc4795899786e54436d7dbc8407ab08eb0384997126322352ed9d4c4250d41a11d0d68dd4b4
DIST speech-dispatcher-0.11.4.tar.gz 7127323 BLAKE2B 651a20ec403c6158756ab6ff7fbedb38ce1cec413be49367128274c8d20ccc7080a2dccd68cb7ebbec6bab05599f06a4aafc561e4e5e53cf52d19fa1b94fa286 SHA512 d0ebe832e2586abdb1284be36f8427cfbbd94f1a2dead1b74526b151e9529f9e61679339274b73afab5f829d184337372ba0aad93d880c42d2a6a1bcb2b7afef
+DIST speech-dispatcher-0.11.5.tar.gz 7230756 BLAKE2B cacc0030489c17dcab4648c55e5b203f40d7a473be9a1ec0402e39fc8f853d30596caff4204052782ca562cc318363aa52118e6d375b5e9bf505ef7159129544 SHA512 d6d880bce0ae5bc2a5d519ef7740c689ae8b4b0bb658379762810e4beae3e465a429fbe19f7c490e89db0ea6a36aedd4b2287ac9251b90059b5c2cb3c0dd8a28
EBUILD speech-dispatcher-0.11.4-r2.ebuild 2913 BLAKE2B 1b4b9f3c20215b0ca21e401386195bbfc178f6c2a1e4fbd2ca976a00b0a0f4555908620d841065630813610f36a7767e7baa320c4e4337d9bd08804340c0cb28 SHA512 c75ebd81b176f679f151b431a8148dee7c9ab9e1247adef39221744e57bebdeb8ffcb741ef6a230be6e23953d3f78fdf4043f0625a06cc85df5c49e3c8c2a05d
+EBUILD speech-dispatcher-0.11.5.ebuild 2760 BLAKE2B 7f31c7b09181aa29fc10564edd27ea639346e461a1e77966a18c974051d6e7d0bc7654fa80bb76e4ce752c9ca04d7299c7c25eab41322ec07dcfd814617e5f28 SHA512 76dac22ebf94dc9bbcac64c6d68d55b7f14c267a960e59a31b483a50fd5887954d2d8b3b06f68125595bc4f1be1b4021c8ef557936297b6501b2de8c609a3521
MISC metadata.xml 721 BLAKE2B 926d97f613858988bb43ba292b45699cd0d2df876d05db38767296d1408d6f60580f32a019cd1541a517ad27606185d046838637ee4c4c27c6c70ced30d0d492 SHA512 22eeafb4e7bad9bdd96f5b950a5bbdd5259734b589bfb34876fe758a0779a5dda532b0bd696acf9da5ff124bb78e3b58d6787bd8bdc698879e34e6c8ed5bcd45
diff --git a/app-accessibility/speech-dispatcher/speech-dispatcher-0.11.5.ebuild b/app-accessibility/speech-dispatcher/speech-dispatcher-0.11.5.ebuild
new file mode 100644
index 000000000000..60fd9d36a48e
--- /dev/null
+++ b/app-accessibility/speech-dispatcher/speech-dispatcher-0.11.5.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit python-r1 systemd
+
+DESCRIPTION="Speech synthesis interface"
+HOMEPAGE="https://freebsoft.org/speechd"
+SRC_URI="https://github.com/brailcom/speechd/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="alsa ao +espeak flite nas pulseaudio +python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="python? ( ${PYTHON_DEPS} )
+ >=dev-libs/dotconf-1.3
+ >=dev-libs/glib-2.36:2
+ >=media-libs/libsndfile-1.0.2
+ alsa? ( media-libs/alsa-lib )
+ ao? ( media-libs/libao )
+ espeak? ( app-accessibility/espeak-ng )
+ flite? ( app-accessibility/flite )
+ nas? ( media-libs/nas )
+ pulseaudio? ( media-libs/libpulse )"
+RDEPEND="${DEPEND}
+ python? ( dev-python/pyxdg[${PYTHON_USEDEP}] )"
+BDEPEND="
+ sys-apps/help2man
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig"
+
+src_configure() {
+ # bug 573732
+ export GIT_CEILING_DIRECTORIES="${WORKDIR}"
+
+ local myeconfargs=(
+ --disable-ltdl
+ --disable-python
+ --disable-static
+ --with-baratinoo=no
+ --with-ibmtts=no
+ --with-kali=no
+ --with-pico=no
+ --with-voxin=no
+ --with-espeak=no
+ $(use_with alsa)
+ $(use_with ao libao)
+ $(use_with espeak espeak-ng)
+ $(use_with flite)
+ $(use_with nas)
+ $(use_with pulseaudio pulse)
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ use python && python_copy_sources
+
+ emake
+
+ if use python; then
+ building() {
+ cd src/api/python || die
+ emake \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)"
+ }
+ python_foreach_impl run_in_build_dir building
+ fi
+}
+
+src_install() {
+ default
+
+ if use python; then
+ installation() {
+ cd src/api/python || die
+ emake \
+ DESTDIR="${D}" \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)" \
+ install
+ }
+ python_foreach_impl run_in_build_dir installation
+ python_replicate_script "${ED}"/usr/bin/spd-conf
+ python_foreach_impl python_optimize
+ fi
+
+ find "${D}" -name '*.la' -type f -delete || die
+}
+
+pkg_postinst() {
+ local editconfig="n"
+ if ! use espeak; then
+ ewarn "You have disabled espeak-ng, which is speech-dispatcher's"
+ ewarn "default speech synthesizer."
+ ewarn
+ editconfig="y"
+ fi
+ if ! use pulseaudio; then
+ ewarn "You have disabled pulseaudio support."
+ ewarn "pulseaudio is speech-dispatcher's default audio subsystem."
+ ewarn
+ editconfig="y"
+ fi
+ if [[ "${editconfig}" == "y" ]]; then
+ ewarn "You must edit ${EROOT}/etc/speech-dispatcher/speechd.conf"
+ ewarn "and make sure the settings there match your system."
+ ewarn
+ fi
+}