summaryrefslogtreecommitdiff
path: root/app-admin/ansible-base
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /app-admin/ansible-base
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'app-admin/ansible-base')
-rw-r--r--app-admin/ansible-base/Manifest5
-rw-r--r--app-admin/ansible-base/ansible-base-2.10.0.ebuild74
-rw-r--r--app-admin/ansible-base/ansible-base-2.10.1.ebuild74
-rw-r--r--app-admin/ansible-base/metadata.xml35
4 files changed, 188 insertions, 0 deletions
diff --git a/app-admin/ansible-base/Manifest b/app-admin/ansible-base/Manifest
new file mode 100644
index 000000000000..13f2d4c4cf16
--- /dev/null
+++ b/app-admin/ansible-base/Manifest
@@ -0,0 +1,5 @@
+DIST ansible-base-2.10.0.tar.gz 5775091 BLAKE2B 2a087b1a9d675c5218e8700f5b455ff280a5dc6e66b575a47755b9936c54594300e3c22acadbe14acfd335c3be788e3d63f6ad3c5c51650cbc036c77ceec41ef SHA512 f9e9631f9ce77e55b06d01814422cbc0ca170e3fbbbd5886e4f87065b68b4d7eefe1c782f6dce14241cc548192c7b06ef778446636be02a342d4bd112000126e
+DIST ansible-base-2.10.1.tar.gz 5980851 BLAKE2B 478c9ca6ebf423dea98830ed0447201dfb8db24f963f2fc849e0eab395611c1fb923c5060c397e12138c3e98d7118e367c4713f44ad07ca914e20c3044e74bba SHA512 77bc2f3f6b924299add7e3a57beaf4a0517b036027a785c177874ae6a07a06679de65770a296f81ab0022cb0b495f17e2ceb772f906172fbf46fb65609be1ce2
+EBUILD ansible-base-2.10.0.ebuild 1837 BLAKE2B be0a57437cefaeaf73ea7c3e1e51e0e537fbb84e3f33eeb49944c4ed4a1de1847e268048a0bb9514a564e51f09986d5d7f85017e898cac23700b9df5bed24e90 SHA512 6e62368737955d8fd9c9ab1aead4c7ae15ac9cde7636314348317e6d9b4059c39dd057d14b2de1e30a640f9a6aaddc2050290e4430f1ad7970bc035908de9b6d
+EBUILD ansible-base-2.10.1.ebuild 1839 BLAKE2B 0b9988118a4af77919bc62493f5857183670b9e8f9794f82b91a334099509f9ed26ae0021072efd5b815da792decded27d5d35ea0007cd80b72739063530d36e SHA512 68e107f805147a0adb738852ffabda2b7c1bedd73533d7b01ad169f49e793a2bce95462aa4d7dfb2f6f7a8738b0aca51bad9f761840d29fb80cbc66820b596d2
+MISC metadata.xml 1265 BLAKE2B 94811a3b6776a4ea3c775279b44101d9491871ad3f85fd023b40c3e3195f9b8ae9bb49fd10c3541774da693ec8520f0634888b32a5afaa2de99ccec1ad68d701 SHA512 19e505adfaebf46c83e92c8e5629fe18043a4bb33ef4b1b294234db89714bf8184f4922d5dbfbf5171c05505ef31d810de21da2fced98fa5536052108d29652b
diff --git a/app-admin/ansible-base/ansible-base-2.10.0.ebuild b/app-admin/ansible-base/ansible-base-2.10.0.ebuild
new file mode 100644
index 000000000000..3cc5cd35c7bb
--- /dev/null
+++ b/app-admin/ansible-base/ansible-base-2.10.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://ansible.com/"
+SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86 ~x64-macos"
+IUSE="doc test"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-notfound-page[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+python_compile() {
+ # disable version checks on upgrade
+ export ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+
+python_compile_all() {
+ if use doc; then
+ cd docs/docsite || die
+ export CPUS=4
+ emake -f Makefile.sphinx html
+ fi
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
+ distutils-r1_python_install_all
+
+ dodoc -r examples
+}
diff --git a/app-admin/ansible-base/ansible-base-2.10.1.ebuild b/app-admin/ansible-base/ansible-base-2.10.1.ebuild
new file mode 100644
index 000000000000..4abf588a0449
--- /dev/null
+++ b/app-admin/ansible-base/ansible-base-2.10.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://ansible.com/"
+SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+IUSE="doc test"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-notfound-page[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+python_compile() {
+ # disable version checks on upgrade
+ export ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+
+python_compile_all() {
+ if use doc; then
+ cd docs/docsite || die
+ export CPUS=4
+ emake -f Makefile.sphinx html
+ fi
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
+ distutils-r1_python_install_all
+
+ dodoc -r examples
+}
diff --git a/app-admin/ansible-base/metadata.xml b/app-admin/ansible-base/metadata.xml
new file mode 100644
index 000000000000..eb7c38b1c2e3
--- /dev/null
+++ b/app-admin/ansible-base/metadata.xml
@@ -0,0 +1,35 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>calchan@gentoo.org</email>
+ <name>Denis Dupeyron</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ <name>Patrice Clement</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">ansible-base</remote-id>
+ <remote-id type="github">ansible/ansible</remote-id>
+ <bugs-to>https://github.com/ansible/ansible/issues</bugs-to>
+ </upstream>
+ <longdescription lang="en">
+Radically simple deployment, model-driven configuration management, and
+command execution framework.
+
+This is a minimal installation of Ansible which contains the core programs,
+some documentation, and a tiny subset of modules and plugins to allow for a
+functioning controller. All other modules, including most of those
+bundled with in Ansible 2.9 and older, must be installed separately,
+e.g. from collections.
+</longdescription>
+</pkgmetadata>