summaryrefslogtreecommitdiff
path: root/app-admin/ansible-lint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /app-admin/ansible-lint
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'app-admin/ansible-lint')
-rw-r--r--app-admin/ansible-lint/Manifest2
-rw-r--r--app-admin/ansible-lint/ansible-lint-5.3.2.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/app-admin/ansible-lint/Manifest b/app-admin/ansible-lint/Manifest
index 0a6f32936063..59b82cd99cbb 100644
--- a/app-admin/ansible-lint/Manifest
+++ b/app-admin/ansible-lint/Manifest
@@ -1,5 +1,7 @@
DIST ansible-lint-5.2.1.tar.gz 356071 BLAKE2B 70c54114a667ba63c1d285ec8a73a7c3332f89cbdf1b8d4866de86aa2c358e41759ac69188806c715cbd3893a2d0b1123e6b679ed208ce4c40141a40b9f54681 SHA512 9ae1aa775572485aaa68ef127cb2ea2d66cd1057878ac396b1644244a070f05b7920eceec3cdb16523f9fadcbcb5df971f3513d7e4d9cbd6ace1ec4f4d861451
DIST ansible-lint-5.3.1.tar.gz 356514 BLAKE2B 3ae30c357ed03c544773671af94763bf76d3544f30b1c7b7081db9a67feaeaecfb678d4b194c05b45fc8c7e75cc1c057ad9612ad4aaf364cfd4904200ac128f5 SHA512 2d46b1cf2605c68765c67e7d7e90a049e9253b058ac01c833ed0afc67ba553a8855f3d9315eec440bfc08c0d9e7b0b0f5e0151021708ad1e05fd895c7f679c43
+DIST ansible-lint-5.3.2.tar.gz 356870 BLAKE2B 4af11f760e30945e066a9d160438bbedd5a4d39799009bc6d30614baab0b88a21cad088c0b758529aaa5fbb54a9f2a1f636ab6d642a37297a27c8ba5240f53ef SHA512 4ff2d36de20b2e6982d0cd1bca6a3f886307701dfa0bf880d2d417387191d90adc9361afb57f8ed26239cbc110e5f05f52a186950d7d3b4b0a8e4406e4695acd
EBUILD ansible-lint-5.2.1.ebuild 1516 BLAKE2B 2506a58802c30dff8193c489b893954e99c4d2328a886e7fe7933dbec463ddaa43982acaff09a1e022da975804af4f73b7f8235dced49a1e63940cf5b439476b SHA512 b6029f18d328dfe5caf4e68a2b2c3d869181643f5cfe15b3a478098d618b48393b92c3ee73bf8b02a54185483963f92fd3f6b60f3008c1275d87316352d87217
EBUILD ansible-lint-5.3.1.ebuild 1556 BLAKE2B a6e8a4ea6e984535de2e47490e409001cc4fe020a286fd86e555aca7fdf9f955b6146a2d69c4c3af9446105036f714b0bda7dc85f2f6c6c1052f743112fa0790 SHA512 2578255ba9909d6befdd254eba015798ad516c31d99017f06c0402333358d77e6d293d466a654106bd03f3fe16cec1dc8cf1db2cdd9392902f4eb37ea400f1e6
+EBUILD ansible-lint-5.3.2.ebuild 1610 BLAKE2B 515be157424773917f842f0e7a03425030721324544365546491af15be989b8a938f0b5433b6931b84cc520d9589c1fc9501e875e03244a040df86a793ea4c38 SHA512 3e93f473e9dffb2c2c47c50360c8ab658f44155c71ae829575b64f6bf23df1ad69aa14f0184ef4e43dce5876ce5ea5a3f7ae9c113ae48713a2c58da88b1d7e67
MISC metadata.xml 581 BLAKE2B b2032b06ec9ebe63385918be612a0ee1c351943bfc05a544670a78d87bb2836eb2143bd80da6542c140ab16d33f4b79fa0f18cce3291833b34e43ffb6fd3e737 SHA512 912848e5c37863ed0b04062210da0e925a2d71f1766dd43bb746e7aa364a86ff501e4a6e9762c584ca6d37d4f38b7418a32f3a02b30a7ee4b3f7b828f84f6646
diff --git a/app-admin/ansible-lint/ansible-lint-5.3.2.ebuild b/app-admin/ansible-lint/ansible-lint-5.3.2.ebuild
new file mode 100644
index 000000000000..bb484dbbc409
--- /dev/null
+++ b/app-admin/ansible-lint/ansible-lint-5.3.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# TODO: py310 - blocked by <=dev-util/yamllint-1.26.3
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Checks ansible playbooks for practices and behaviour that can be improved"
+HOMEPAGE="https://github.com/ansible-community/ansible-lint"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+# 14 tests fail due to usersandbox denying the executable 'ansible'
+# access to $HOME/.ansible. More importantly, some tests (6 as of 5.2.1)
+# fail even when run manually with tox.
+RESTRICT="test"
+
+RDEPEND="
+ >=app-admin/ansible-2.10[${PYTHON_USEDEP}]
+ >=app-admin/ansible-base-2.11.4[${PYTHON_USEDEP}]
+ >=dev-python/enrich-1.2.6[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/rich-9.5.1[${PYTHON_USEDEP}]
+ >=dev-python/ruamel-yaml-0.15.37[${PYTHON_USEDEP}]
+ dev-python/tenacity[${PYTHON_USEDEP}]
+ >=dev-python/wcmatch-7.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm_git_archive-1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/flaky-3.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.1.0[${PYTHON_USEDEP}]
+ >=dev-util/yamllint-1.25.0[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest
+
+pkg_postinst() {
+ optfeature_header "Consider installing the following optional packages:"
+ optfeature "letting ${PN} run YAML checks" dev-util/yamllint
+}