summaryrefslogtreecommitdiff
path: root/app-admin/ansible-molecule
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-11 11:46:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-11 11:46:23 +0100
commit2046683958d0497bec1458741dc867558b69e622 (patch)
tree7e3b4eb74040f3fb955d11fe2db0ef9da77af912 /app-admin/ansible-molecule
parent980af9d76d4b7d7541b41eeff427e5cbd5cf7ec3 (diff)
gentoo auto-resync : 11:05:2023 - 11:46:23
Diffstat (limited to 'app-admin/ansible-molecule')
-rw-r--r--app-admin/ansible-molecule/Manifest2
-rw-r--r--app-admin/ansible-molecule/ansible-molecule-5.0.1.ebuild76
2 files changed, 78 insertions, 0 deletions
diff --git a/app-admin/ansible-molecule/Manifest b/app-admin/ansible-molecule/Manifest
index ed54385abd23..5f1783d72a4e 100644
--- a/app-admin/ansible-molecule/Manifest
+++ b/app-admin/ansible-molecule/Manifest
@@ -1,3 +1,5 @@
DIST molecule-4.0.4.tar.gz 337260 BLAKE2B 14c493fa8aaa15466ebca19af9e5325ddb824c151d07d800136dcb714a430ea2dc42b38c9ec6e805e29ec3226376a532793d51c5d0544d6d5105510e5365ca8c SHA512 d7c1ceefbf74cbc27a397e7a40d855b23325bbde31a4cd1920961413a7db950e9fc530fec180de877eb37984bac8603033aa5a582e68e7f4c4ac2a10721c6630
+DIST molecule-5.0.1.tar.gz 334911 BLAKE2B c021171996a4e57a3f3cffc1f72396b07c59f0e0c6a4b9277d9ad994655f37aafc920164f6a91f9a533497f24cc780d4ff07a8e40cfea4ce89e6249b8415e438 SHA512 c5d6a112c328932c16c8e126cd6308ad8aecc46a03ab43fef2fd0869e5b93c7216df4c7f7e115ebf8e4b4293968848598e8e02e462b0a9d91307f79c6b0a01bd
EBUILD ansible-molecule-4.0.4.ebuild 2672 BLAKE2B 89d1d795f7c50189cc28c3afd6123a4b6353acec9f2f6319c7cfbf8e33b7afd70936c02f1cca85ca25f435f32b66dae14d1254412732e4f1010f500af4145171 SHA512 d79263e07cf1f6af1eb0047a1a6e12bd3ef4ed1091afaf89b7674a3fe763e349398a60bd1eac1663debe11fa42f0376d905b94d951291123e728a1cfa882138d
+EBUILD ansible-molecule-5.0.1.ebuild 2725 BLAKE2B 0b054c882a89f4e4e1d5791cdc61076448b07aa5c593d19436d33c00c9ae7f2581da0aebd21f31c7b7fedff4bb3f45659eda7dd7ef9dd788e21b4334126ea3af SHA512 8bce5a0e9f8af1daa0f6465ba61b48c07b0ef27bab4723949ae764a1d9462bd5bad977f783e4544c212748acd845adc8288fd5f29b2fd56bf0a2418d1f450e86
MISC metadata.xml 407 BLAKE2B 869b6c1d6da66568eeac2daaca56567876dbfb057f50add7bbc95fef8a3fc38b99279d359a90573f8d6af47d0e451445827f6efeefa8fb0e7954e8b624783855 SHA512 e6dbbe2c0536ea84bdfea0168a743dbe3de424b442757441bc4f978e07d41ca6022eb2d6f269c921f42b4e7d858788f967c1c35bd4241a35dbe25a161f5744de
diff --git a/app-admin/ansible-molecule/ansible-molecule-5.0.1.ebuild b/app-admin/ansible-molecule/ansible-molecule-5.0.1.ebuild
new file mode 100644
index 000000000000..ac127b363db2
--- /dev/null
+++ b/app-admin/ansible-molecule/ansible-molecule-5.0.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+DOCS_BUILDER="mkdocs"
+# cairosvg and pillow are technically speaking dependencies of the mkdocs-material
+# plugin "social" (Bug #906126).
+# Still missing: dev-python/mkdocstrings[python]
+DOCS_DEPEND="
+ dev-python/pillow
+ >=dev-python/mkdocs-ansible-0.1.4
+ dev-python/mkdocs-autorefs
+ media-gfx/cairosvg
+"
+PYPI_PN="molecule"
+
+inherit distutils-r1 docs optfeature pypi
+
+DESCRIPTION="A toolkit designed to aid in the development and testing of Ansible roles"
+HOMEPAGE="https://pypi.org/project/molecule/ https://github.com/ansible-community/molecule/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="selinux"
+
+RDEPEND="$(python_gen_cond_dep '
+ <dev-python/ansible-compat-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/click-8.0[${PYTHON_USEDEP}]
+ <dev-python/click-9[${PYTHON_USEDEP}]
+ >=dev-python/click-help-colors-0.9[${PYTHON_USEDEP}]
+ >=dev-python/enrich-1.2.7[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.11.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.9.1[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ <dev-python/pluggy-2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-9.5.1[${PYTHON_USEDEP}]
+ >=dev-util/cookiecutter-1.7.3[${PYTHON_USEDEP}]
+ selinux? ( sys-libs/libselinux[python,${PYTHON_USEDEP}] )
+')"
+BDEPEND="$(python_gen_cond_dep '
+ >=dev-python/setuptools-scm-7.0.0[${PYTHON_USEDEP}]
+ test? (
+ app-admin/ansible-lint[${PYTHON_USEDEP}]
+ app-misc/check-jsonschema[${PYTHON_USEDEP}]
+ >=dev-python/ansi2html-1.6.0[${PYTHON_USEDEP}]
+ dev-python/filelock[${PYTHON_USEDEP}]
+ <dev-python/pexpect-5[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-plus-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-testinfra-7.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-3.1.0[${PYTHON_USEDEP}]
+ )
+')"
+
+# test_role.py doesn't play nicely with FEATURES=usersandbox. As for test_command.py:
+# - quite a few of these tests use the network;
+# - test_command_dependency[shell] only works if Molecule has previously been installed;
+# - tests involving creation of a new scenario fail on ansible-lint errors, even though
+# a config file is deployed which should skip expected issues.
+EPYTEST_DESELECT=(
+ src/molecule/test/functional/test_command.py
+ src/molecule/test/unit/command/init/test_role.py
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature_header "Some optional packages commonly used in Molecule scenarios:"
+ optfeature "checking playbooks for practices and behaviour that can be improved" app-admin/ansible-lint
+}