summaryrefslogtreecommitdiff
path: root/app-admin/ansible-molecule
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-13 02:01:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-13 02:01:50 +0000
commit2a3e0d61b3d88306b6fae46756f9ba7d230222ae (patch)
treea0d3259dd259861a49a2d3e6e9220beaa8ec39c2 /app-admin/ansible-molecule
parent39c32f4d5dca9f6293fccb69e9d50baf494c8de4 (diff)
gentoo auto-resync : 13:12:2024 - 02:01:50
Diffstat (limited to 'app-admin/ansible-molecule')
-rw-r--r--app-admin/ansible-molecule/Manifest2
-rw-r--r--app-admin/ansible-molecule/ansible-molecule-24.12.0.ebuild76
2 files changed, 78 insertions, 0 deletions
diff --git a/app-admin/ansible-molecule/Manifest b/app-admin/ansible-molecule/Manifest
index f2430a0a4c86..7f9d81833dc6 100644
--- a/app-admin/ansible-molecule/Manifest
+++ b/app-admin/ansible-molecule/Manifest
@@ -1,4 +1,6 @@
AUX ansible-molecule-24.2.1-mkdocs_google_fonts.patch 156 BLAKE2B e311c1a4c1d3cc9a087611a70dfa6a5634d0842afdd426a708a390b7391507e330d2d9680a5b5a85949d9985beafb80fb146a53742d645d1b8ccb78f5f7a4f64 SHA512 66113e61b0f97243e15afc7b7fea8657cee0cabfa450a2bbe6a1b751cdd9cd82be6bfad6b36802377fd3261e9e55d3d0e37eb44e9c26838110495cd43773cc9f
+DIST molecule-24.12.0.tar.gz 4412418 BLAKE2B 0dba13534a7d4d9b1095c38e9694cd51b3e750cb9ab611b3078972182d09319a7b858e3dba018c370a9b7c6a8065036f60d8cab58da1e7ee9660be746b9bdf34 SHA512 6d709832091514b55f697ed70d7c7ae4695537a868ed3e8a0b0cb1c868ce5b161baf849412f94fbe723fae491a4ca4e510179ba69c40a3b48711aef36cedc2ba
DIST molecule-24.2.1.tar.gz 343228 BLAKE2B 9605b5a8e21d37597cbf35f0f6f811471909dde5496541b1d7cd130eb2b970125fdc291df6493f8716f38514df17d957094604ae49e64d16f2207a0d3682bd38 SHA512 3813163d72cee51987d340c8a1ed0e03d8abe509a601e94c3e32bf673a56edd83d0c2bde1347057fe8a4c2b37e11a068ef689dd669d4395da64bec3921f1403d
+EBUILD ansible-molecule-24.12.0.ebuild 2769 BLAKE2B ad0b48c0b880b5ccad97b6a8ce6a88eb272d564f6ea9c4d14443e6b74bbe9580fc54b240a44c3e90ba4152338b290dda52e14ddcf600a0625930a857e36c1f9c SHA512 a9215edeca6a61b8e2a9bede6cd7070758f724adc6eb8b4e233b0e04673f1f0d28acbf5abfe76f34f6035d11884b97c00e3fa39a9ea8cd3d75cc3929617def16
EBUILD ansible-molecule-24.2.1.ebuild 3013 BLAKE2B 978335a99c499a3d4ac8fa13dab0207f6ed085c72f84dd8c08703b481fd0a6e0c8419e0729cefbd5aebd1d3e37d308fcf60a42301d6b93c9b051718751cbc51f SHA512 62d34a4887da28d71e9a045bfee64bc5b79e4502b9a8f13e32353e3fcfab66b46ad6b678050720beedd91f3f3589affb447a883192b51c0ed8de3e8e02d29eaf
MISC metadata.xml 319 BLAKE2B e21046964335743f016597d0b19ef5edba9452c5cadeaf9db45a3443cdf3320b8c766a8e2302cecc203aa333cbd9c988ffe0330a7e07a083c3d157ae4b8e91c1 SHA512 b082b103d0c47df58411d7ad1e67cf274d287f8398d4235fe83d2a6f7e722d72e9441ec919510f98965b2d01ebe1d9fd25fe987a358786d2cc55ea375c7fed3d
diff --git a/app-admin/ansible-molecule/ansible-molecule-24.12.0.ebuild b/app-admin/ansible-molecule/ansible-molecule-24.12.0.ebuild
new file mode 100644
index 000000000000..b2ef4a306e45
--- /dev/null
+++ b/app-admin/ansible-molecule/ansible-molecule-24.12.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{11..13} )
+PYPI_PN="molecule"
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="A toolkit designed to aid in the development and testing of Ansible roles"
+HOMEPAGE="https://pypi.org/project/molecule/ https://github.com/ansible/molecule/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+IUSE="selinux"
+
+# Since around the time of the switch to the yy.m.patchlevel versioning scheme
+# the test suite has been completely incompatible with Portage, with several
+# tests which do pass under Tox failing even with disabled sandboxing.
+# Nb. As of 24.2.1 two tests fail even under Tox, for both PyPI and GitHub
+# tarballs.
+RESTRICT="test"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.18.1[${PYTHON_USEDEP}]
+ >=dev-python/ansible-compat-24.10.0[${PYTHON_USEDEP}]
+ >=dev-python/click-8.0[${PYTHON_USEDEP}]
+ <dev-python/click-9[${PYTHON_USEDEP}]
+ >=dev-python/click-help-colors-0.9[${PYTHON_USEDEP}]
+ >=dev-python/enrich-1.2.7[${PYTHON_USEDEP}]
+ >=dev-python/jinja2-2.11.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.9.1[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ <dev-python/pluggy-2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-6.0.1-r1[${PYTHON_USEDEP}]
+ >=dev-python/rich-13.7.1[${PYTHON_USEDEP}]
+ >=dev-python/wcmatch-8.2.5[${PYTHON_USEDEP}]
+ selinux? ( sys-libs/libselinux[python,${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+ test? (
+ >=app-admin/ansible-lint-6.12.1[${PYTHON_USEDEP}]
+ >=app-misc/check-jsonschema-0.28.4-r1[${PYTHON_USEDEP}]
+ >=dev-python/ansi2html-1.8.0[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.9.0[${PYTHON_USEDEP}]
+ <dev-python/pexpect-5[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-plus-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-3.1.0[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-24.2.1-mkdocs_google_fonts.patch
+)
+
+# test_role.py doesn't play nicely with FEATURES=usersandbox. As for test_command.py:
+# - quite a few of these tests use the network;
+# - test_command_dependency[shell] only works if Molecule has previously been installed;
+# - tests involving creation of a new scenario fail on ansible-lint errors, even though
+# a config file is deployed which should skip expected issues.
+EPYTEST_DESELECT=(
+ src/molecule/test/functional/test_command.py
+ src/molecule/test/unit/command/init/test_role.py
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature_header "Some optional packages commonly used in Molecule scenarios:"
+ optfeature "checking playbooks for practices and behaviour that can be improved" app-admin/ansible-lint
+}