summaryrefslogtreecommitdiff
path: root/app-admin/apachetop/apachetop-0.19.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /app-admin/apachetop/apachetop-0.19.7.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'app-admin/apachetop/apachetop-0.19.7.ebuild')
-rw-r--r--app-admin/apachetop/apachetop-0.19.7.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/apachetop/apachetop-0.19.7.ebuild b/app-admin/apachetop/apachetop-0.19.7.ebuild
new file mode 100644
index 000000000000..c55508cd46dd
--- /dev/null
+++ b/app-admin/apachetop/apachetop-0.19.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A realtime Apache log analyzer"
+HOMEPAGE="https://github.com/tessus/apachetop"
+SRC_URI="https://github.com/tessus/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="fam pcre"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+ sys-libs/readline:0=
+ fam? ( virtual/fam )
+ pcre? ( dev-libs/libpcre )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --with-logfile="${EPREFIX}"/var/log/apache2/access_log \
+ --without-adns \
+ $(use_with fam) \
+ $(use_with pcre)
+}