summaryrefslogtreecommitdiff
path: root/app-admin/aws-cw-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
commit76dfef0cec9170000357d2f354e412daf48941fc (patch)
tree56647120c0ee20ab3494475c86722034cd194b02 /app-admin/aws-cw-tools
parentccf84bcd604130256d1377cd58f0a634ae6ee20f (diff)
gentoo resync : 30.12.2017
Diffstat (limited to 'app-admin/aws-cw-tools')
-rw-r--r--app-admin/aws-cw-tools/Manifest2
-rw-r--r--app-admin/aws-cw-tools/aws-cw-tools-1.0.12.1.ebuild33
2 files changed, 18 insertions, 17 deletions
diff --git a/app-admin/aws-cw-tools/Manifest b/app-admin/aws-cw-tools/Manifest
index 6a5045c0ffe4..aa67c70b6e69 100644
--- a/app-admin/aws-cw-tools/Manifest
+++ b/app-admin/aws-cw-tools/Manifest
@@ -1,3 +1,3 @@
DIST CloudWatch-1.0.12.1.zip 6156651 BLAKE2B 140dc28fa44423824f180f34ab05918068e941f31de3081c0ee7ae462ee8d63f26c4fdc838a9e677638a34609a215f52b83572980e488d34557d39d610c434e7 SHA512 881a428a2861b86196a691f24a3471058426f049170d16f067d7cc319712beb161c80041e9ae89339d5298ffbf2869c04509fbe4620cd60cc74658c8d3ab11ec
-EBUILD aws-cw-tools-1.0.12.1.ebuild 1671 BLAKE2B 28ee2388a0688108e3559422eedf7cf437efdde882d3bb51320ad943dbb29f381bc44ca78431f38ee6750390eccd313f7ad0286c8eb56e272daa94f46926fe57 SHA512 8cdfae8dec09e84c76e0b29bf308ac7d59ddf29b5978c24a515ef83671d964410d2aae8a7fef7d960780f865303998bddc94f161826847ad4c38373a79ca1209
+EBUILD aws-cw-tools-1.0.12.1.ebuild 1644 BLAKE2B 16edd301ca96cee51d87ec0949c36a07d3489e495020a7f8c63da072b46ec1168570ef9d41474c12c2de2da3c5d04bbae8a7be1c372434cbabe6cb8c35bb23d6 SHA512 a1d5b319c2389852bce354ee7fc7f460ac30042256a681964173dff877445d5bbd7f619c8e5d9574c260294a07d3b643f514852f637b37b5d3bce58263a19c5b
MISC metadata.xml 456 BLAKE2B 7c623b757f291e6ff28618f87a39f47dcbaa1b7dec75d642a98fc4930b3b75089af8d0ae14b14e9e422ed0ff12716ba337606a58fc1d678547ad16991669f103 SHA512 aa4a57f4b0181ace33cad1698cdadd8cf41eb6f8fa8184ef415d09e0b0fbc81eaf579800c36040a9e01fb4fd2715e646a45d906d55e07617185ffe3f7b8538e8
diff --git a/app-admin/aws-cw-tools/aws-cw-tools-1.0.12.1.ebuild b/app-admin/aws-cw-tools/aws-cw-tools-1.0.12.1.ebuild
index cef181338339..ab4c5fb5543e 100644
--- a/app-admin/aws-cw-tools/aws-cw-tools-1.0.12.1.ebuild
+++ b/app-admin/aws-cw-tools/aws-cw-tools-1.0.12.1.ebuild
@@ -1,42 +1,42 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=6
DESCRIPTION="The API tools serve as the client interface to the Amazon CloudWatch web service"
HOMEPAGE="http://aws.amazon.com/developertools/2534"
# SRC_URI="http://ec2-downloads.s3.amazonaws.com/CloudWatch-2010-08-01.zip"
SRC_URI="mirror://sabayon/${CATEGORY}/CloudWatch-${PV}.zip"
-S="${WORKDIR}/CloudWatch-${PV}"
-
LICENSE="Amazon"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
+RESTRICT="mirror"
+
DEPEND="app-arch/unzip"
RDEPEND="virtual/jre"
-RESTRICT="mirror"
-src_unpack() {
- unpack ${A}
- cd "$S"
+S="${WORKDIR}/CloudWatch-${PV}"
+
+src_prepare() {
+ default
find . -name '*.cmd' -delete || die
}
src_install() {
- dodir /opt/${PN}
insinto /opt/${PN}/lib
- doins -r "${S}"/lib/*
+ doins -r lib/.
+
exeinto /opt/${PN}/bin
- doexe "${S}"/bin/*
+ doexe bin/*
dodir /etc/env.d
- cat - > "${T}"/99${PN} <<EOF
-AWS_CLOUDWATCH_HOME=/opt/${PN}
-PATH=/opt/${PN}/bin
-ROOTPATH=/opt/${PN}/bin
-EOF
+ cat - > "${T}"/99${PN} <<- EOF || die
+ AWS_CLOUDWATCH_HOME=/opt/${PN}
+ PATH=/opt/${PN}/bin
+ ROOTPATH=/opt/${PN}/bin
+ EOF
doenvd "${T}"/99${PN}
dodoc "THIRDPARTYLICENSE.TXT"
@@ -46,6 +46,7 @@ pkg_postinst() {
ewarn "Remember to run: env-update && source /etc/profile if you plan"
ewarn "to use these tools in a shell before logging out (or restarting"
ewarn "your login manager)"
+
elog
elog "You need to put the following in your ~/.bashrc replacing the"
elog "values with the full path to your AWS credentials file."