summaryrefslogtreecommitdiff
path: root/app-admin/aws-iam-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
commit76dfef0cec9170000357d2f354e412daf48941fc (patch)
tree56647120c0ee20ab3494475c86722034cd194b02 /app-admin/aws-iam-tools
parentccf84bcd604130256d1377cd58f0a634ae6ee20f (diff)
gentoo resync : 30.12.2017
Diffstat (limited to 'app-admin/aws-iam-tools')
-rw-r--r--app-admin/aws-iam-tools/Manifest2
-rw-r--r--app-admin/aws-iam-tools/aws-iam-tools-1.3.0.ebuild36
2 files changed, 19 insertions, 19 deletions
diff --git a/app-admin/aws-iam-tools/Manifest b/app-admin/aws-iam-tools/Manifest
index 93a0920b5f87..a8d7a2f10d53 100644
--- a/app-admin/aws-iam-tools/Manifest
+++ b/app-admin/aws-iam-tools/Manifest
@@ -1,3 +1,3 @@
DIST IAMCli-1.3.0.zip 3957057 BLAKE2B b2e429c2fb3169e23d6e6fc4c4b33594f2814bf976d1c584551008561b71977a3ee4abafd50bd3e52592e918624da01b83527557d2079772d083fbe96ee52eb5 SHA512 5012ece2d0569545848d83cf879b4d05f7f955f22bbc31b86f3993e4f5ee48de3099369fddf7f2b2d98f89e56c8c329e427a1f7dca0afa728ea9593c1b36497c
-EBUILD aws-iam-tools-1.3.0.ebuild 1623 BLAKE2B 4ff825ffdff114cf600dc47557e4434419d67489af44f64e8c901c2232b617002a615d6d9b6ccd159fa119fc36b99863637efa9fb1dd96d6c8f837e812d8c15b SHA512 db74dd4808fa98ba9b80a661d6da4a9a967e77b1aa98cd5fcaa4e5078eb0f97431596b8f30cb9d27cc4256808d14c712a0fc5f2219594bc46f3551e7b1536cbc
+EBUILD aws-iam-tools-1.3.0.ebuild 1553 BLAKE2B b5a9214325f6ba6de22f9bfb774fdce73acdabf9a41bd6f27e06e4d967d3129820f855e35a3cacc82b49b13fcbd6142f97e8356f5ae6afbbdb15c5205de07925 SHA512 a437128c9f7dc8ff56e9cf4e0fd076aa2c8e596384581f8b8a11bf1c61369ebf1d7054a0c8cdd49522afa6037bc9129355875a2f79a9403e3edc41bc4cca1be7
MISC metadata.xml 456 BLAKE2B 7c623b757f291e6ff28618f87a39f47dcbaa1b7dec75d642a98fc4930b3b75089af8d0ae14b14e9e422ed0ff12716ba337606a58fc1d678547ad16991669f103 SHA512 aa4a57f4b0181ace33cad1698cdadd8cf41eb6f8fa8184ef415d09e0b0fbc81eaf579800c36040a9e01fb4fd2715e646a45d906d55e07617185ffe3f7b8538e8
diff --git a/app-admin/aws-iam-tools/aws-iam-tools-1.3.0.ebuild b/app-admin/aws-iam-tools/aws-iam-tools-1.3.0.ebuild
index e70c4d29a090..5714f191ff31 100644
--- a/app-admin/aws-iam-tools/aws-iam-tools-1.3.0.ebuild
+++ b/app-admin/aws-iam-tools/aws-iam-tools-1.3.0.ebuild
@@ -1,50 +1,50 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=6
DESCRIPTION="The Command Line Interface for the AWS Identity and Access Management Service"
HOMEPAGE="http://aws.amazon.com/developertools/AWS-Identity-and-Access-Management/4143"
SRC_URI="mirror://sabayon/${CATEGORY}/IAMCli-${PV}.zip"
-S="${WORKDIR}/IAMCli-${PV}"
-
LICENSE="Amazon"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
+RESTRICT="mirror"
+
DEPEND="app-arch/unzip"
RDEPEND="virtual/jre"
-RESTRICT="mirror"
-src_unpack() {
- unpack ${A}
- cd "${WORKDIR}/IAMCli-${PV}"
+S="${WORKDIR}/IAMCli-${PV}"
+
+src_prepare() {
+ default
find . -name '*.cmd' -delete || die
}
src_install() {
- dodir /opt/${PN}
insinto /opt/${PN}/lib
- doins -r "${S}"/lib/*
+ doins -r lib/.
+
exeinto /opt/${PN}/bin
- doexe "${S}"/bin/*
-
- dodir /etc/env.d
- cat - > "${T}"/99${PN} <<EOF
-AWS_IAM_HOME=/opt/${PN}
-PATH=/opt/${PN}/bin
-ROOTPATH=/opt/${PN}/bin
-EOF
+ doexe bin/*
+
+ cat > "${T}"/99${PN} <<- EOF || die
+ AWS_IAM_HOME=/opt/${PN}
+ PATH=/opt/${PN}/bin
+ ROOTPATH=/opt/${PN}/bin
+ EOF
doenvd "${T}"/99${PN}
- dodoc "LICENSE.txt"
+ dodoc LICENSE.txt
}
pkg_postinst() {
ewarn "Remember to run: env-update && source /etc/profile if you plan"
ewarn "to use these tools in a shell before logging out (or restarting"
ewarn "your login manager)"
+
elog
elog "You need to put the following in your ~/.bashrc replacing the"
elog "values with the full path to your AWS credentials file."