summaryrefslogtreecommitdiff
path: root/app-admin/bastille/bastille-3.0.9-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
commitd87262dd706fec50cd150aab3e93883b6337466d (patch)
tree246b44c33ad7a57550430b0a60fa0df86a3c9e68 /app-admin/bastille/bastille-3.0.9-r1.ebuild
parent71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/bastille/bastille-3.0.9-r1.ebuild')
-rw-r--r--app-admin/bastille/bastille-3.0.9-r1.ebuild69
1 files changed, 0 insertions, 69 deletions
diff --git a/app-admin/bastille/bastille-3.0.9-r1.ebuild b/app-admin/bastille/bastille-3.0.9-r1.ebuild
deleted file mode 100644
index cfdc9cf09dcd..000000000000
--- a/app-admin/bastille/bastille-3.0.9-r1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PERL_EXPORT_PHASE_FUNCTIONS=no
-inherit eutils perl-module
-
-PATCHVER=0.2
-MY_PN=${PN/b/B}
-MY_P=${MY_PN}-${PV}
-S=${WORKDIR}/${MY_PN}
-DESCRIPTION="Bastille-Linux is a security hardening tool"
-HOMEPAGE="http://bastille-linux.org/"
-SRC_URI="mirror://sourceforge/${PN}-linux/${MY_P}.tar.bz2
- mirror://gentoo/${P}-gentoo-${PATCHVER}.patch.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
-IUSE="X"
-
-RDEPEND="
- net-firewall/iptables
- app-admin/logrotate
- dev-perl/Curses
- net-firewall/psad
- X? ( dev-perl/Tk )
- virtual/logger
-"
-
-src_prepare() {
- epatch "${WORKDIR}"/${P}-gentoo-${PATCHVER}.patch
-
- # make sure the Perl modules go into vendor dir
- epatch "${FILESDIR}/${P}-perl.patch"
- perl_set_version
-
- cd "${S}"
- chmod a+x Install.sh bastille-ipchains bastille-netfilter
-}
-
-src_install() {
- perl_set_version
- export VENDOR_LIB
-
- cd "${S}"
- DESTDIR="${D}" ./Install.sh
-
- # Example configs
- cd "${S}"
- insinto /usr/share/Bastille
- doins *.config
-
- newinitd ${PN}-firewall.gentoo-init ${PN}-firewall
-
- # Documentation
- cd "${S}"
- dodoc *.txt BUGS Change* README*
- cd "${S}"/docs
- doman *.1m
-}
-
-pkg_postinst() {
- elog "Please be aware that when using the Server Lax, Server Moderate, or"
- elog "Server Paranoia configurations, you may need to use InteractiveBastille"
- elog "to set any advanced network information, such as masquerading and"
- elog "internal interfaces, if you plan to use them."
-}