summaryrefslogtreecommitdiff
path: root/app-admin/ccze/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-admin/ccze/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-admin/ccze/files')
-rw-r--r--app-admin/ccze/files/ccze-0.2.1-tinfo.patch10
-rw-r--r--app-admin/ccze/files/ccze-fbsd.patch25
-rw-r--r--app-admin/ccze/files/ccze-ldflags.patch11
-rw-r--r--app-admin/ccze/files/ccze-segfault.patch29
4 files changed, 75 insertions, 0 deletions
diff --git a/app-admin/ccze/files/ccze-0.2.1-tinfo.patch b/app-admin/ccze/files/ccze-0.2.1-tinfo.patch
new file mode 100644
index 000000000000..d0d7550e3337
--- /dev/null
+++ b/app-admin/ccze/files/ccze-0.2.1-tinfo.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -100,6 +100,7 @@
+ strndup strstr])
+
+ AC_CHECK_LIB(ncurses, initscr, [], [AC_ERROR(NCurses library not found)])
++AC_SEARCH_LIBS(stdscr, tinfo,,[AC_ERROR([Cannot find a library providing stdscr])])
+ AC_CHECK_FUNC(dlopen, [], [AC_CHECK_LIB(dl, dlopen)])
+ AC_CHECK_FUNC(getopt_long, [], [AC_CHECK_LIB(gnugetopt, getopt_long)])
+
diff --git a/app-admin/ccze/files/ccze-fbsd.patch b/app-admin/ccze/files/ccze-fbsd.patch
new file mode 100644
index 000000000000..ae694e0e4423
--- /dev/null
+++ b/app-admin/ccze/files/ccze-fbsd.patch
@@ -0,0 +1,25 @@
+--- a/src/ccze-compat.h
++++ b/src/ccze-compat.h
+@@ -29,6 +29,11 @@
+ #include <stddef.h>
+ #include <stdio.h>
+
++# ifndef __error_t_defined
++typedef int error_t;
++# define __error_t_defined 1
++# endif
++
+ #ifndef HAVE_STRNDUP
+ char *strndup (const char *s, size_t size);
+ #endif
+--- a/src/ccze-compat.c
++++ b/src/ccze-compat.c
+@@ -275,7 +275,7 @@
+ char **valuep)
+ {
+ int i = getsubopt (optionp, tokens, valuep);
+-#if HAVE_SUBOPTARg
++#if HAVE_SUBOPTARG
+ if (!*valuep && suboptarg)
+ *valuep = strdup (suboptarg);
+ #endif
diff --git a/app-admin/ccze/files/ccze-ldflags.patch b/app-admin/ccze/files/ccze-ldflags.patch
new file mode 100644
index 000000000000..4f8c8f207209
--- /dev/null
+++ b/app-admin/ccze/files/ccze-ldflags.patch
@@ -0,0 +1,11 @@
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -75,7 +75,7 @@
+ ${PROGRAM}: ${OBJECTS} ${PLUGIN_SOBJS}
+ ${CC} -rdynamic ${ALL_CFLAGS} -o $@ $^ ${ALL_LDFLAGS}
+ ccze-dump ccze-cssdump: %: %.o ccze-compat.o ccze-color.c
+- ${CC} ${ALL_CFLAGS} -o $@ $@.o ccze-compat.o
++ ${CC} ${ALL_CFLAGS} ${ALL_LDFLAGS} -o $@ $@.o ccze-compat.o
+ ccze-builtins.c: Makefile
+ echo '#include <ccze.h>' >$@
+ echo '#include "ccze-private.h"' >>$@
diff --git a/app-admin/ccze/files/ccze-segfault.patch b/app-admin/ccze/files/ccze-segfault.patch
new file mode 100644
index 000000000000..5bdd823e4120
--- /dev/null
+++ b/app-admin/ccze/files/ccze-segfault.patch
@@ -0,0 +1,29 @@
+--- a/src/ccze.c
++++ b/src/ccze.c
+@@ -209,7 +209,7 @@
+ }
+ break;
+ case 'a':
+- plugin = strtok (optarg, "=");
++ plugin = strtok (arg, "=");
+ value = strtok (NULL, "\n");
+ ccze_plugin_argv_set (plugin, value);
+ break;
+@@ -249,7 +249,7 @@
+ ccze_config.remfac = 1;
+ break;
+ case 'm':
+- subopts = optarg;
++ subopts = arg;
+ while (*subopts != '\0')
+ {
+ switch (getsubopt (&subopts, m_subopts, &value))
+@@ -273,7 +273,7 @@
+ }
+ break;
+ case 'o':
+- subopts = optarg;
++ subopts = arg;
+ while (*subopts != '\0')
+ {
+ switch (getsubopt (&subopts, o_subopts, &value))