summaryrefslogtreecommitdiff
path: root/app-admin/checksec/checksec-1.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /app-admin/checksec/checksec-1.9.0.ebuild
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'app-admin/checksec/checksec-1.9.0.ebuild')
-rw-r--r--app-admin/checksec/checksec-1.9.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-admin/checksec/checksec-1.9.0.ebuild b/app-admin/checksec/checksec-1.9.0.ebuild
new file mode 100644
index 000000000000..eae3c30567d3
--- /dev/null
+++ b/app-admin/checksec/checksec-1.9.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PN=${PN}.sh
+DESCRIPTION="Tool to check properties of executables (e.g. ASLR/PIE, RELRO, PaX, Canaries)"
+HOMEPAGE="https://github.com/slimm609/checksec.sh"
+SRC_URI="https://github.com/slimm609/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"/${MY_PN}-${PV}
+
+DOCS=( ChangeLog README.md )
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-1.7.2-path.patch
+ eapply_user
+ sed 's,^pkg_release=false,pkg_release=true,' -i ${PN} || die
+}
+
+src_install() {
+ default
+
+ doman extras/man/*
+
+ insinto /usr/share/zsh/site-functions
+ doins extras/zsh/_${PN}
+
+ dobin ${PN}
+}