summaryrefslogtreecommitdiff
path: root/app-admin/chroot_safe/chroot_safe-1.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-07 11:03:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-07 11:03:14 +0100
commit957235cf19a691360c720f7913672adda4258ed0 (patch)
tree812bba7928f4293ead05a7ee9c1ac39c5ef9f12e /app-admin/chroot_safe/chroot_safe-1.4-r1.ebuild
parent62f67115b5c46134c34f88f4b1cbdacc19384c0a (diff)
gentoo resync : 07.10.2018
Diffstat (limited to 'app-admin/chroot_safe/chroot_safe-1.4-r1.ebuild')
-rw-r--r--app-admin/chroot_safe/chroot_safe-1.4-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-admin/chroot_safe/chroot_safe-1.4-r1.ebuild b/app-admin/chroot_safe/chroot_safe-1.4-r1.ebuild
new file mode 100644
index 000000000000..1eb04bd3ccbc
--- /dev/null
+++ b/app-admin/chroot_safe/chroot_safe-1.4-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Chroot any dynamically linked application in a safe and sane manner"
+HOMEPAGE="http://chrootsafe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN//_}/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=( "${FILESDIR}"/${P}-ldflags.patch )
+
+src_configure() {
+ econf --libexecdir="${EPREFIX}/usr/$(get_libdir)"
+}
+
+src_compile() {
+ emake CPPFLAGS="${CXXFLAGS}" CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ dolib.so chroot_safe.so
+ dosbin chroot_safe
+ sed -i -e "s:/chroot_safe::" "${ED}"/usr/sbin/chroot_safe \
+ || die "sed chroot_safe failed"
+ doman chroot_safe.1
+ dodoc CHANGES.txt
+}