summaryrefslogtreecommitdiff
path: root/app-admin/clustershell
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/clustershell
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/clustershell')
-rw-r--r--app-admin/clustershell/Manifest6
-rw-r--r--app-admin/clustershell/clustershell-1.6-r1.ebuild47
-rw-r--r--app-admin/clustershell/clustershell-1.6.ebuild45
-rw-r--r--app-admin/clustershell/clustershell-1.7.3.ebuild57
-rw-r--r--app-admin/clustershell/metadata.xml8
5 files changed, 163 insertions, 0 deletions
diff --git a/app-admin/clustershell/Manifest b/app-admin/clustershell/Manifest
new file mode 100644
index 000000000000..8599ad260b02
--- /dev/null
+++ b/app-admin/clustershell/Manifest
@@ -0,0 +1,6 @@
+DIST clustershell-1.6.tar.gz 950548 BLAKE2B e6b2eb236537b23e86f0942b56db3bab7d970870febe76b7dd80719f90d5cd8ac5c0b059695110f966fc3423b77c289c0b951e8c329f33905175004ee811b723 SHA512 d94979bf5b5ead406f49e4ba691cf8541c03398913eb2fb9da724f50ba8b47059b76ddb6058dc5aaea86bbc8588b4d9c75cc34a8a7a94dcfa184ca73250c3b02
+DIST clustershell-1.7.3.tar.gz 345447 BLAKE2B 45bf059670a71724d8614f9b084c5e865daa1fb8dd2268e572d1a30b4d69259162fda8ee22eb2cc22261773c4e34849d345147de76c1628422f6c326b746724d SHA512 acb8e8a5b4a576ee93fbe23a8d903bab813f4182b50d9cd752b3684c743e611d3ee3fcfde31818c0a92495a3ee7640094d4568a03fdbf543e398a1b741a978d4
+EBUILD clustershell-1.6-r1.ebuild 953 BLAKE2B 29d90f4d32e0dde737806c2d7a59c6891b0d3734ceda694f369ab9685a42f9a922d1f7541aa41f8fbb56428ea329dc36fa50143cc8ab83aa5d3955cb8f6f7030 SHA512 cd8694812a01006f3f66a797bad01037e22d28a581c286fa0d22fb1ad44bf13ee3c44278d1c575b609854094aac2f928df62a38d82661157935ce96c15ad9269
+EBUILD clustershell-1.6.ebuild 886 BLAKE2B f9bb4cbafde98c9c7e6bc217ec8b77664f9fdf2e92a51d4314a31ff945ca467e199a5bb63712b598a390eeae4780bc6032b5db3392500bf7d670688035cdf68c SHA512 4a87ed707eb37cee226e8e8e432e9445398903cf4df8d2a66447383b60ce481e048de427b8d7fc8c5d27742ea6a8c526d444581dbe43e26b35eb5a1a703ddff5
+EBUILD clustershell-1.7.3.ebuild 1178 BLAKE2B f34c186c9d67313ecd36c3f30e738d49cbd06b40a0554742963bbcf57b3a63b391d713e48b3e98b42122c5afbd6ea71ebf35512852ef5f8472e03fdf967e8339 SHA512 acb24ccfff54f345d031380cf344db5a8e27b31ec294b299d226d71547df80b1bcc2670ee30f55e1bffaf1e204f7d3b30ad5a482731bad2f847ea162c4f0e4e7
+MISC metadata.xml 257 BLAKE2B ab7ed946089a6a737244d144e97b9ab34ee6bf812bb341a994d1a3552d15c20186311322905354baa6353bed45b2248709e801558bc4c64a207a204f7e374e92 SHA512 a24cf6411331ed58ac1395d5f10e85530bbe2f7d9ca09121ac8e3ed3b518ad8b31ad50adb903404b41749c089bda33aa34bd28d8ba0da0b1f1b36620674e77be
diff --git a/app-admin/clustershell/clustershell-1.6-r1.ebuild b/app-admin/clustershell/clustershell-1.6-r1.ebuild
new file mode 100644
index 000000000000..faa5e3e63f9c
--- /dev/null
+++ b/app-admin/clustershell/clustershell-1.6-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: test phase
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+inherit distutils-r1
+
+DESCRIPTION="Python framework for efficient cluster administration"
+HOMEPAGE="https://cea-hpc.github.com/clustershell/"
+SRC_URI="https://github.com/cea-hpc/clustershell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CeCILL-C"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc libressl"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_install() {
+ distutils-r1_src_install
+
+ if use doc ; then
+ local i
+ for i in $(ls -I man "${S}"/doc) ; do
+ dodoc -r doc/${i}
+ done
+ fi
+
+ doman doc/man/man*/*
+
+ insinto /etc/${PN}
+ doins -r conf/*
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Some default system-wide config files have been installed into"
+ einfo "/etc/${PN}"
+ einfo
+}
diff --git a/app-admin/clustershell/clustershell-1.6.ebuild b/app-admin/clustershell/clustershell-1.6.ebuild
new file mode 100644
index 000000000000..6a13780d51c7
--- /dev/null
+++ b/app-admin/clustershell/clustershell-1.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: test phase
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+inherit distutils-r1
+
+DESCRIPTION="Python framework for efficient cluster administration"
+HOMEPAGE="https://cea-hpc.github.com/clustershell/"
+SRC_URI="https://github.com/cea-hpc/clustershell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CeCILL-C"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+RDEPEND="dev-libs/openssl"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_install() {
+ distutils-r1_src_install
+
+ if use doc ; then
+ local i
+ for i in $(ls -I man "${S}"/doc) ; do
+ dodoc -r doc/${i}
+ done
+ fi
+
+ doman doc/man/man*/*
+
+ insinto /etc/${PN}
+ doins -r conf/*
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Some default system-wide config files have been installed into"
+ einfo "/etc/${PN}"
+ einfo
+}
diff --git a/app-admin/clustershell/clustershell-1.7.3.ebuild b/app-admin/clustershell/clustershell-1.7.3.ebuild
new file mode 100644
index 000000000000..3756006e28cf
--- /dev/null
+++ b/app-admin/clustershell/clustershell-1.7.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: test phase
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+inherit distutils-r1
+
+DESCRIPTION="Python framework for efficient cluster administration"
+HOMEPAGE="https://cea-hpc.github.com/clustershell/"
+SRC_URI="https://github.com/cea-hpc/clustershell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc libressl test"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND="${CDEPEND}
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+
+RESTRICT="test" # currently fail
+
+src_install() {
+ distutils-r1_src_install
+
+ if use doc ; then
+ local i
+ for i in $(ls -I man "${S}"/doc) ; do
+ dodoc -r doc/${i}
+ done
+ fi
+
+ doman doc/man/man*/*
+
+ insinto /etc/${PN}
+ doins -r conf/*
+}
+
+python_test() {
+ cd tests || die
+ nosetests -sv --all-modules || die
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Some default system-wide config files have been installed into"
+ einfo "/etc/${PN}"
+ einfo
+}
diff --git a/app-admin/clustershell/metadata.xml b/app-admin/clustershell/metadata.xml
new file mode 100644
index 000000000000..5d5942742693
--- /dev/null
+++ b/app-admin/clustershell/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">cea-hpc/clustershell</remote-id>
+ </upstream>
+</pkgmetadata>