summaryrefslogtreecommitdiff
path: root/app-admin/clustershell
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-25 15:53:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-25 15:53:45 +0000
commit83ebb477861172671f6796999e016400b659d65f (patch)
tree0cec26d10b5fcfee34cd56a952e8111f306feefb /app-admin/clustershell
parentbaeb826318951e5c82b18c1e9ee120ac5dcf0b94 (diff)
gentoo auto-resync : 25:02:2023 - 15:53:45
Diffstat (limited to 'app-admin/clustershell')
-rw-r--r--app-admin/clustershell/Manifest2
-rw-r--r--app-admin/clustershell/clustershell-1.9.1.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/app-admin/clustershell/Manifest b/app-admin/clustershell/Manifest
index 36b5bc393dd6..6ddf5060848f 100644
--- a/app-admin/clustershell/Manifest
+++ b/app-admin/clustershell/Manifest
@@ -1,3 +1,5 @@
+DIST clustershell-1.9.1.gh.tar.gz 383917 BLAKE2B 90d8c8390453a2c843bbb909a741d24d5f8e4b8eb03631bbe81b98973fce95d96dd3e68d0b951bc23d067057222c858e5041a3bafde200e0e2d14a0be995689f SHA512 32ee8b43d92e7ada8c81facc6a0609c39beee9189fa6fb9c2237387a58134f99fb2e6ab6e5de35c8e6fc8d3cef57f74f4c08b14968484546859071dff2594eb1
DIST clustershell-1.9.gh.tar.gz 382574 BLAKE2B 031eb9683db330f3b90ac06fa9a0409ea72c1be3d83c8d0519e0080ead715386043c925a6dbaeafdb38351c54f1508c050279603cd81bc2de60ba2df5733f636 SHA512 9eb4e9663a6381fa27311d1d70002ba64066ee6e2e08aaf772974d8097c6ca2d020563fc8478064e76bc6e56d37ed7eefc2919db99a2f5b26bd878fa7b764a15
+EBUILD clustershell-1.9.1.ebuild 1134 BLAKE2B a382459c7be182f5b215aa6775a4f05098d4d513423fb40f314d014a7f126c6d626e75777f0757e3411cf2cf5dfab87ba815afa34ff3542ca27a995dcee006c4 SHA512 52118a47e4edd4010e814ea82ff0245140a6daa3799e440cde1b8591065dfb6bb37fdaf24a75c44a3894849db50d30258aaef2ca6e335cd0cf97e5e06712d301
EBUILD clustershell-1.9.ebuild 1156 BLAKE2B c2aa3e12edaf2a17208373c440617d7dceebbe018c7364ba3e6f50ab954f3274e9b3236a8e1b1843bcc7eb579f8230e9d1f783d7ba0ce3c11e8ec9a0f27401be SHA512 0bb4cddc8fafee1e860474b822b82bc29f5ad7d0bb63f7062c0dd98ac4955a2f6f61e169a9882d534ac555959f5f1366b9185a81c00bb4768e6c50d3fa81e72e
MISC metadata.xml 610 BLAKE2B 1baa68f298ccc1117524968f3ddef220f068e876cfe8d6e5243a5f3144bfa8db21aa93bdb92efd3e7082c0e32b2747d2b544687114b09b78f823636d9b9be5b7 SHA512 0e4a89c4ea24577e065ed6b1a5714cfabea0a3452d546a16824608d2fdbc97ac39fb43d49c7adb279342a774b6719d52707b54091fc30326cbef14755fc04e0f
diff --git a/app-admin/clustershell/clustershell-1.9.1.ebuild b/app-admin/clustershell/clustershell-1.9.1.ebuild
new file mode 100644
index 000000000000..a630103853a9
--- /dev/null
+++ b/app-admin/clustershell/clustershell-1.9.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python framework for efficient cluster administration"
+HOMEPAGE="https://github.com/cea-hpc/clustershell/"
+SRC_URI="
+ https://github.com/cea-hpc/clustershell/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ app-shells/pdsh
+ net-misc/openssh
+ sys-devel/bc
+ )
+"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ default
+
+ # remove test sets that require working ssh connection
+ rm tests/{CLIClush,TaskDistant*}Test.py || die
+}
+
+python_test() {
+ cd tests || die
+ # Automatic discovery does not work
+ "${EPYTHON}" -m unittest_or_fail -v *.py || die "Tests failed with ${EPYTHON}"
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}
+
+pkg_postinst() {
+ einfo "Some default system-wide config files have been installed into"
+ einfo "/etc/${PN}"
+}