summaryrefslogtreecommitdiff
path: root/app-admin/conky/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /app-admin/conky/files
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'app-admin/conky/files')
-rw-r--r--app-admin/conky/files/conky-1.10.4-x11-build.patch31
-rw-r--r--app-admin/conky/files/conky-1.10.8-portmon.patch20
2 files changed, 20 insertions, 31 deletions
diff --git a/app-admin/conky/files/conky-1.10.4-x11-build.patch b/app-admin/conky/files/conky-1.10.4-x11-build.patch
deleted file mode 100644
index eb113a47fd57..000000000000
--- a/app-admin/conky/files/conky-1.10.4-x11-build.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 178015a9495b7d40031ed7459e4f6b6731633a7c Mon Sep 17 00:00:00 2001
-From: shizeeg <shizeeque@gmail.com>
-Date: Thu, 8 Sep 2016 18:24:29 +0300
-Subject: [PATCH] Fix build without X11 (#317)
-
----
- src/conky.cc | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/src/conky.cc b/src/conky.cc
-index 0a812fc..4c5da94 100644
---- a/src/conky.cc
-+++ b/src/conky.cc
-@@ -1404,6 +1404,9 @@ static void draw_string(const char *s)
-
- int draw_each_line_inner(char *s, int special_index, int last_special_applied)
- {
-+#ifndef BUILD_X11
-+ static int cur_x, cur_y; /* current x and y for drawing */
-+#endif
- #ifdef BUILD_X11
- int font_h = 0;
- int cur_y_add = 0;
-@@ -1934,6 +1937,7 @@ static void draw_text(void)
-
- static void draw_stuff(void)
- {
-+ static int text_offset_x, text_offset_y; /* offset for start position */
- text_offset_x = text_offset_y = 0;
- #ifdef BUILD_IMLIB2
- cimlib_render(text_start_x, text_start_y, window.width, window.height);
diff --git a/app-admin/conky/files/conky-1.10.8-portmon.patch b/app-admin/conky/files/conky-1.10.8-portmon.patch
new file mode 100644
index 000000000000..e7b17dd1119a
--- /dev/null
+++ b/app-admin/conky/files/conky-1.10.8-portmon.patch
@@ -0,0 +1,20 @@
+--- conky-1.10.8/src/CMakeLists.txt 2019-03-09 08:24:26.315879386 +0100
++++ conky-1.10.8/src/CMakeLists.txt 2019-03-09 08:24:38.555878656 +0100
+@@ -220,6 +220,15 @@
+ install(TARGETS
+ conky
+ RUNTIME DESTINATION bin
+- LIBRARY DESTINATION lib
+- ARCHIVE DESTINATION lib
++ LIBRARY DESTINATION ${LIB_INSTALL_DIR}
++ ARCHIVE DESTINATION ${LIB_INSTALL_DIR}
+ )
++
++if(BUILD_PORT_MONITORS)
++ install(TARGETS
++ tcp-portmon
++ RUNTIME DESTINATION bin
++ LIBRARY DESTINATION ${LIB_INSTALL_DIR}
++ ARCHIVE DESTINATION ${LIB_INSTALL_DIR}
++)
++endif(BUILD_PORT_MONITORS)