summaryrefslogtreecommitdiff
path: root/app-admin/dio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-08 20:11:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-08 20:11:47 +0100
commitf625b9919a60a30f1bd860f7d1b2eac183ced593 (patch)
tree7543f00925ff7277e31881de0a87801681f6f92f /app-admin/dio
parente3872864be25f7421015bef2732fa57c0c9fb726 (diff)
gentoo resync : 08.08.2018
Diffstat (limited to 'app-admin/dio')
-rw-r--r--app-admin/dio/Manifest4
-rw-r--r--app-admin/dio/dio-1.5.2-r1.ebuild41
-rw-r--r--app-admin/dio/dio-1.5.2.ebuild28
-rw-r--r--app-admin/dio/metadata.xml23
4 files changed, 62 insertions, 34 deletions
diff --git a/app-admin/dio/Manifest b/app-admin/dio/Manifest
index 7fad798ca5ae..8c31e697af42 100644
--- a/app-admin/dio/Manifest
+++ b/app-admin/dio/Manifest
@@ -1,3 +1,3 @@
DIST dio-1.5.2.tar.gz 44344 BLAKE2B 8e573cbf2ad1b717ffec09f20f8c7474841bc3e1635af35116d02b37af56ef3b4742e12725134d485f788e7abb595605640e19bd6f84bfd8f14289abf1695089 SHA512 366d2f2d25b8d16439c4a9aaa7cd775ddffb1022980675cdda8e2e4d4de3d3e5dcfa8d0c581b73fcfe4eff66ee8ef682f082c8788f514b7abdf1a2cb2159b9ba
-EBUILD dio-1.5.2.ebuild 549 BLAKE2B 3553d95a1b4f3b4c3b1ee239f063874149b1ddc46ad831908a32304f9a3c300d7eae3b0a793fbca25a9fc4c292e85435b95ae31f1930b3cc44b37b318c6e260d SHA512 4554efe518dc9a795a07751a85950bcc0b6edfa6cc35ce71cd0401ad84d63db832d9864a5f7144f9d28c320008ab06246b2dcaa7afbb37a29d213547e0399709
-MISC metadata.xml 255 BLAKE2B e8c22e505b32d30e59df38afab75c6a8bc0b4149e4f582eba4aa894352150792de4e054e8784a536c5249fdc0724e37b70860252e68d14fcac35ab7b56092c2a SHA512 f6ca4591922970e01ce40e4d88c39745f26dd2abf1c351b29f3d8d8b2c6a624fce4d0fcd18d6acfd1eabe6642cd1028033e61eabca4ce6d19aa58838cde828bf
+EBUILD dio-1.5.2-r1.ebuild 871 BLAKE2B 05332002c8ed739e28b4b902f7404e00a248eca9ed747603e2fff5842a3f773e1076bd31b11b75c6a7cdcc73dba284407695e5d3295d5f7ef0b1faa9f820cec4 SHA512 c65e8d195a6dd8fde56ebb3f9146233b7f06bb987884e311c49d90a572e1c1d49ee62ab6b8de9ef40f241b4ad49bd07ca18381bab404d8c53caaf6cc8fc18067
+MISC metadata.xml 912 BLAKE2B 5fe57b665757cb19dbe7e6efe2202d5cb4e8311fd21c3974a0c42017841330ce03242e5ac656818781cd39cb3ff62c05ed69ee008b8aa0c1809311819e23c588 SHA512 80995a42eba255a8e79ae0ae2596114b2703a433151b3f33d438a002c220194b14905221b9ab2e59185776c331ba22342c04d3ebf5aa8297b1ef988c45621f62
diff --git a/app-admin/dio/dio-1.5.2-r1.ebuild b/app-admin/dio/dio-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..2a0d993e8a0e
--- /dev/null
+++ b/app-admin/dio/dio-1.5.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="A device I/O monitoring tool"
+HOMEPAGE="https://github.com/donaldmcintosh/dio"
+SRC_URI="https://github.com/donaldmcintosh/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}/src"
+
+DOCS=( "README" "../README.md" )
+HTML_DOCS=( "../site/www.diodio.org/." )
+
+src_prepare() {
+ # Include the 'tinfo' lib, if sys-libs/ncurses is compiled with USE="tinfo"
+ if has_version -d 'sys-libs/ncurses[tinfo]'; then
+ sed -e 's/lcurses/& -ltinfo/' -i Makefile || die
+ fi
+
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin dio
+ doman dio.1
+ einstalldocs
+}
diff --git a/app-admin/dio/dio-1.5.2.ebuild b/app-admin/dio/dio-1.5.2.ebuild
deleted file mode 100644
index 6087eb8c5354..000000000000
--- a/app-admin/dio/dio-1.5.2.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit toolchain-funcs
-
-DESCRIPTION="dio - Device I/O monitoring tool"
-HOMEPAGE="https://github.com/donaldmcintosh/dio"
-SRC_URI="https://github.com/donaldmcintosh/dio/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="sys-libs/ncurses:0"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${P}/src"
-
-src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
-}
-
-src_install() {
- dobin dio
- doman dio.1
-}
diff --git a/app-admin/dio/metadata.xml b/app-admin/dio/metadata.xml
index ebf597f23ef3..021428c4e44c 100644
--- a/app-admin/dio/metadata.xml
+++ b/app-admin/dio/metadata.xml
@@ -1,8 +1,23 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="github">donaldmcintosh/dio</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ It samples kernel statistics at the specified time interval
+ and uses them to derive useful realtime and cumulative performance statistics.
+ The output is presented in a standard terminal window using the standard curses library,
+ which contains the output on visible terminal.
+ The approach offers a more intuitive visual presentation of the data.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/donaldmcintosh/dio/issues</bugs-to>
+ <remote-id type="github">donaldmcintosh/dio</remote-id>
+ </upstream>
</pkgmetadata>