summaryrefslogtreecommitdiff
path: root/app-admin/djbdns-logparse/djbdns-logparse-0.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-23 17:30:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-23 17:30:18 +0100
commit0e7ef53ddcc33809bcb2644d3649617113b78ea3 (patch)
treef1665ac62e9addb6b2c3663e7f7507b84c82a43e /app-admin/djbdns-logparse/djbdns-logparse-0.0.2.ebuild
parent55a7866dd6169a108d3a9e8d6696a970dea8a0b6 (diff)
gentoo auto-resync : 23:09:2022 - 17:30:17
Diffstat (limited to 'app-admin/djbdns-logparse/djbdns-logparse-0.0.2.ebuild')
-rw-r--r--app-admin/djbdns-logparse/djbdns-logparse-0.0.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-admin/djbdns-logparse/djbdns-logparse-0.0.2.ebuild b/app-admin/djbdns-logparse/djbdns-logparse-0.0.2.ebuild
new file mode 100644
index 000000000000..a37424d8def8
--- /dev/null
+++ b/app-admin/djbdns-logparse/djbdns-logparse-0.0.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Make tinydns and dnscache logs human-readable"
+HOMEPAGE="http://michael.orlitzky.com/code/djbdns-logparse.xhtml"
+SRC_URI="http://michael.orlitzky.com/code/releases/${P}.tar.gz"
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# djbdns-logparse pipes the logs through the "tai64nlocal" program
+# that comes with sys-process/daemontools.
+RDEPEND="sys-process/daemontools"
+BDEPEND="test? ( ${RDEPEND} )"
+
+python_install_all() {
+ doman "doc/man1/${PN}.1"
+ local DOCS=( doc/README )
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ esetup.py test
+}