summaryrefslogtreecommitdiff
path: root/app-admin/docker-bench/docker-bench-0.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /app-admin/docker-bench/docker-bench-0.5.0.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'app-admin/docker-bench/docker-bench-0.5.0.ebuild')
-rw-r--r--app-admin/docker-bench/docker-bench-0.5.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-admin/docker-bench/docker-bench-0.5.0.ebuild b/app-admin/docker-bench/docker-bench-0.5.0.ebuild
new file mode 100644
index 000000000000..013113aeb31b
--- /dev/null
+++ b/app-admin/docker-bench/docker-bench-0.5.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="Docker Bench for Security runs the CIS Docker Benchmark"
+HOMEPAGE="https://github.com/aquasecurity/docker-bench"
+SRC_URI="https://github.com/aquasecurity/docker-bench/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-vendor.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ ego build -mod=vendor -o ${PN} .
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /etc/docker-bench/
+ doins -r cfg
+}