summaryrefslogtreecommitdiff
path: root/app-admin/exo/exo-1.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /app-admin/exo/exo-1.9.0.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'app-admin/exo/exo-1.9.0.ebuild')
-rw-r--r--app-admin/exo/exo-1.9.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-admin/exo/exo-1.9.0.ebuild b/app-admin/exo/exo-1.9.0.ebuild
new file mode 100644
index 000000000000..0af1e7521f7a
--- /dev/null
+++ b/app-admin/exo/exo-1.9.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Command-line tool for everything at Exoscale: compute, storage, dns."
+HOMEPAGE="https://exoscale.github.io/cli"
+SRC_URI="https://github.com/exoscale/cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+DEPEND="dev-lang/go:="
+RESTRICT="strip"
+
+S="${WORKDIR}/cli-${PV}"
+
+src_compile() {
+ go build -mod vendor -o ${PN} || die "build failed"
+}
+
+src_install() {
+ dobin ${PN}
+}