summaryrefslogtreecommitdiff
path: root/app-admin/fetchlog
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/fetchlog
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/fetchlog')
-rw-r--r--app-admin/fetchlog/Manifest4
-rw-r--r--app-admin/fetchlog/fetchlog-1.4-r1.ebuild45
-rw-r--r--app-admin/fetchlog/files/fetchlog-1.4-fix-build-system.patch30
-rw-r--r--app-admin/fetchlog/metadata.xml8
4 files changed, 87 insertions, 0 deletions
diff --git a/app-admin/fetchlog/Manifest b/app-admin/fetchlog/Manifest
new file mode 100644
index 000000000000..9e1c7b03b372
--- /dev/null
+++ b/app-admin/fetchlog/Manifest
@@ -0,0 +1,4 @@
+AUX fetchlog-1.4-fix-build-system.patch 631 BLAKE2B ebbc0d0e90c5183a2ac396ffc26356223b5b8072100a9a6dc2f7fd0c9c94287213f7f8f8749e3e54612f7c777848012f92fccfbb02295345d578dcbd974f3091 SHA512 480a30e040f56e3e1cf21172dc7f7f060fa81a8a0efb95e15a20b7762444b356547435f3eacc4cdb7a504f3049f6b05a7fab219f6cab9d3fe7901968a69c796e
+DIST fetchlog-1.4.tar.gz 32393 BLAKE2B 2741c536dfb17414ffaf90cebd9f8c7c1a1c80edb30bc726f15aa6acd610a07afb926c2566d27b30125e7f4733c1abde8eb81c68d81f609bc05328cf90755d44 SHA512 51590c0cdfa8f4a15fcb4a436375d960c25f35d84558ab46def58f83c97da30caee449eea7c62c539da786a613c2b1e51dbc223d70d56c21daad6e9faf8a51ad
+EBUILD fetchlog-1.4-r1.ebuild 901 BLAKE2B b63c8dedb7800b1d792ebaeefc371c92f1e4c0149814087a34c1621d28a59d84422a2e53c2f2a4fcaa5d9d9eed4ab214a888527efeba25a39c5eacc82a4c78ea SHA512 5dc6ccac654048c675b1d72f4ace6ce832dd79c5fb445257c4f0176d27d5f6a34460a9e3d879d949cb479fc9bae232d68388459b632dadfa859b72f1671e87dd
+MISC metadata.xml 250 BLAKE2B a7de32c64d6f141fafdc392101c9c7ddeabb84d3c2f452662c96e27aa5e5f9d3ce47336bc707eb61396b02bee553a624a75195b7bc84949aabb5b660b1800dab SHA512 c4bde4a741bd01c371d3a4dec51ba522ad6ccb2fb95214e41f93366bedd37d7ca1729e638a5aee8e6af9e2280ce6c06c80e404428516e6a5c86264a629e87fe9
diff --git a/app-admin/fetchlog/fetchlog-1.4-r1.ebuild b/app-admin/fetchlog/fetchlog-1.4-r1.ebuild
new file mode 100644
index 000000000000..c4313f546021
--- /dev/null
+++ b/app-admin/fetchlog/fetchlog-1.4-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Displays the last new messages of a logfile"
+HOMEPAGE="http://fetchlog.sourceforge.net/"
+SRC_URI="mirror://sourceforge/fetchlog/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~ppc64"
+IUSE="snmp"
+
+RDEPEND="
+ snmp? (
+ >=dev-perl/Net-SNMP-4.0.1-r2
+ >=net-analyzer/net-snmp-5.0.6
+ )"
+DEPEND=""
+
+PATCHES=( "${FILESDIR}"/${PN}-1.4-fix-build-system.patch )
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin fetchlog
+ einstalldocs
+ dodoc *cfg*
+ doman fetchlog.1
+}
+
+pkg_preinst() {
+ elog
+ elog "This utility can be used together with Nagios"
+ elog "To make use of these features you need to"
+ elog "install net-analyzer/nagios."
+ elog "This feature depends on SNMP, so make use you"
+ elog "have 'snmp' in your USE flags"
+ elog
+}
diff --git a/app-admin/fetchlog/files/fetchlog-1.4-fix-build-system.patch b/app-admin/fetchlog/files/fetchlog-1.4-fix-build-system.patch
new file mode 100644
index 000000000000..53c05d85f74c
--- /dev/null
+++ b/app-admin/fetchlog/files/fetchlog-1.4-fix-build-system.patch
@@ -0,0 +1,30 @@
+--- a/Makefile
++++ b/Makefile
+@@ -23,8 +23,8 @@
+ ### compiler
+
+ ### gcc
+-CC=gcc
+-CFLAGS= -O -Werror -Wall -Wcast-qual -Wstrict-prototypes \
++CC ?= gcc
++CFLAGS += -Wall -Wcast-qual -Wstrict-prototypes \
+ -Wmissing-prototypes -Wmissing-declarations -Winline -Wcast-align
+ ### cc
+ #CC=cc
+@@ -72,7 +72,7 @@
+
+ # compiler stuff
+ # --------------
+-CC_OPT= $(CFLAGS) -DFETCHLOG_VERSION_NO=\"$(FETCHLOG_VERSION)\" \
++CPPFLAGS += -DFETCHLOG_VERSION_NO=\"$(FETCHLOG_VERSION)\" \
+ $(HAS_MADVISE) $(HAS_REGEX)
+
+ # all
+@@ -82,7 +82,6 @@
+ # fetchlog
+ # -------
+ fetchlog: fetchlog.c
+- $(CC) $(CC_OPT) fetchlog.c -o fetchlog
+
+
+ # install
diff --git a/app-admin/fetchlog/metadata.xml b/app-admin/fetchlog/metadata.xml
new file mode 100644
index 000000000000..f45d03726427
--- /dev/null
+++ b/app-admin/fetchlog/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="sourceforge">fetchlog</remote-id>
+ </upstream>
+</pkgmetadata>