summaryrefslogtreecommitdiff
path: root/app-admin/lastpass-binary-component
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/lastpass-binary-component
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/lastpass-binary-component')
-rw-r--r--app-admin/lastpass-binary-component/Manifest3
-rw-r--r--app-admin/lastpass-binary-component/lastpass-binary-component-4.1.44_p20171210.ebuild118
-rw-r--r--app-admin/lastpass-binary-component/metadata.xml20
3 files changed, 141 insertions, 0 deletions
diff --git a/app-admin/lastpass-binary-component/Manifest b/app-admin/lastpass-binary-component/Manifest
new file mode 100644
index 000000000000..bf1f3ea2528f
--- /dev/null
+++ b/app-admin/lastpass-binary-component/Manifest
@@ -0,0 +1,3 @@
+DIST lastpass-binary-component-4.1.44_p20171210.tar.bz2 1625075 BLAKE2B 90812cfae90c90ab7f91ac293e501e9b8c6d0b4fca9e1f05e88865eb85042286308d2ce6eb90d306583aa9481de7588746a3402c3b4b9f29e2e540e4a4c2b287 SHA512 16ceebd054fe807975f838305044bf5e75ccbba2c592f7bf08af18d1209067c7e8b0e00457092242c3869de2ec5c59bfdfdb3ff06f801dbb2108b7dac1a7adbf
+EBUILD lastpass-binary-component-4.1.44_p20171210.ebuild 3659 BLAKE2B 3c5b5e500329013a373f05d94862fe6f1181ff6853623b709fd7385c985e7e7d61542df3d1fbff6f4d571ed328e306718e0401ecc55b4dfe5006c728f172d59e SHA512 7003c1bad71275ec8e1cebfd933b0087702ac65c3d8a5daa2655c7e65150986f8de1f1bfb89fb795a1ec72b0a86dae0138469e5e34023c2a3c03174a18c46f79
+MISC metadata.xml 816 BLAKE2B ea7163f64706263e360241192a07e1e12eabc6fb196e5029cec931c53dacad20a9a4d851402f8942120328aa551159e2ba340257d50a5fcc36f7a72145e13a18 SHA512 71eb5c8aa836f75a5bfed79d7398e30628a274586a019d094a114d582ae2011d148cae325eb79b67e64035822cd18f154b9626142a7b2cc4c57f1e40f2f15b6b
diff --git a/app-admin/lastpass-binary-component/lastpass-binary-component-4.1.44_p20171210.ebuild b/app-admin/lastpass-binary-component/lastpass-binary-component-4.1.44_p20171210.ebuild
new file mode 100644
index 000000000000..beff308bc57f
--- /dev/null
+++ b/app-admin/lastpass-binary-component/lastpass-binary-component-4.1.44_p20171210.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Binary component required by the LastPass Password Manager browser extension"
+HOMEPAGE="https://helpdesk.lastpass.com/downloading-and-installing/#h5"
+# sadly, upstream has no versioned distfiles
+SRC_URI="https://lastpass.com/lplinux.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="LastPass"
+SLOT="0"
+KEYWORDS="-* ~x86 ~amd64"
+RESTRICT="strip mirror" # We can't mirror it, but we can fetch it
+
+RDEPEND="
+ !!app-admin/lastpass
+"
+
+LASTPASS_EXEDIR=/opt/lastpass/
+
+QA_PREBUILT="
+ ${LASTPASS_EXEDIR}nplastpass*
+"
+
+S="${WORKDIR}"
+
+src_install() {
+ # This is based on the upstream installer script that's in the tarball
+ bin=nplastpass
+ use amd64 && bin="${bin}64"
+ exeinto ${LASTPASS_EXEDIR}
+ doexe "${S}"/${bin}
+
+ # Generate the policy file for Chrome/Chromium/Opera
+ cat >"${T}"/lastpass_policy.json <<-EOF || die
+ {
+ "ExtensionInstallSources": [
+ "https://lastpass.com/*",
+ "https://*.lastpass.com/*",
+ "https://d1jxck0p3rkj0.cloudfront.net/lastpass/*"
+ ]
+ }
+ EOF
+ # Install the policy file for Chrome/Chromium/Opera
+ for d in /etc/chromium /etc/opt/chrome; do
+ insinto ${d}/policies/managed
+ doins "${T}"/lastpass_policy.json
+ done
+
+ # Generate the app manifest for Chrome/Opera
+ cat >"${T}"/com.lastpass.nplastpass.json <<-EOF || die
+ {
+ "name": "com.lastpass.nplastpass",
+ "description": "LastPass",
+ "path": "${LASTPASS_EXEDIR}${bin}",
+ "type": "stdio",
+ "allowed_origins": [
+ "chrome-extension://hdokiejnpimakedhajhdlcegeplioahd/",
+ "chrome-extension://debgaelkhoipmbjnhpoblmbacnmmgbeg/",
+ "chrome-extension://hnjalnkldgigidggphhmacmimbdlafdo/",
+ "chrome-extension://hgnkdfamjgnljokmokheijphenjjhkjc/"
+ ]
+ }
+ EOF
+ # Install the app manifest for Chrome/Opera
+ # https://developer.chrome.com/apps/nativeMessaging
+ # https://dev.opera.com/extensions/message-passing/
+ insinto /etc/opt/chrome/native-messaging-hosts
+ doins "${T}"/com.lastpass.nplastpass.json
+
+ # Generate the app manifest for Chromium
+ cat >"${T}"/com.lastpass.nplastpass.json <<-EOF || die
+ {
+ "name": "com.lastpass.nplastpass",
+ "description": "LastPass",
+ "path": "${LASTPASS_EXEDIR}${bin}",
+ "type": "stdio",
+ "allowed_origins": [
+ "chrome-extension://hdokiejnpimakedhajhdlcegeplioahd/",
+ "chrome-extension://debgaelkhoipmbjnhpoblmbacnmmgbeg/",
+ "chrome-extension://hgnkdfamjgnljokmokheijphenjjhkjc/"
+ ]
+ }
+ EOF
+ # Install the app manifest for Chromium
+ # https://developer.chrome.com/apps/nativeMessaging
+ insinto /etc/chromium/native-messaging-hosts/
+ doins "${T}"/com.lastpass.nplastpass.json
+
+ # Generate the app manifest for Firefox
+ cat >"${T}"/com.lastpass.nplastpass.json <<-EOF || die
+ {
+ "name": "com.lastpass.nplastpass",
+ "description": "LastPass",
+ "path": "${LASTPASS_EXEDIR}${bin}",
+ "type": "stdio",
+ "allowed_extensions": [
+ "support@lastpass.com"
+ ]
+ }
+ EOF
+ # Install the app manifest for Firefox
+ # https://developer.mozilla.org/en-US/Add-ons/WebExtensions/Native_manifests#Manifest_location
+ insinto /usr/lib/mozilla/native-messaging-hosts/
+ doins "${T}"/com.lastpass.nplastpass.json
+}
+
+pkg_postinst() {
+ einfo "This package only installs the components required by the browser extension."
+ einfo "Visit the links below for your browser to install the extension itself:"
+ einfo "Chrome/Chromium: https://lastpass.com/dl/inline/?full=1"
+ einfo "Firefox: https://lastpass.com/lastpassffx/"
+ einfo "Opera: https://lastpass.com/dl/"
+ einfo
+ einfo "Chrome, Chromium and Opera users need to manually enable the binary component."
+ einfo "For more info, visit: https://lastpass.com/support.php?cmd=showfaq&id=5576"
+}
diff --git a/app-admin/lastpass-binary-component/metadata.xml b/app-admin/lastpass-binary-component/metadata.xml
new file mode 100644
index 000000000000..6f4f533e3c35
--- /dev/null
+++ b/app-admin/lastpass-binary-component/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gokturk@gentoo.org</email>
+ <name>Göktürk Yüksek</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ </maintainer>
+ <longdescription lang="en">
+ The binary features for Lastpass include faster encryption/decryption,
+ clipboard integration, smart card authentication and more for
+ <pkg>www-client/google-chrome</pkg>, <pkg>www-client/chromium</pkg>,
+ and <pkg>www-client/opera</pkg> web browsers. For
+ <pkg>www-client/firefox</pkg> this package is not required as the
+ extension bundles the binary components already.
+ </longdescription>
+</pkgmetadata>