summaryrefslogtreecommitdiff
path: root/app-admin/linode-cli/linode-cli-5.49.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-04 00:00:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-04 00:00:19 +0100
commit7f3fecbb5b871825fe9632f46659869cab6a3769 (patch)
treedd2be4fe7ee3475ca4ad093698f0f8fd1e0965dc /app-admin/linode-cli/linode-cli-5.49.0.ebuild
parenta98588cfddf3d6e88a5f17d7f399b695163c7a85 (diff)
gentoo auto-resync : 04:05:2024 - 00:00:19
Diffstat (limited to 'app-admin/linode-cli/linode-cli-5.49.0.ebuild')
-rw-r--r--app-admin/linode-cli/linode-cli-5.49.0.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/app-admin/linode-cli/linode-cli-5.49.0.ebuild b/app-admin/linode-cli/linode-cli-5.49.0.ebuild
deleted file mode 100644
index 0dde07261839..000000000000
--- a/app-admin/linode-cli/linode-cli-5.49.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1 pypi shell-completion
-
-DESCRIPTION="Official command-line interface for interacting with the Linode API"
-HOMEPAGE="https://github.com/linode/linode-cli https://www.linode.com/"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-# Tests require network, a linode account and an API key.
-# WARNING: tests will incur costs and will wipe the account.
-RESTRICT="test"
-
-RDEPEND="
- dev-python/boto3[${PYTHON_USEDEP}]
- >=dev-python/linode-metadata-0.3[${PYTHON_USEDEP}]
- dev-python/openapi3[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/rich[${PYTHON_USEDEP}]
- <dev-python/urllib3-3[${PYTHON_USEDEP}]
-"
-
-python_install_all() {
- distutils-r1_python_install_all
-
- PYTHONPATH=. ${EPYTHON} linodecli --skip-config completion bash > "${T}/${PN}".bash || die
- PYTHONPATH=. ${EPYTHON} linodecli --skip-config completion fish > "${T}/${PN}".fish || die
-
- newbashcomp "${T}/${PN}".bash ${PN}
- newfishcomp "${T}/${PN}".fish ${PN}
-
- dosym ${PN} "$(get_bashcompdir)"/linode
- dosym ${PN} "$(get_bashcompdir)"/lin
- dosym ${PN} "$(get_fishcompdir)"/linode
- dosym ${PN} "$(get_fishcompdir)"/lin
-}