summaryrefslogtreecommitdiff
path: root/app-admin/linode-cli
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-14 11:06:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-14 11:06:13 +0100
commite000645bea7492c9f5277722c0ada7e1ee0b4833 (patch)
treea604499d25e682002ec55cc5e7d14e0c53809199 /app-admin/linode-cli
parentbe8708090362c01c6111c4b76f1e395c14d86e00 (diff)
gentoo auto-resync : 14:08:2024 - 11:06:13
Diffstat (limited to 'app-admin/linode-cli')
-rw-r--r--app-admin/linode-cli/Manifest2
-rw-r--r--app-admin/linode-cli/linode-cli-5.51.0.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/app-admin/linode-cli/Manifest b/app-admin/linode-cli/Manifest
index 363bf907c1d2..89093c877a92 100644
--- a/app-admin/linode-cli/Manifest
+++ b/app-admin/linode-cli/Manifest
@@ -1,3 +1,5 @@
DIST linode_cli-5.50.0.tar.gz 146902 BLAKE2B ebe83454f06bc281a91dcc276db7378779d73717ca49bbcc81fe59e61c6eb448d7a7bde9e5482bb21ca05c0484001f86dab4b4296011ecbb156c13b38573f7ea SHA512 3fb95f76c19f17f897ebce3bfb6d32de1f9a2ed2d8ba9078180e465acbe20b873a59092809a2c766c326e0c5e27c983c84aef9ae7c210004f51b2b62225694e1
+DIST linode_cli-5.51.0.tar.gz 154535 BLAKE2B 7cd59795bed698ec73510d7881a2768f31fb405619e991608b711433cc971aa024d173b54a184b96aa7de9db879593fd358d5b4cdd140c699f941ad19f29bdd4 SHA512 ca9fad8af34e84993c8be9d6f253955389df32d42e6a881b72b2445a71951b5d2458e8580189fdc26d3c870ff7af20fce71a4a838aeb0d96380b0588e1f34146
EBUILD linode-cli-5.50.0.ebuild 1338 BLAKE2B 8cdcd6d7ad933ac3ee00ad19a9f900961de75404b4e9b36f8043cca9e76e6db846c1ec4a9490901edd15cba501fcf9671a808444f144962b63574c60281343cd SHA512 396a0108dfddab2e2c5ba57caec6d599d3723807cce301a2545415f0e0c625e6f0c0e846b2b243bba459695928c360c35ed04ea027ac236c450530458c6893d9
+EBUILD linode-cli-5.51.0.ebuild 1338 BLAKE2B 8cdcd6d7ad933ac3ee00ad19a9f900961de75404b4e9b36f8043cca9e76e6db846c1ec4a9490901edd15cba501fcf9671a808444f144962b63574c60281343cd SHA512 396a0108dfddab2e2c5ba57caec6d599d3723807cce301a2545415f0e0c625e6f0c0e846b2b243bba459695928c360c35ed04ea027ac236c450530458c6893d9
MISC metadata.xml 483 BLAKE2B 7b3a4b824e16ba32424777359d0daf09d17cc498a06f9ce5acfd7baec80ffea26220145676f37edfe46302257fd0a2bc5071d60f955dc19cda582419b2027f5c SHA512 33c8fae2235a7a6d2653a4db3341b2d69e390ed6dfa33868dd7e6b3a384f78013ae3c42a91d8eddd25929086f7705ce0869a34e28eedadb497e286ae59570be4
diff --git a/app-admin/linode-cli/linode-cli-5.51.0.ebuild b/app-admin/linode-cli/linode-cli-5.51.0.ebuild
new file mode 100644
index 000000000000..21d1ca44d811
--- /dev/null
+++ b/app-admin/linode-cli/linode-cli-5.51.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi shell-completion
+
+DESCRIPTION="Official command-line interface for interacting with the Linode API"
+HOMEPAGE="https://github.com/linode/linode-cli https://www.linode.com/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Tests require network, a linode account and an API key.
+# WARNING: tests will incur costs and will wipe the account.
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/boto3[${PYTHON_USEDEP}]
+ >=dev-python/linode-metadata-0.3[${PYTHON_USEDEP}]
+ dev-python/openapi3[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ <dev-python/urllib3-3[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ PYTHONPATH=. ${EPYTHON} linodecli completion bash > "${T}/${PN}".bash || die
+ PYTHONPATH=. ${EPYTHON} linodecli completion fish > "${T}/${PN}".fish || die
+
+ newbashcomp "${T}/${PN}".bash ${PN}
+ newfishcomp "${T}/${PN}".fish ${PN}
+
+ dosym ${PN} "$(get_bashcompdir)"/linode
+ dosym ${PN} "$(get_bashcompdir)"/lin
+ dosym ${PN} "$(get_fishcompdir)"/linode
+ dosym ${PN} "$(get_fishcompdir)"/lin
+}