summaryrefslogtreecommitdiff
path: root/app-admin/longrun/longrun-0.9-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
commit76dfef0cec9170000357d2f354e412daf48941fc (patch)
tree56647120c0ee20ab3494475c86722034cd194b02 /app-admin/longrun/longrun-0.9-r4.ebuild
parentccf84bcd604130256d1377cd58f0a634ae6ee20f (diff)
gentoo resync : 30.12.2017
Diffstat (limited to 'app-admin/longrun/longrun-0.9-r4.ebuild')
-rw-r--r--app-admin/longrun/longrun-0.9-r4.ebuild38
1 files changed, 17 insertions, 21 deletions
diff --git a/app-admin/longrun/longrun-0.9-r4.ebuild b/app-admin/longrun/longrun-0.9-r4.ebuild
index afe681e3a693..0508c52ea188 100644
--- a/app-admin/longrun/longrun-0.9-r4.ebuild
+++ b/app-admin/longrun/longrun-0.9-r4.ebuild
@@ -1,54 +1,50 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-inherit eutils linux-info toolchain-funcs
+EAPI=6
+
+inherit linux-info toolchain-funcs
DESCRIPTION="A utility to control Transmeta's Crusoe and Efficeon processors"
HOMEPAGE="http://freshmeat.net/projects/longrun/"
DEBIAN_PATCH_VERSION="19"
-DEBIAN_PATCH="${PN}_${PV}-${DEBIAN_PATCH_VERSION}.diff.gz"
+DEBIAN_PATCH="${PN}_${PV}-${DEBIAN_PATCH_VERSION}.diff"
SRC_URI="
mirror://kernel/linux/utils/cpu/crusoe/${P}.tar.bz2
- mirror://debian/pool/main/l/${PN}/${DEBIAN_PATCH}"
+ mirror://debian/pool/main/l/${PN}/${DEBIAN_PATCH}.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-ppc x86"
IUSE=""
-DEPEND=""
+DEPEND="sys-apps/groff"
S=${WORKDIR}/${PN}
CONFIG_CHECK="~X86_MSR ~X86_CPUID"
-
ERROR_X86_MSR="
Longrun needs a MSR device to function. Please select
MSR under Processor type and features. It can be build
-directly into the kernel or as a module.
-"
-
+directly into the kernel or as a module."
ERROR_X86_CPUID="
Longrun needs a CPUID device to function. Please select
CPUID under Processor type and features. It can be
-build directly into the kernel or as a module.
-"
+build directly into the kernel or as a module."
-src_unpack() {
- unpack ${P}.tar.bz2
- cd "${S}"
- epatch "${DISTDIR}/${DEBIAN_PATCH}"
- epatch "${FILESDIR}/${PV}-makefile_cflags.patch"
- epatch "${FILESDIR}/${PV}-replace-loff_t.patch"
-}
+PATCHES=(
+ "${WORKDIR}"/${DEBIAN_PATCH}
+ "${FILESDIR}"/${PV}-makefile_cflags.patch
+ "${FILESDIR}"/${PV}-replace-loff_t.patch
+)
-src_compile() {
- emake CC="$(tc-getCC)" || die "emake failed"
+src_configure() {
+ tc-export CC
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ default
dodoc MAKEDEV-cpuid-msr
}