summaryrefslogtreecommitdiff
path: root/app-admin/mcollective
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/mcollective
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/mcollective')
-rw-r--r--app-admin/mcollective/Manifest6
-rw-r--r--app-admin/mcollective/files/mcollectived.initd28
-rw-r--r--app-admin/mcollective/mcollective-2.12.1.ebuild60
-rw-r--r--app-admin/mcollective/mcollective-2.12.2.ebuild60
-rw-r--r--app-admin/mcollective/metadata.xml17
5 files changed, 171 insertions, 0 deletions
diff --git a/app-admin/mcollective/Manifest b/app-admin/mcollective/Manifest
new file mode 100644
index 000000000000..0a91ee75d8dd
--- /dev/null
+++ b/app-admin/mcollective/Manifest
@@ -0,0 +1,6 @@
+AUX mcollectived.initd 497 BLAKE2B 1fe966f49117f9ea1b8c8ca4f5c92d5ddd7f8fb28658e4c3b016c193b69d1c42d35da85ace176279d09778c12fcc664748ea743c9b88219cb0fec2292ca867d4 SHA512 dc77a522e3ab6af3e23c559bfcb385033f2200b58b50db59000e7f56b2a789e8fbd83340f8ee494a1a9fdbdd1bd737a2b17ae4743823794264723fdc931ea6b0
+DIST mcollective-2.12.1.tar.gz 1517946 BLAKE2B 785acc53a4854f47caebe1d6a5f9cc850c3c33fd21e1b6e57d0d9761b2a7a3bbab2f2df398aa5344d90bc11397a545c8663d60ff3b2f6ff835fdc619d874928e SHA512 2398fb0202d8d5669a6efa81d96a87ee7e9221c1bc1b2e5be1917f2fec2527879b34be8df8c3052acf0ed58074b2da185f0837889d9300bde190bc95e8237d9a
+DIST mcollective-2.12.2.tar.gz 1517725 BLAKE2B e5f2b94843b95fa0749ed7e3e1ae52aeb485bf6644b64d971efd7d7a0e7bc806de0d2b00997c7e36d004fd78c479b9cf19b927e717ad0f3e4c13e820e5481637 SHA512 83be835499adf836797a67adda9be6d1bbf32524560ae51533875a1e2507599c7a0a1d2a76513669b919cf1eeceabdf13162eedb8972c74ecdeba5427b1701e4
+EBUILD mcollective-2.12.1.ebuild 1649 BLAKE2B b9fafb43c324d42bce01b95452bace880809ed327170098fb81c36fcc7c0505464624166ebcee596a9068742e1a6958e727052f553693db5e0275764180ca4aa SHA512 9ae9e1b5f0e5b31cd1dc44edc844253bfca1c80e8b626ec06a2e0a66eb08c0d935747a097f2f516d8e85f0ce79f28a675d1866b866789af47706048c92ad6c2f
+EBUILD mcollective-2.12.2.ebuild 1649 BLAKE2B b9fafb43c324d42bce01b95452bace880809ed327170098fb81c36fcc7c0505464624166ebcee596a9068742e1a6958e727052f553693db5e0275764180ca4aa SHA512 9ae9e1b5f0e5b31cd1dc44edc844253bfca1c80e8b626ec06a2e0a66eb08c0d935747a097f2f516d8e85f0ce79f28a675d1866b866789af47706048c92ad6c2f
+MISC metadata.xml 534 BLAKE2B e8866ac769b65ccc61dfe79fe5883bee78ea4066187b7136b899a1a16fa74952f88fd2b81376033d36418dc670d5669d9b65fc3195720ad95adf30bfe49729b1 SHA512 e94dd85f11b4f8b838e928220cb887eeb70860e6d04f03e904ddd4332baddd3b01221305e7229fb575585235436d0d942c116f821ef37adae636a7d5c6193199
diff --git a/app-admin/mcollective/files/mcollectived.initd b/app-admin/mcollective/files/mcollectived.initd
new file mode 100644
index 000000000000..8e295ceaa41c
--- /dev/null
+++ b/app-admin/mcollective/files/mcollectived.initd
@@ -0,0 +1,28 @@
+#!/sbin/openrc-run
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the Apache License, Version 2.0
+
+mcollectived="/usr/sbin/mcollectived"
+pidfile="/var/run/mcollectived"
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting mcollectived"
+ ${mcollectived} --pid=${pidfile} --config="/etc/mcollective/server.cfg"
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping mcollectived"
+ kill `cat ${pidfile}`
+ eend $?
+}
+
+restart() {
+ svc_stop
+ sleep 2
+ svc_start
+}
diff --git a/app-admin/mcollective/mcollective-2.12.1.ebuild b/app-admin/mcollective/mcollective-2.12.1.ebuild
new file mode 100644
index 000000000000..e5ded06a8259
--- /dev/null
+++ b/app-admin/mcollective/mcollective-2.12.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+inherit ruby-ng
+
+DESCRIPTION="Framework to build server orchestration or parallel job execution
+systems"
+HOMEPAGE="https://docs.puppet.com/mcollective/"
+SRC_URI="https://github.com/puppetlabs/marionette-collective/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/all/marionette-collective-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc +client"
+
+DEPEND=""
+RDEPEND=">=dev-ruby/stomp-1.4.4"
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+each_ruby_install() {
+ cd "marionette-collective-${PV}"
+ doruby -r lib/*
+ insinto /usr/share/mcollective
+ use client && dosbin bin/mco
+ dosbin bin/mcollectived
+ if use doc ; then
+ dohtml -r doc/*
+ insinto /usr/share/doc/${P}/ext
+ doins -r ext/*
+ fi
+ newinitd "${FILESDIR}"/mcollectived.initd mcollectived
+ insinto /etc/mcollective
+ cd etc
+ for cfg in *.dist ; do
+ newins "${cfg}" "${cfg%%.dist}"
+ sed -i -e "s:^libdir.*:libdir = /usr/share/mcollective/plugins:" \
+ "${D}"/etc/mcollective/${cfg%%.dist} || die "sed failed"
+ done
+ insinto /etc/mcollective/plugin.d
+}
+
+pkg_postinst() {
+ einfo "Mcollective requires a stomp server installed and functioning before"
+ einfo "you can use it. The recommended server to use is ActiveMQ [1] but"
+ einfo "any other stomp compatible server should work."
+ einfo
+ einfo "It is recommended you read the \'getting started\' guide [2] if this"
+ einfo "is a new installation"
+ einfo
+ einfo "[1] https://activemq.apache.org/"
+ einfo "[2] https://code.google.com/p/mcollective/wiki/GettingStarted"
+}
diff --git a/app-admin/mcollective/mcollective-2.12.2.ebuild b/app-admin/mcollective/mcollective-2.12.2.ebuild
new file mode 100644
index 000000000000..e5ded06a8259
--- /dev/null
+++ b/app-admin/mcollective/mcollective-2.12.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+inherit ruby-ng
+
+DESCRIPTION="Framework to build server orchestration or parallel job execution
+systems"
+HOMEPAGE="https://docs.puppet.com/mcollective/"
+SRC_URI="https://github.com/puppetlabs/marionette-collective/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/all/marionette-collective-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc +client"
+
+DEPEND=""
+RDEPEND=">=dev-ruby/stomp-1.4.4"
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+each_ruby_install() {
+ cd "marionette-collective-${PV}"
+ doruby -r lib/*
+ insinto /usr/share/mcollective
+ use client && dosbin bin/mco
+ dosbin bin/mcollectived
+ if use doc ; then
+ dohtml -r doc/*
+ insinto /usr/share/doc/${P}/ext
+ doins -r ext/*
+ fi
+ newinitd "${FILESDIR}"/mcollectived.initd mcollectived
+ insinto /etc/mcollective
+ cd etc
+ for cfg in *.dist ; do
+ newins "${cfg}" "${cfg%%.dist}"
+ sed -i -e "s:^libdir.*:libdir = /usr/share/mcollective/plugins:" \
+ "${D}"/etc/mcollective/${cfg%%.dist} || die "sed failed"
+ done
+ insinto /etc/mcollective/plugin.d
+}
+
+pkg_postinst() {
+ einfo "Mcollective requires a stomp server installed and functioning before"
+ einfo "you can use it. The recommended server to use is ActiveMQ [1] but"
+ einfo "any other stomp compatible server should work."
+ einfo
+ einfo "It is recommended you read the \'getting started\' guide [2] if this"
+ einfo "is a new installation"
+ einfo
+ einfo "[1] https://activemq.apache.org/"
+ einfo "[2] https://code.google.com/p/mcollective/wiki/GettingStarted"
+}
diff --git a/app-admin/mcollective/metadata.xml b/app-admin/mcollective/metadata.xml
new file mode 100644
index 000000000000..bbf72aa5c8c7
--- /dev/null
+++ b/app-admin/mcollective/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="client">Install client utilities</flag>
+ </use>
+ <longdescription lang="en">
+ mcollective is a framework to build server orchestration or parallel job
+ execution systems.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">puppetlabs/marionette-collective</remote-id>
+ </upstream>
+</pkgmetadata>