summaryrefslogtreecommitdiff
path: root/app-admin/openrc-settingsd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
commitb49088575eb777ced2551f484da86317332d6087 (patch)
treebf9a151cf2d61956340d555659ffc098ee1da466 /app-admin/openrc-settingsd
parent514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (diff)
gentoo resync : 24.07.2021
Diffstat (limited to 'app-admin/openrc-settingsd')
-rw-r--r--app-admin/openrc-settingsd/Manifest2
-rw-r--r--app-admin/openrc-settingsd/openrc-settingsd-1.1.0.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/app-admin/openrc-settingsd/Manifest b/app-admin/openrc-settingsd/Manifest
index 0babc34cacb2..a71e5ecfcb33 100644
--- a/app-admin/openrc-settingsd/Manifest
+++ b/app-admin/openrc-settingsd/Manifest
@@ -1,4 +1,6 @@
AUX openrc-settingsd-1.0.1-remove-bashisms.patch 2670 BLAKE2B 06b61db1c40ae4a99b5fd46c3f83eecb8428c5bef150be1f7d6b0e25ab4667cae40a4664720586540a7d180218e5b4e23ad4fafeaaadce112a9566e412c4f9a3 SHA512 c4715aa4bdf35011400d02971d2739db347aeed96bbffe42c56a47714a0554c69137fa4b239b0b8ad3eed118d1da2af8c26bd4eaf8e39fa19176c85ed9c289fa
DIST openrc-settingsd-1.0.1.tar.xz 243552 BLAKE2B 2abf084c59ef310ca72bf2d528c6f8f04b3a502ea421247989e5356e759f2850f1749ffae7592ff30c92a0496db01e9d5e55c2a4ae9dbd3a9954414d4eabd31b SHA512 1f04a4b078a5fb659573daec0962f819af7eaff17a6213c4881726833cf32becd71dd820cd63767e2933465df26b3e4a3475d94f23e203a6977298965c709b21
+DIST openrc-settingsd-v1.1.0.tar.bz2 41781 BLAKE2B 1a508c5751a3b2c734b533ebdf72d4c5fa97b67743caf5e47f06fc505a286e92167715e0ec706528a4e9a74d0aed9d78d6b6b2d542c1df3781d5bd76ff700b91 SHA512 f63aa624097a806094c51a6da8fc6f4962c3302ea0acf02be17744db9d5caf4cfd68294a8e8916e62eeeca722cadc571715b9751730f9d9cf1f9be66e93510f7
EBUILD openrc-settingsd-1.0.1-r1.ebuild 1459 BLAKE2B c6c15c6f92b560645982b0558585f7cdff35957e8eb7bb7b090fef2d30f7b0582c9dff2a547e1fbdd52eb2c3aff0684c8f8b32d3399a94be7127d5dbd8cc076f SHA512 a0a81314af123503b312cac28b6e2d4394ad1d1ae2f5c35f4f505919c3d278620a907ec111565c8f04021483cbba4bcd5648598f3dd2fb6e5f38f1d1d63e197a
+EBUILD openrc-settingsd-1.1.0.ebuild 1473 BLAKE2B fcbcc46ddaceba2870a1408e908a3f991e348a240fd12ab7352d75fe80ba575638fa359a54de606e2f5f3c42ad9ec8080ebb024f47ce0b10306b9e3a1fb7b004 SHA512 281592aab7ae5f570f469b3903d29f15bcd61192d59734e1f5127a6d6e57ab41e3f0d84d58ac03aed0b2c39e2ab4d5854c868b6b734087949286b1007603587c
MISC metadata.xml 375 BLAKE2B 2ef1245cabf20154d53ca5b9161f9e5055d38ede47687bc2314cf787c804dbff40a1278769fec061468c95139a8c5f9f573e06e901c580e6923e93b29e3db398 SHA512 489eae3aa828d6aeb43f3b24783777644f7abd7522d842c44918ba6c5fecf0ca9f02f91764f7f2566960283737f4a2c17f307f4f26e9d1c8ff92ee9e2e99e8fc
diff --git a/app-admin/openrc-settingsd/openrc-settingsd-1.1.0.ebuild b/app-admin/openrc-settingsd/openrc-settingsd-1.1.0.ebuild
new file mode 100644
index 000000000000..7a0eee93c891
--- /dev/null
+++ b/app-admin/openrc-settingsd/openrc-settingsd-1.1.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="System settings D-Bus service for OpenRC"
+HOMEPAGE="https://gitlab.com/postmarketOS/openrc-settingsd/"
+SRC_URI="https://gitlab.com/postmarketOS/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="systemd"
+
+DEPEND="
+ >=dev-libs/glib-2.30:2
+ dev-libs/libdaemon:0=
+ sys-apps/dbus
+ sys-apps/openrc:=
+ sys-auth/polkit
+"
+RDEPEND="
+ ${DEPEND}
+ systemd? ( >=sys-apps/systemd-197 )
+ !systemd? ( sys-auth/nss-myhostname !sys-apps/systemd )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_prepare() {
+ default
+ eautoreconf
+ sed -i -e 's:/sbin/runscript:/sbin/openrc-run:g' data/init.d/openrc-settingsd.in || die
+}
+
+src_configure() {
+ econf \
+ --with-pidfile="${EPREFIX}"/run/openrc-settingsd.pid
+}
+
+src_install() {
+ default
+ if use systemd; then
+ # Avoid file collision with systemd
+ rm -vr "${ED}"/usr/share/{dbus-1,polkit-1} "${ED}"/etc/dbus-1 || die "rm failed"
+ fi
+}
+
+pkg_postinst() {
+ if use systemd; then
+ elog "You installed ${PN} with USE=systemd. In this mode,"
+ elog "${PN} will not start via simple dbus activation, so you"
+ elog "will have to manually enable it as an rc service:"
+ elog " # /etc/init.d/openrc-settingsd start"
+ elog " # rc-update add openrc-settingsd default"
+ fi
+}