summaryrefslogtreecommitdiff
path: root/app-admin/pwman3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-28 12:00:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-28 12:00:19 +0100
commit7166f3a0a0b7886d340010458d0b130013cb9989 (patch)
tree3ff502007dde9dba943a004a3bf201ae4e0787bd /app-admin/pwman3
parent345c02ca33341652116ddec6705530223af2de85 (diff)
gentoo auto-resync : 28:08:2024 - 12:00:19
Diffstat (limited to 'app-admin/pwman3')
-rw-r--r--app-admin/pwman3/Manifest2
-rw-r--r--app-admin/pwman3/pwman3-0.13.1.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/app-admin/pwman3/Manifest b/app-admin/pwman3/Manifest
index 18a5e2209175..aae8528828c8 100644
--- a/app-admin/pwman3/Manifest
+++ b/app-admin/pwman3/Manifest
@@ -1,3 +1,5 @@
DIST pwman3-0.12.2.tar.gz 76744 BLAKE2B 5223169a267f0c35bcb26499138c9b768c6e29c4ce39d4fb89c56eb72d24a9729159bed93af24e12f1e0e6c1569586772eb36954afd51afc7c97c9de898346e5 SHA512 587839e7d532ef3c53e2c429b086eb6bd59290ce43687034400f8e0772cc4e97c9296694ad83c5fa3fdde37b8d8fef5bc150e9f81fcb9fe8712ffafb4be8b400
+DIST pwman3-0.13.1.tar.gz 81775 BLAKE2B d470735a8d514b335f2cf0c0ca84db2f362324262fd22617a98084d2e34b3b37447c2519204525a582a2bb5365f82452819270ad26195537fb776dedcf432bd2 SHA512 8b729968b7817a82692a8f9424f81882e4568cf8ecf5de52037a176ca028aaa58cf238f1d92dab02fbbe547fb872f74440d6eb0bc7a4b0a30649b6d9e3008ee4
EBUILD pwman3-0.12.2.ebuild 966 BLAKE2B 8bfc598ec4d12420b52b43d5a881d34e5bf00e29d2f4af5b1dcd2b3a0b991479d4a25010f96cbfa2dd164394f18487df52fd565bef14e972e355812a2d4457f8 SHA512 13be127f7da2720dd9132e94e4771bae341a6da0798adab09eff311ec26b66d13c57f64d48a972797c7e664849d5421249160b062415e989b72e4218cff18149
+EBUILD pwman3-0.13.1.ebuild 1120 BLAKE2B 5322d9070b518c693ab116dc076adb0642f0fb636f32e05f31501342f8a10be39ea7e45ddf83179589da9affd3aef0587b7a4149b0ce134a5e59096980eb0205 SHA512 270c7b58f4eb34b5b62bcb8257e41eacba71319981c6bbd36e4ebaab3475bd23b5b9861f1ae6995e13fa8dd046313d124e8ffb55b8c1655075d33821cf979a8f
MISC metadata.xml 944 BLAKE2B 24c67369c51110a1b5af7460665b6f55a129e86a5e61c4b9cafdf262862cbd21eff1a535dd5bf41c13ddbb3e13913ad06a5ec4bf63d5c8d5d13ee2764685cc2c SHA512 58aceafd3d884f3652682796932e9d6edf8ffecff9f61ee0b7c76f11897f5da20b18a603a8b7246da38ba507b25d5122b2f957349db94c0186abf94fc65c5602
diff --git a/app-admin/pwman3/pwman3-0.13.1.ebuild b/app-admin/pwman3/pwman3-0.13.1.ebuild
new file mode 100644
index 000000000000..678acd2e3e0b
--- /dev/null
+++ b/app-admin/pwman3/pwman3-0.13.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="A lightweight password-manager with multiple database backends"
+HOMEPAGE="https://pwman3.github.io/pwman3/"
+SRC_URI="https://github.com/pwman3/pwman3/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/cryptography-2.3[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${EPYTHON}" -m tests.test_pwman || die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "Support for mongodb" dev-python/pymongo
+ optfeature "Support for postgresql" dev-python/psycopg:2
+ optfeature "Support for mysql" dev-python/pymysql
+}