summaryrefslogtreecommitdiff
path: root/app-admin/qpage/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
commit76dfef0cec9170000357d2f354e412daf48941fc (patch)
tree56647120c0ee20ab3494475c86722034cd194b02 /app-admin/qpage/files
parentccf84bcd604130256d1377cd58f0a634ae6ee20f (diff)
gentoo resync : 30.12.2017
Diffstat (limited to 'app-admin/qpage/files')
-rw-r--r--app-admin/qpage/files/qpage-3.3-fix-build-system.patch21
-rw-r--r--app-admin/qpage/files/qpage-3.3-gentoo.patch16
2 files changed, 29 insertions, 8 deletions
diff --git a/app-admin/qpage/files/qpage-3.3-fix-build-system.patch b/app-admin/qpage/files/qpage-3.3-fix-build-system.patch
new file mode 100644
index 000000000000..0fd091df8e0e
--- /dev/null
+++ b/app-admin/qpage/files/qpage-3.3-fix-build-system.patch
@@ -0,0 +1,21 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -65,12 +65,12 @@
+ @exit 1
+
+ install: all
+- $(RM) $(bindir)/$(PROG)
+- $(MKDIR) -p $(bindir)
+- $(CP) $(PROG) $(bindir)
+- $(RM) $(mandir)/man1/$(PROG).1
+- $(MKDIR) -p $(mandir)/man1
+- $(CP) $(PROG).man $(mandir)/man1/$(PROG).1
++ $(RM) $(DESTDIR)$(bindir)/$(PROG)
++ $(MKDIR) -p $(DESTDIR)$(bindir)
++ $(CP) $(PROG) $(DESTDIR)$(bindir)
++ $(RM) $(DESTDIR)$(mandir)/man1/$(PROG).1
++ $(MKDIR) -p $(DESTDIR)$(mandir)/man1
++ $(CP) $(PROG).man $(DESTDIR)$(mandir)/man1/$(PROG).1
+
+ # $(INSTALL) S99qpage /etc/rc3.d
+ # ln /etc/rc3.d/S99qpage /etc/init.d/qpage
diff --git a/app-admin/qpage/files/qpage-3.3-gentoo.patch b/app-admin/qpage/files/qpage-3.3-gentoo.patch
index 577fb8a4ff3b..72baf899764e 100644
--- a/app-admin/qpage/files/qpage-3.3-gentoo.patch
+++ b/app-admin/qpage/files/qpage-3.3-gentoo.patch
@@ -1,5 +1,5 @@
---- config.input.dist 2003-04-11 14:03:36.000000000 -0700
-+++ config.input 2003-04-11 14:05:47.000000000 -0700
+--- a/config.input
++++ b/config.input
@@ -20,7 +20,7 @@
# See the QuickPage documentation for complete details about
# the syntax of the configuration file.
@@ -18,8 +18,8 @@
#
---- qpage.man.dist 2003-04-18 14:43:45.000000000 -0700
-+++ qpage.man 2003-04-18 14:43:55.000000000 -0700
+--- a/qpage.man
++++ b/qpage.man
@@ -867,7 +867,7 @@
must be able to detect when it's safe to send dial commands to the modem.
.LP
@@ -29,8 +29,8 @@
.SH SEE ALSO
.B RFC-1861
.SH KNOWN BUGS
---- example.cf.dist 2003-04-25 09:55:47.000000000 -0700
-+++ example.cf 2003-04-25 10:55:11.000000000 -0700
+--- a/example.cf
++++ b/example.cf
@@ -21,7 +21,7 @@
#
# modem=<modem name>
@@ -59,8 +59,8 @@
baudrate=1200
parity=even
allowpid=yes
---- ixo.c.dist 2003-04-25 11:36:30.000000000 -0700
-+++ ixo.c 2003-04-25 11:37:37.000000000 -0700
+--- a/ixo.c
++++ b/ixo.c
@@ -192,7 +192,7 @@
if ((i = read_modem(fd, seconds)) < 0)
return(NULL);