summaryrefslogtreecommitdiff
path: root/app-admin/qtpass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-02 06:31:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-02 06:31:11 +0000
commitff733bfb4d0bd82175e03255004faef8721b53ea (patch)
treec1061dbb981bc9e61d4f31b6610569711c7b482f /app-admin/qtpass
parentc4d4d544a37efc45bd5482e62e1fcdbe7d5993d3 (diff)
gentoo auto-resync : 02:01:2025 - 06:31:11
Diffstat (limited to 'app-admin/qtpass')
-rw-r--r--app-admin/qtpass/Manifest3
-rw-r--r--app-admin/qtpass/files/qtpass-1.4.0-qt-6.8-profiles.patch42
-rw-r--r--app-admin/qtpass/qtpass-1.4.0-r2.ebuild (renamed from app-admin/qtpass/qtpass-1.4.0-r1.ebuild)7
3 files changed, 49 insertions, 3 deletions
diff --git a/app-admin/qtpass/Manifest b/app-admin/qtpass/Manifest
index 82b768e4a904..b4fd3615c1a6 100644
--- a/app-admin/qtpass/Manifest
+++ b/app-admin/qtpass/Manifest
@@ -1,4 +1,5 @@
AUX qtpass-1.4.0-qt-6.8-buildfix.patch 691 BLAKE2B 8336eb26131e134389d3db751a5dcbf2375cd9569cbf3f7582fe9cb6ef6f08c1e2993c8d4a006e71cae55e5f8c13d8c58edaf1b2b1cdc9592c2c764514066630 SHA512 e80bc14d987e95c9a7160d5ad12579a5f43fa3671f879d5779482ce932a522bb4390792a00f03c9d234a19d43e6953ac1838a5db59347d881ec7762c0bb04870
+AUX qtpass-1.4.0-qt-6.8-profiles.patch 1387 BLAKE2B 93c4c80e32f848aa8d54056e31a47d7d28c1b031afa0b1e77de23105a1b079726ad323aae1ba7c9c042270fe66a5510c345693f159075b31bbc3a3d6269e2f9d SHA512 2526cb7de434642a29ada8cfdb914fd7f47ef649d5112e79143dba804ad8a08578a3db2aefb8b83a041caaf0cf98ded1db825c22f2237b606de99e0368b0f4c8
DIST qtpass-1.4.0.tar.gz 581368 BLAKE2B 12bf414ea781bad34d97fe28ae39f44e17812039f0d798162b6d875918f20a1583f7a53a1e98ed917edf41c15709c7693c7651205c5e4ec85860ee773350f075 SHA512 47c1284c10e0d8a3bf63c049fc29d785d1a53bef6f183bbe22efebf466371dd454a6e43c944739f487d609f3cde188701ba538e9cb8e2c7e5530f8fa6f992625
-EBUILD qtpass-1.4.0-r1.ebuild 1311 BLAKE2B ee3421016ccc0d4f94b105952c10df98c60f32d8974ed66c61213a0eb907f55e35305b009c9dc1add0fc135de832037dfec17388ff6bbf80992f1cce027881b5 SHA512 54b8d643f51fc62593cc70aa678bfb9685735ce48544f703b435bff1e6d2b117ca790b7dc9296461bcc00f4653f9f72debb747b030e0e746332477c4863719d3
+EBUILD qtpass-1.4.0-r2.ebuild 1354 BLAKE2B 949bcc2cab877edd31f234d0e376786e8e3996146cb3bac08b12db93a9a18c25b6b0e5cecc9c0c632f65f01032957f3a33056126d1e4e28f20da0fa38a505ec7 SHA512 cadf237199450df28411e36af89cbc83b6ebde39a9858fae9b505044fb73005250f921344fdda3b63afdc47d3cd3968879035e1e54d5788f258ee1638e4022bd
MISC metadata.xml 485 BLAKE2B 526a8203c5a8601f6bdae7fcc71fb26a6def402406493ebf95869624f8cea44a09fe2c23a041adebcd1bc5bc4ac9c64b2c33725b7d6d24bbf4f415926468a0ce SHA512 bc1c8273227625672ebfce619956a342dc3c74d412a16383c035e88b289a8dad9383ab00c9c5bd4f368dd8fefdad025b0d4f7c209b84251b0e26e16ef4149eef
diff --git a/app-admin/qtpass/files/qtpass-1.4.0-qt-6.8-profiles.patch b/app-admin/qtpass/files/qtpass-1.4.0-qt-6.8-profiles.patch
new file mode 100644
index 000000000000..61531e696755
--- /dev/null
+++ b/app-admin/qtpass/files/qtpass-1.4.0-qt-6.8-profiles.patch
@@ -0,0 +1,42 @@
+From 315397bb882a840eba68b343659b567a7409f34f Mon Sep 17 00:00:00 2001
+From: John Doe <johndoe@example.com>
+Date: Sat, 25 May 2024 01:23:33 +0800
+Subject: [PATCH] Fix multiple profiles issue for Qt6
+
+---
+ src/mainwindow.cpp | 4 ++++
+ src/mainwindow.h | 4 ++++
+ 2 files changed, 8 insertions(+)
+
+diff --git a/src/mainwindow.cpp b/src/mainwindow.cpp
+index b39d3147..66b87dc2 100644
+--- a/src/mainwindow.cpp
++++ b/src/mainwindow.cpp
+@@ -787,7 +787,11 @@ void MainWindow::updateProfileBox() {
+ * correct "profile"
+ * @param name
+ */
++#if QT_VERSION < QT_VERSION_CHECK(6, 0, 0)
+ void MainWindow::on_profileBox_currentIndexChanged(QString name) {
++#else
++void MainWindow::on_profileBox_currentTextChanged(QString name) {
++#endif
+ if (m_qtPass->isFreshStart() || name == QtPassSettings::getProfile())
+ return;
+
+diff --git a/src/mainwindow.h b/src/mainwindow.h
+index 172e326f..b5325f61 100644
+--- a/src/mainwindow.h
++++ b/src/mainwindow.h
+@@ -97,7 +97,11 @@ private slots:
+ void clearPanel(bool notify = true);
+ void on_lineEdit_textChanged(const QString &arg1);
+ void on_lineEdit_returnPressed();
++#if QT_VERSION < QT_VERSION_CHECK(6, 0, 0)
+ void on_profileBox_currentIndexChanged(QString);
++#else
++ void on_profileBox_currentTextChanged(QString);
++#endif
+ void showContextMenu(const QPoint &pos);
+ void showBrowserContextMenu(const QPoint &pos);
+ void openFolder();
diff --git a/app-admin/qtpass/qtpass-1.4.0-r1.ebuild b/app-admin/qtpass/qtpass-1.4.0-r2.ebuild
index e6a4bd5f91d9..b98ef039ff14 100644
--- a/app-admin/qtpass/qtpass-1.4.0-r1.ebuild
+++ b/app-admin/qtpass/qtpass-1.4.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -31,7 +31,10 @@ BDEPEND="dev-qt/qttools:6[linguist]"
DOCS=( {CHANGELOG,CONTRIBUTING,FAQ,README}.md )
-PATCHES=( "${FILESDIR}"/${P}-qt-6.8-buildfix.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-qt-6.8-buildfix.patch
+ "${FILESDIR}"/${P}-qt-6.8-profiles.patch
+)
src_prepare() {
default