summaryrefslogtreecommitdiff
path: root/app-admin/setools/setools-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
commit2891d29af8907ce881662f4a02844926d7a293c7 (patch)
tree56979d96839d0827aa52008b81b746b4934d88df /app-admin/setools/setools-9999.ebuild
parentde49812990871e1705b64051c35161d5e6400269 (diff)
gentoo resync : 31.12.2018
Diffstat (limited to 'app-admin/setools/setools-9999.ebuild')
-rw-r--r--app-admin/setools/setools-9999.ebuild32
1 files changed, 13 insertions, 19 deletions
diff --git a/app-admin/setools/setools-9999.ebuild b/app-admin/setools/setools-9999.ebuild
index 13b8cb7389c8..70e0fb4bed29 100644
--- a/app-admin/setools/setools-9999.ebuild
+++ b/app-admin/setools/setools-9999.ebuild
@@ -1,52 +1,46 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
-PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+PYTHON_COMPAT=( python3_5 python3_6 )
inherit distutils-r1
DESCRIPTION="Policy Analysis Tools for SELinux"
-HOMEPAGE="https://github.com/TresysTechnology/setools/wiki"
+HOMEPAGE="https://github.com/SELinuxProject/setools/wiki"
if [[ ${PV} == 9999 ]] ; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/TresysTechnology/setools.git"
+ EGIT_REPO_URI="https://github.com/SELinuxProject/setools.git"
else
- SRC_URI="https://github.com/TresysTechnology/setools/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/SELinuxProject/setools/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~x86"
fi
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-IUSE="X debug test"
+IUSE="X test"
RDEPEND="${PYTHON_DEPS}
- >=sys-libs/libsepol-2.7:=
- >=sys-libs/libselinux-2.7:=[${PYTHON_USEDEP}]
- >=dev-python/networkx-1.8[${PYTHON_USEDEP}]
- virtual/python-enum34[${PYTHON_USEDEP}]
- dev-libs/libpcre:=
+ >=dev-python/networkx-2.0[${PYTHON_USEDEP}]
+ >=sys-libs/libsepol-2.8:=
+ >=sys-libs/libselinux-2.8:=
X? (
dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
)"
DEPEND="${RDEPEND}
- >=dev-lang/swig-2.0.12:0
- sys-devel/bison
- sys-devel/flex
- >=sys-libs/libsepol-2.5
+ >=dev-python/cython-0.27
test? (
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
sys-apps/checkpolicy
)"
python_prepare_all() {
sed -i "s/'-Werror', //" "${S}"/setup.py || die "failed to remove Werror"
- sed -i "s@^base_lib_dirs = .*@base_lib_dirs = ['${ROOT:-/}usr/$(get_libdir)']@g" "${S}"/setup.py || \
- die "failed to set base_lib_dirs"
+ sed -i "s@^lib_dirs = .*@lib_dirs = ['${ROOT:-/}usr/$(get_libdir)']@" "${S}"/setup.py || \
+ die "failed to set lib_dirs"
- use X || local PATCHES=( "${FILESDIR}"/setools-4.1.1-remove-gui.patch )
+ use X || local PATCHES=( "${FILESDIR}"/setools-4.2.0-remove-gui.patch )
distutils-r1_python_prepare_all
}