summaryrefslogtreecommitdiff
path: root/app-admin/sshguard/sshguard-99999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
commitc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (patch)
tree9ea78393bc3ecd6ab4de449383d4e97e5f3648ae /app-admin/sshguard/sshguard-99999.ebuild
parent2891d29af8907ce881662f4a02844926d7a293c7 (diff)
gentoo resync : 12.01.2019
Diffstat (limited to 'app-admin/sshguard/sshguard-99999.ebuild')
-rw-r--r--app-admin/sshguard/sshguard-99999.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-admin/sshguard/sshguard-99999.ebuild b/app-admin/sshguard/sshguard-99999.ebuild
new file mode 100644
index 000000000000..407363556f81
--- /dev/null
+++ b/app-admin/sshguard/sshguard-99999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools git-r3
+
+DESCRIPTION="protects hosts from brute force attacks against ssh"
+HOMEPAGE="https://www.sshguard.net/"
+EGIT_REPO_URI="https://bitbucket.org/${PN}/${PN}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+
+DEPEND="
+ sys-devel/flex
+"
+RDEPEND="
+ virtual/logger
+"
+DOCS=(
+ CHANGELOG.rst
+ CONTRIBUTING.rst
+ README.rst
+ examples/net.sshguard.plist
+ examples/sshguard.service
+ examples/whitelistfile.example
+)
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.1.0-conf.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/${PN}.initd-r1 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+
+ insinto /etc
+ newins examples/sshguard.conf.sample sshguard.conf
+}