summaryrefslogtreecommitdiff
path: root/app-admin/sxid/sxid-4.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-admin/sxid/sxid-4.2-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-admin/sxid/sxid-4.2-r2.ebuild')
-rw-r--r--app-admin/sxid/sxid-4.2-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-admin/sxid/sxid-4.2-r2.ebuild b/app-admin/sxid/sxid-4.2-r2.ebuild
new file mode 100644
index 000000000000..1dd3cef652d9
--- /dev/null
+++ b/app-admin/sxid/sxid-4.2-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="suid, sgid file and directory checking"
+HOMEPAGE="http://freshmeat.net/projects/sxid"
+SRC_URI="http://linukz.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="virtual/mailx"
+
+DOCS=( docs/sxid.{conf,cron}.example )
+
+src_prepare() {
+ default
+ # this is an admin application and really requires root to run correctly
+ # we need to move the binary to the sbin directory
+ sed -i s/bindir/sbindir/g source/Makefile.in || die
+ eautoreconf
+}
+
+pkg_postinst() {
+ elog
+ elog "You will need to configure sxid.conf for your system using the manpage and example"
+ elog
+}