summaryrefslogtreecommitdiff
path: root/app-admin/sxid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/sxid
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/sxid')
-rw-r--r--app-admin/sxid/Manifest3
-rw-r--r--app-admin/sxid/metadata.xml8
-rw-r--r--app-admin/sxid/sxid-4.2-r2.ebuild32
3 files changed, 43 insertions, 0 deletions
diff --git a/app-admin/sxid/Manifest b/app-admin/sxid/Manifest
new file mode 100644
index 000000000000..948d69f8362a
--- /dev/null
+++ b/app-admin/sxid/Manifest
@@ -0,0 +1,3 @@
+DIST sxid-4.2.tar.gz 41827 BLAKE2B c436ffd1b05306508c0ab0e4236cb3968d4456ae0686357a3a2c2a587fdbdaf8e760d5ff8198188c23854b080a91a35fc27a9717ab28f6907deb887a7b455cea SHA512 ed2832a0ffa89a41eba39e116122878b830c46ee7bfb906652606cff61fe16bc28ab6e6b4a802cc2436d9b3a7bdd734a827f007e6f1ce14ca84a9015d3a37a69
+EBUILD sxid-4.2-r2.ebuild 742 BLAKE2B c7614bb1724fca040f2977c4e6df40e15c97f48319128859081d1529bf1fcb70434feaf24b7a20396bd8937476fdb3ff2ee2e82863c818ca7fea54af397133bb SHA512 eef8fc9083ccee3ddf0264510a50803a36a66d50c0ba482ffe2e69407756963cf01314be2e32a432297cbefb22be4a4e4261fce2edb88e269320924dbdd4138e
+MISC metadata.xml 239 BLAKE2B 2c20ec7073e95bd9e1cc847b1e1fa0e79e8f22177834ae4ec3c9f4f6599ef0b626fe6eb76aa8684fe5e6493278a508f3c48552d8184a1da955078848df42a1c6 SHA512 78b96763365234c0639c1b756aad62686435ddb7c52aaa88b2afe19c978eb7cf1e0f5d16ea1f7f394d77491fa6b0d978e42d208f4fa1255d1e265432c4642323
diff --git a/app-admin/sxid/metadata.xml b/app-admin/sxid/metadata.xml
new file mode 100644
index 000000000000..28ab88d96ca0
--- /dev/null
+++ b/app-admin/sxid/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="freshmeat">sxid</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-admin/sxid/sxid-4.2-r2.ebuild b/app-admin/sxid/sxid-4.2-r2.ebuild
new file mode 100644
index 000000000000..5351273bef83
--- /dev/null
+++ b/app-admin/sxid/sxid-4.2-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="suid, sgid file and directory checking"
+HOMEPAGE="http://freshmeat.net/projects/sxid"
+SRC_URI="http://linukz.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+RDEPEND="virtual/mailx"
+
+DOCS=( docs/sxid.{conf,cron}.example )
+
+src_prepare() {
+ default
+ # this is an admin application and really requires root to run correctly
+ # we need to move the binary to the sbin directory
+ sed -i s/bindir/sbindir/g source/Makefile.in || die
+ eautoreconf
+}
+
+pkg_postinst() {
+ elog
+ elog "You will need to configure sxid.conf for your system using the manpage and example"
+ elog
+}