summaryrefslogtreecommitdiff
path: root/app-admin/terraform/terraform-0.11.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /app-admin/terraform/terraform-0.11.12.ebuild
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'app-admin/terraform/terraform-0.11.12.ebuild')
-rw-r--r--app-admin/terraform/terraform-0.11.12.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/app-admin/terraform/terraform-0.11.12.ebuild b/app-admin/terraform/terraform-0.11.12.ebuild
deleted file mode 100644
index a70144a8d83f..000000000000
--- a/app-admin/terraform/terraform-0.11.12.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit golang-vcs-snapshot
-
-DESCRIPTION="A tool for building, changing, and combining infrastructure safely"
-HOMEPAGE="https://www.terraform.io/"
-
-EGO_PN="github.com/hashicorp/${PN}"
-SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND=">=dev-lang/go-1.11.0"
-
-DOCS=( README.md CHANGELOG.md )
-
-src_compile() {
- cd "src/${EGO_PN}" || die
- GOPATH="${S}" GOCACHE="${T}/go-cache" go build \
- -v -work -o "${S}/${PN}" ./ || die
-}
-
-src_install() {
- dobin terraform
-
- pushd "src/${EGO_PN}" >/dev/null || die
- einstalldocs
- popd >/dev/null || die
-}
-
-pkg_postinst() {
- elog "If you would like to install shell completions please run:"
- elog " terraform -install-autocomplete"
-}