summaryrefslogtreecommitdiff
path: root/app-admin/ttyplot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-29 00:57:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-29 00:57:18 +0000
commiteecd75a62239257eb2235bfe8697c73887a9a080 (patch)
tree8c01b16cb32e1a22ad5b8efe32d843c96cfa2ff2 /app-admin/ttyplot
parent7b97d94d4769a556456398d66819200655c4d76c (diff)
gentoo auto-resync : 29:01:2024 - 00:57:18
Diffstat (limited to 'app-admin/ttyplot')
-rw-r--r--app-admin/ttyplot/Manifest1
-rw-r--r--app-admin/ttyplot/ttyplot-1.6.2-r1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-admin/ttyplot/Manifest b/app-admin/ttyplot/Manifest
index 1386dc71e7e3..5450c2add3ac 100644
--- a/app-admin/ttyplot/Manifest
+++ b/app-admin/ttyplot/Manifest
@@ -5,5 +5,6 @@ DIST ttyplot-1.6.2.gh.tar.gz 56277 BLAKE2B c7a818a69774fc7c5f6b498e5bf2f9c3ec644
EBUILD ttyplot-1.5.1.ebuild 543 BLAKE2B 7f9974816705530096921b04c9025de905671b948132b84e41f2779a4f81f449f1472a968352f8a818a172e14dcee98f0d618c237fb7b72b3efe724d5848ca1b SHA512 5b21e285e7ea461d5f83356533c57d565911af06faa4bbcf625fae75d6c096db4442670f88f6058e7a0f0fee6dcd95426b881ea5ca1e666c294dc0e823abf2f6
EBUILD ttyplot-1.5.2.ebuild 543 BLAKE2B 7f9974816705530096921b04c9025de905671b948132b84e41f2779a4f81f449f1472a968352f8a818a172e14dcee98f0d618c237fb7b72b3efe724d5848ca1b SHA512 5b21e285e7ea461d5f83356533c57d565911af06faa4bbcf625fae75d6c096db4442670f88f6058e7a0f0fee6dcd95426b881ea5ca1e666c294dc0e823abf2f6
EBUILD ttyplot-1.6.1.ebuild 570 BLAKE2B 852b23385164024323beae090bb6517db66cb0b13722bc7b20afcc92c46026c6d62e6c9cf96ba33d4d1fb07cf1baeb78dc5562061489656fd2bf416e4f34a520 SHA512 b35b4f2166f6969d80bfbc8c1a848f13c4e5867741745da2702d2695ae788a90f52e1390f62778650b9469d6de66c04993e2a955deb6d19fbf2db174f83dbdad
+EBUILD ttyplot-1.6.2-r1.ebuild 638 BLAKE2B 0bf0671236d6accd015b00a2b3601a26b02eb20a3ff1f11dd71389fa7fc160c48688edad2dbebd5c31a828de0db218bad99eca56ea16287a02d58be4b78051b9 SHA512 80f1e35223cdb0853f1b3346cba05f8aa8582fc6e50676f27c4330ea8d2e0a99aa54b3bd332be824abd0768176f9fed4b959da28308957917a21588fcaed700c
EBUILD ttyplot-1.6.2.ebuild 570 BLAKE2B e50cff61d0168a11dcee01fcc747aaddd96ab0f0dc491e0dbc624c60e7d96419fe8ffd0247fe297fcb00c3e0f44c8a83ec86ed342aad462b71ff59b139e3e447 SHA512 5a4c26a4d1ebca811c084200b8605ffe242f8dceb0d3b1d88f4c46b9e1d65d99aa05775f55b7d91efb7d3997ed90a99520575d03df1810ce88bf4c5a1d46596c
MISC metadata.xml 329 BLAKE2B bd5447e3674a73231ebd7a5bb2a617d00fba46b3cc681954c29f8784001f86e0a3085cf614b5c59b26f0a47300dc01a4f8047f05d57ed898d43c0014ddf33f65 SHA512 a150258d92fc957ab9f70dac4b083afc417493c666de1aa4cba92fbf7b79b6c793790cb97a6c44a9c60c1668e9f28008467451efc0f5ad4dd0b27f6302b238f1
diff --git a/app-admin/ttyplot/ttyplot-1.6.2-r1.ebuild b/app-admin/ttyplot/ttyplot-1.6.2-r1.ebuild
new file mode 100644
index 000000000000..a0e31d253379
--- /dev/null
+++ b/app-admin/ttyplot/ttyplot-1.6.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Realtime plotting utility with data input from stdin"
+HOMEPAGE="https://github.com/tenox7/ttyplot"
+SRC_URI="https://github.com/tenox7/ttyplot/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="virtual/pkgconfig"
+DEPEND="${RDEPEND}
+ sys-libs/ncurses[tinfo]"
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ local args=(
+ PREFIX=/usr
+ MANPREFIX=/usr/share/man
+ DESTDIR="${D}"
+ )
+ emake "${args[@]}" install
+}