summaryrefslogtreecommitdiff
path: root/app-admin/usbview/usbview-2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /app-admin/usbview/usbview-2.2.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'app-admin/usbview/usbview-2.2.ebuild')
-rw-r--r--app-admin/usbview/usbview-2.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-admin/usbview/usbview-2.2.ebuild b/app-admin/usbview/usbview-2.2.ebuild
new file mode 100644
index 000000000000..15b921b80152
--- /dev/null
+++ b/app-admin/usbview/usbview-2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info
+
+DESCRIPTION="Display the topology of devices on the USB bus"
+HOMEPAGE="http://www.kroah.com/linux-usb/ https://github.com/gregkh/usbview"
+SRC_URI="http://www.kroah.com/linux-usb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~hppa ppc ppc64 sparc x86"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/imagemagick-tools[png,svg]
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ CONFIG_CHECK="~DEBUG_FS"
+ linux-info_pkg_setup
+}