summaryrefslogtreecommitdiff
path: root/app-admin/webapp-config/webapp-config-1.54-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
commitd87262dd706fec50cd150aab3e93883b6337466d (patch)
tree246b44c33ad7a57550430b0a60fa0df86a3c9e68 /app-admin/webapp-config/webapp-config-1.54-r2.ebuild
parent71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/webapp-config/webapp-config-1.54-r2.ebuild')
-rw-r--r--app-admin/webapp-config/webapp-config-1.54-r2.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/app-admin/webapp-config/webapp-config-1.54-r2.ebuild b/app-admin/webapp-config/webapp-config-1.54-r2.ebuild
deleted file mode 100644
index d364cbb45113..000000000000
--- a/app-admin/webapp-config/webapp-config-1.54-r2.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
-
-inherit distutils-r1
-
-SRC_URI="https://dev.gentoo.org/~twitch153/${PN}/${P}.tar.bz2"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-
-DESCRIPTION="Gentoo's installer for web-based applications"
-HOMEPAGE="https://sourceforge.net/projects/webapp-config/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="+portage"
-
-DEPEND="app-text/xmlto
- sys-apps/gentoo-functions"
-RDEPEND="portage? ( sys-apps/portage[${PYTHON_USEDEP}] )"
-
-python_prepare() {
- epatch "${FILESDIR}/${P}-pvr-check.patch"\
- "${FILESDIR}/${P}-fix-bashism.patch"
-}
-python_compile_all() {
- emake -C doc/
-}
-
-python_install() {
- # According to this discussion:
- # http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
- # distutils does not provide for specifying two different script install
- # locations. Since we only install one script here the following should
- # be ok
- distutils-r1_python_install --install-scripts="${EPREFIX}/usr/sbin"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- insinto /etc/vhosts
- doins config/webapp-config
-
- keepdir /usr/share/webapps
- keepdir /var/db/webapps
-
- dodoc AUTHORS
- doman doc/*.[58]
- dohtml doc/*.[58].html
-}
-
-python_test() {
- PYTHONPATH="." "${PYTHON}" WebappConfig/tests/external.py \
- || die "Testing failed with ${EPYTHON}"
-}
-
-pkg_postinst() {
- elog "webapp-config now requires that all -I/-U/-C commands be followed"
- elog "by the package name and package version of the webapp"
- elog "eg.) 'webapp-config -d drupal -I drupal 8.0.0_beta10'"
- elog "See 'man 8 webapp-config' for more information"
-}