summaryrefslogtreecommitdiff
path: root/app-antivirus/fangfrisch/fangfrisch-1.5.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-16 08:04:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-16 08:04:03 +0000
commit97f40b36b1afa9726e32962d11f3ac2d0bc5792e (patch)
tree1c7d586bc8a53d3b768630527bb80a477d661fa3 /app-antivirus/fangfrisch/fangfrisch-1.5.0-r1.ebuild
parentb435e036d9775b71048373b91d4c7c3398826858 (diff)
gentoo auto-resync : 16:02:2023 - 08:04:02
Diffstat (limited to 'app-antivirus/fangfrisch/fangfrisch-1.5.0-r1.ebuild')
-rw-r--r--app-antivirus/fangfrisch/fangfrisch-1.5.0-r1.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/app-antivirus/fangfrisch/fangfrisch-1.5.0-r1.ebuild b/app-antivirus/fangfrisch/fangfrisch-1.5.0-r1.ebuild
index 6699e401c1fd..53c0fb8c80fa 100644
--- a/app-antivirus/fangfrisch/fangfrisch-1.5.0-r1.ebuild
+++ b/app-antivirus/fangfrisch/fangfrisch-1.5.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{9,10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1 readme.gentoo-r1 systemd
@@ -38,20 +38,19 @@ LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="amd64 x86"
+# Due to the nature of Fangfrisch, most tests require network
+# connectivity and/or access keys to download signature files.
+PROPERTIES="test_network"
+RESTRICT="test"
+
DEPEND=">=dev-python/requests-2.22.0[${PYTHON_USEDEP}]
>=dev-python/sqlalchemy-1.3.11[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"
+distutils_enable_tests unittest
+
python_prepare_all() {
sed -i -e '/SQLAlchemy/d' setup.py || die
- # Due to the nature of Fangfrisch, most tests require network
- # connectivity and/or access keys to download signature files.
- # Also, my own CI reports show that the tests are successful,
- # so instead of a pick-and-choose approach, the complete tests
- # directory is removed in this ebuild. --RS
- if [ -d tests ]; then
- rm -r tests || die
- fi
distutils-r1_python_prepare_all
}