summaryrefslogtreecommitdiff
path: root/app-antivirus/fangfrisch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /app-antivirus/fangfrisch
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'app-antivirus/fangfrisch')
-rw-r--r--app-antivirus/fangfrisch/Manifest5
-rw-r--r--app-antivirus/fangfrisch/fangfrisch-1.2.0.ebuild64
-rw-r--r--app-antivirus/fangfrisch/files/fangfrisch.conf24
-rw-r--r--app-antivirus/fangfrisch/files/fangfrisch.cron4
-rw-r--r--app-antivirus/fangfrisch/metadata.xml23
5 files changed, 120 insertions, 0 deletions
diff --git a/app-antivirus/fangfrisch/Manifest b/app-antivirus/fangfrisch/Manifest
new file mode 100644
index 000000000000..0b5da88007ed
--- /dev/null
+++ b/app-antivirus/fangfrisch/Manifest
@@ -0,0 +1,5 @@
+AUX fangfrisch.conf 512 BLAKE2B 1b1cd87fbf2095f8d6839fef2175b70cdf1c8d72bcfa8eb06e9abe5e88150f3d4414a64679d775f1fef4378a940334c6c1567f387dbf6ce7f8bb40f6070f31c0 SHA512 e3fff2b24a6bd05a709472e9b7b5416732807171539d31c9f2129e8b7c2ef2b5f047a7090818a2aae77941169030e7785be7a6cded1220f8a130e9e60ea05ce6
+AUX fangfrisch.cron 170 BLAKE2B b2b3572bb468942eecc006749710900bb19e29d40ad444a4b1ee1575f2d4eda77e2b4c66f6ab75208bbb28c48f0d26075b2d0517982cd62d0f082aa657ff82f2 SHA512 46ba3a9bbdc93896387e9ca3a2fef1bbae6711b3680baa0afddf41c83b537e62d9425fe93d7d7befc60dd8a89aa4c70f9947b596594d5ca93024acec1f9bf454
+DIST fangfrisch-1.2.0.tar.gz 113088 BLAKE2B 9fb5f4b838e6337128c9e988f5749864cadacb74c9e3006f29cf8b976592af88c00ff5359cd70e4d6901e24cfc01b061861b7b1a563a82d66b2d71c970627c26 SHA512 6f6c0cfc4d840f99186c83e6109c6234ff5bfb44e19bcd3309056347392e46da56e17106259508864b05397d39ea92500ab6863b50d55efc790d88b59f88ee3b
+EBUILD fangfrisch-1.2.0.ebuild 1721 BLAKE2B b3032f4ca1b2622ef4c177bd6bedd1ed127cca6f67581517f944a5523a42b2b70730b7fb9e852815ca8fe8677516687b68a04612f900e30f7c1a5af92aa6bca9 SHA512 9c9c5d2d8b294bf25dfdfa10588848620a9e594090152a22d8f35b526f8387c4b88a5ab1a69bef4f787f4b5da9e4669c07afa63d913bcf4e822581b1ebb8ab89
+MISC metadata.xml 863 BLAKE2B f3324a0adbcf5979af8daf27906630edb5d6ae78cf74ef1abd7610297587a382981658381d22b8af6233f543b02903733d1dce13df27faa4c6eb243cc164b243 SHA512 b11935bd73f1d405292dbd80456380dcc1b390015158cbacb1023b12f755d41c2af656514ec1fc9e307752706166fa96651fdebc626f1e0e4134e0a0a9d01f82
diff --git a/app-antivirus/fangfrisch/fangfrisch-1.2.0.ebuild b/app-antivirus/fangfrisch/fangfrisch-1.2.0.ebuild
new file mode 100644
index 000000000000..96c6bbfecc59
--- /dev/null
+++ b/app-antivirus/fangfrisch/fangfrisch-1.2.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Update and verify unofficial Clam Anti-Virus signatures"
+HOMEPAGE="https://github.com/rseichter/fangfrisch https://pypi.org/project/fangfrisch/"
+SRC_URI="https://github.com/rseichter/fangfrisch/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+MY_CONF="/etc/${PN}.conf"
+MY_DBDIR="/var/lib/${PN}"
+DISABLE_AUTOFORMATTING=1
+DOC_CONTENTS="See https://rseichter.github.io/fangfrisch/ for the official
+documentation.
+
+### Fresh installations:
+
+Modify ${MY_CONF} according to your preferences.
+Assuming you place the database into ${MY_DBDIR}
+(recommended), execute the following commands in a root shell:
+
+mkdir -m 0770 ${MY_DBDIR}
+chgrp clamav ${MY_DBDIR}
+sudo -u clamav -- fangfrisch -c ${MY_CONF} initdb
+
+You can now enable /etc/cron.d/${PN} for periodic updates.
+
+### Alternative: Updating from release 1.0.1:
+
+Either create a fresh database or manually delete all existing
+database tables, then run the initdb command as shown above."
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=dev-python/requests-2.22.0[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.3.11[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ sed -i -e '/SQLAlchemy/d' setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ insinto /etc
+ doins "${FILESDIR}/${PN}.conf"
+ insinto /etc/cron.d
+ newins "${FILESDIR}/${PN}.cron" ${PN}
+ distutils-r1_python_install_all
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ FORCE_PRINT_ELOG=1 readme.gentoo_print_elog
+}
diff --git a/app-antivirus/fangfrisch/files/fangfrisch.conf b/app-antivirus/fangfrisch/files/fangfrisch.conf
new file mode 100644
index 000000000000..ded86b9cc981
--- /dev/null
+++ b/app-antivirus/fangfrisch/files/fangfrisch.conf
@@ -0,0 +1,24 @@
+# See https://rseichter.github.io/fangfrisch/ for detailed documentation
+
+[DEFAULT]
+db_url = sqlite:////var/lib/fangfrisch/db.sqlite
+local_directory = /var/lib/clamav
+log_method = syslog
+log_target = /dev/log
+on_update_exec = clamdscan --reload
+
+[malwarepatrol]
+enabled = yes
+# Replace with your personal Malwarepatrol receipt
+receipt = abcd1234
+
+[sanesecurity]
+enabled = yes
+
+[securiteinfo]
+enabled = yes
+# Replace with your personal SecuriteInfo customer ID
+customer_id = abcdef123456
+
+[urlhaus]
+enabled = yes
diff --git a/app-antivirus/fangfrisch/files/fangfrisch.cron b/app-antivirus/fangfrisch/files/fangfrisch.cron
new file mode 100644
index 000000000000..55595c8e20c1
--- /dev/null
+++ b/app-antivirus/fangfrisch/files/fangfrisch.cron
@@ -0,0 +1,4 @@
+# HOME=/var/lib/fangfrisch
+# LOG_LEVEL=WARNING
+# minute hour day-of-month month day-of-week user command
+# */10 * * * * clamav fangfrisch -c /etc/fangfrisch.conf refresh
diff --git a/app-antivirus/fangfrisch/metadata.xml b/app-antivirus/fangfrisch/metadata.xml
new file mode 100644
index 000000000000..86c7e98f50ea
--- /dev/null
+++ b/app-antivirus/fangfrisch/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@seichter.de</email>
+ <name>Ralph Seichter</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>dilfridge@gentoo.org</email>
+ <name>Andreas K. Huettel</name>
+ </maintainer>
+ <longdescription lang="en">
+ Fangfrisch (German for "freshly caught") is a sibling of the
+ Clam Anti-Virus freshclam utility. It allows downloading virus
+ definition files that are not official ClamAV canon, e.g. from
+ Sanesecurity, URLhaus and others. Fangfrisch was designed with
+ security in mind, to be run by an unprivileged user only.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">rseichter/fangfrisch</remote-id>
+ <remote-id type="pypi">fangfrisch</remote-id>
+ </upstream>
+</pkgmetadata>