summaryrefslogtreecommitdiff
path: root/app-arch/alien/alien-8.95.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-arch/alien/alien-8.95.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-arch/alien/alien-8.95.ebuild')
-rw-r--r--app-arch/alien/alien-8.95.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-arch/alien/alien-8.95.ebuild b/app-arch/alien/alien-8.95.ebuild
new file mode 100644
index 000000000000..e692f8eac638
--- /dev/null
+++ b/app-arch/alien/alien-8.95.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="Converts between the rpm, dpkg, stampede slp, and slackware tgz file formats"
+HOMEPAGE="http://kitenet.net/programs/alien"
+SRC_URI="mirror://debian/pool/main/a/${PN}/${PN}_${PV}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc ppc64 x86"
+IUSE="+bzip2"
+
+RDEPEND="
+ app-arch/rpm
+ app-arch/dpkg
+ dev-util/debhelper
+ >=app-arch/tar-1.14.91
+ bzip2? (
+ app-arch/bzip2
+ )"
+
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -e s%'$(VARPREFIX)'%${D}% -e s%'$(PREFIX)'%${D}/usr%g \
+ -i "${S}"/Makefile.PL || die "sed failed."
+}