summaryrefslogtreecommitdiff
path: root/app-arch/atool
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /app-arch/atool
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'app-arch/atool')
-rw-r--r--app-arch/atool/Manifest3
-rw-r--r--app-arch/atool/atool-0.39.0-r1.ebuild15
-rw-r--r--app-arch/atool/files/atool-0.39.0-configure-bashism.patch12
3 files changed, 28 insertions, 2 deletions
diff --git a/app-arch/atool/Manifest b/app-arch/atool/Manifest
index e8e9f02cb1e3..222f2a4ea371 100644
--- a/app-arch/atool/Manifest
+++ b/app-arch/atool/Manifest
@@ -1,3 +1,4 @@
+AUX atool-0.39.0-configure-bashism.patch 365 BLAKE2B 677ab0da286c462adf41b8b58d007dee8e3fe874a7ff34a652e1c16160186c9e633d77901d943f18edaec23ec92356c4b09eca41f0e0d7eb9f92055e580d3400 SHA512 f99d333339f605a3c6f0373984b107925b764ff6843d2b8b9c96e50bb3b368812acaf9a56d1f3db2dcdfff0b3ba2d9a9301312d3e4dd0a2dc3ffec3086b1b9e0
DIST atool-0.39.0.tar.gz 119307 BLAKE2B 770da3764a75d29472ce052c568ff534b88a394ef022c91678693e2eeaad1613343dcbda907346e2ac83eb4e6c164bc8e7a07b3edbad919e7cacb3846221eb90 SHA512 2011c13f510a140e71d26f9eac60d07f2cb9004dc278303fd37c5c7f78a6a2366ad9193e7b4e015d9fba8218c59205a6339189ae4775b0afc42328f9607524d3
-EBUILD atool-0.39.0-r1.ebuild 397 BLAKE2B 2f135263b9377ca21f8405695607667edcc7973155bf7417a1a389590b6e0259d40b3e664ece0fb3329cd83b06183bef09e0e0a6cc4eb4cfb99aa037b09865ff SHA512 4fedacf094bd90bb79cc0731eac449867fa6c59a8fdf6e7f42d15937a508136b1d1411f9a2508087fb9955f586616d4cb79a4c4ecd7c146639c55e07e294bf91
+EBUILD atool-0.39.0-r1.ebuild 555 BLAKE2B f51081d65c029402338ffff8e8dece46d8a654e8ff359a1beaf92bbaf4fbebc6fb80668ea5f41d2c1ad037d3edd2fcc7cb1cdcb65adc8e6726b7e8c9212b62f0 SHA512 b41c2d8aa299f1ebb45890845a7241450d68e32bb752805abed69b59f33cb5ce13bd3864db49650fd1681dee54fcf6f968a0a504133851461b0de0d16cd9655b
MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-arch/atool/atool-0.39.0-r1.ebuild b/app-arch/atool/atool-0.39.0-r1.ebuild
index 4ab3fb6b4aec..b5a2d655b278 100644
--- a/app-arch/atool/atool-0.39.0-r1.ebuild
+++ b/app-arch/atool/atool-0.39.0-r1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit autotools
+
DESCRIPTION="Script for managing file archives of various types"
HOMEPAGE="https://www.nongnu.org/atool/"
SRC_URI="https://savannah.nongnu.org/download/${PN}/${P}.tar.gz"
@@ -14,3 +16,14 @@ KEYWORDS="amd64 ppc x86"
DEPEND="dev-lang/perl"
RDEPEND="${DEPEND}
!app-text/adiff"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.39.0-configure-bashism.patch
+)
+
+src_prepare() {
+ default
+
+ # Needed for the bashism patch
+ eautoreconf
+}
diff --git a/app-arch/atool/files/atool-0.39.0-configure-bashism.patch b/app-arch/atool/files/atool-0.39.0-configure-bashism.patch
new file mode 100644
index 000000000000..512bdc02ee9f
--- /dev/null
+++ b/app-arch/atool/files/atool-0.39.0-configure-bashism.patch
@@ -0,0 +1,12 @@
+https://bugs.gentoo.org/775158
+--- a/configure.ac
++++ b/configure.ac
+@@ -11,7 +11,7 @@ AC_DEFINE_DIR(LOCALSTATEDIR, localstatedir)
+ dnl Perl stuff
+ AC_PATH_PROG([PERL], [perl])
+ eval `$PERL -V:startperl`
+-if test "${startperl:0:1}" = "#" ; then
++if test "$(printf %.1s "$startperl")" = "#" ; then
+ startperl="\\$startperl"
+ fi
+ AC_SUBST(PERL_SHEBANG, $startperl)