summaryrefslogtreecommitdiff
path: root/app-arch/brotli/brotli-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
commit62f67115b5c46134c34f88f4b1cbdacc19384c0a (patch)
tree0a76b14de203a4c23040e5665e39df8de9867745 /app-arch/brotli/brotli-9999.ebuild
parent265dbe5dbc14c199299496c6db8fce3f76647015 (diff)
gentoo resync : 30.09.2018
Diffstat (limited to 'app-arch/brotli/brotli-9999.ebuild')
-rw-r--r--app-arch/brotli/brotli-9999.ebuild26
1 files changed, 19 insertions, 7 deletions
diff --git a/app-arch/brotli/brotli-9999.ebuild b/app-arch/brotli/brotli-9999.ebuild
index d6d1f9946eb2..72733671f1db 100644
--- a/app-arch/brotli/brotli-9999.ebuild
+++ b/app-arch/brotli/brotli-9999.ebuild
@@ -1,12 +1,13 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy )
DISTUTILS_OPTIONAL="1"
+DISTUTILS_IN_SOURCE_BUILD="1"
-inherit cmake-utils distutils-r1 eapi7-ver
+inherit cmake-multilib distutils-r1 eapi7-ver
DESCRIPTION="Generic-purpose lossless compression algorithm"
HOMEPAGE="https://github.com/google/brotli"
@@ -33,21 +34,27 @@ else
fi
src_prepare() {
- cmake-utils_src_prepare
use python && distutils-r1_src_prepare
+ cmake-utils_src_prepare
}
-src_configure() {
+multilib_src_configure() {
local mycmakeargs=(
-DBUILD_SHARED_LIBS=ON
-DBUILD_TESTING="$(usex test)"
)
cmake-utils_src_configure
+}
+src_configure() {
+ cmake-multilib_src_configure
use python && distutils-r1_src_configure
}
-src_compile() {
+multilib_src_compile() {
cmake-utils_src_compile
+}
+src_compile() {
+ cmake-multilib_src_compile
use python && distutils-r1_src_compile
}
@@ -55,12 +62,17 @@ python_test(){
esetup.py test || die
}
-src_test() {
+multilib_src_test() {
cmake-utils_src_test
+}
+src_test() {
+ cmake-multilib_src_test
use python && distutils-r1_src_test
}
-src_install() {
+multilib_src_install() {
cmake-utils_src_install
+}
+multilib_src_install_all() {
use python && distutils-r1_src_install
}